在线检测未来函数

飞狐交易护驾指标公式

来源:Internet,编辑:股旁网,2015-11-20

DRAWGBK((DATE > 0),COLORRGB(0,33,0),COLORRGB(0,33,0),1);
Z_1:=C-REF(C,1);
空头:EMA(EMA(Z_1,6),6)/EMA(EMA(ABS(Z_1),6),6)*20,LINETHICK,PRECISION2,Color00FF00;
多头:(空头*2-FORCAST(空头,9)),LINETHICK,PRECISION2,ColorFF59FF;
{警报}
RSV:=(C-LLV(L,3))/(HHV(H,3)-LLV(L,3))*100;
K:=SMA(RSV,2,1);
D:=SMA(K,2,1);
J:=3*K-2*D;
引力:SMA(J,2,1)-SMA(J,3,1),LINETHICK,PRECISION2,COLORGRAY;
Jj_1:=VALUEWHEN(多头<=空头,多头);
Jj_2:=VALUEWHEN(多头>空头,空头);
K1:=IF(多头>空头,1,IF(多头<空头,-1,0));
K2:=VALUEWHEN(K1<>0,K1);
警报:IF(K2>0,Jj_1,Jj_2),LINETHICK,PRECISION2,Color00B4FF;
{近台比}
Jt_b1:=(O+L+H+C*3)/6;
Jt_b2:=REVERSE(Jt_b1)+2*WMA(Jt_b1,5);
Jt_b3:=3*Jt_b2-2*SMA(Jt_b2,2,1);
Jt_b4:=VALUEWHEN(BARSLAST(C>Jt_b3),Jt_b3);
Jt_b5:=VALUEWHEN(BARSLAST(C<=Jt_b3),Jt_b3);
Jt_b6:=IF(C<=Jt_b3,Jt_b4,Jt_b5);
近台比:=(C-Jt_b6)/Jt_b6*100;
A5:=近台比[SYSPARAM(1)];
RA5:=近台比[SYSPARAM(1)-1];
jt5:=if(A5>RA5,'↑','↓');
PARTLINE(C,警报),Color00B4FF;
FILLRGN(空头>多头,空头,多头),Color005800;
FILLRGN(空头<=多头,空头,多头),Color000078;
引力,PRECISION2,COLORSTICK,COLORBLACK;
{画各线}
PARTLINE(C,空头),Color00FF00;
PARTLINE(C,多头),ColorFF59FF;
DRAWTEXTEX(C,1,872,0,'近台比: '+NUMTOSTR(近台比[SYSPARAM(1)],2)+jt5),COLORYELLOW;

飞狐交易护驾指标公式

 

相关文章