在线检测未来函数

通达信换手率加MACD双背离指标公式

来源:Internet,编辑:股旁网,2015-11-20

A1:=IF(RANGE(FROMOPEN,0,61),VOL/CAPITAL*100*60/FROMOPEN,DRAWNULL);
A2:=IF(RANGE(FROMOPEN,60,121),VOL/CAPITAL*100*120/FROMOPEN,A1);
A3:=IF(RANGE(FROMOPEN,120,181),VOL/CAPITAL*100*180/FROMOPEN,A2);
A4:=IF(RANGE(FROMOPEN,180,241),VOL/CAPITAL*100*240/FROMOPEN,A3);
A5:=IF(ISLASTBAR&&PERIOD=5,VOL/CAPITAL*100*240/FROMOPEN,DRAWNULL);
预测:IF(ISLASTBAR&&PERIOD=4,A4,A5),COLORRED;
STICKLINE(ISLASTBAR,预测,0,-1,-1),COLORGREEN;
J10:=O>REF(C,1) AND C<O;{今日高开低走}
J15:=V/REF(MA(V,13),1);
J20:=J15>5;
DRAWNUMBER(J10 AND J20,HSL*1.1,J15);
换手:100*DYNAINFO(37),VOLSTICK,NODRAW;
十换手:SUM(换手,10),NODRAW;
廿换手:SUM(换手,20),COLORFF6EC7,NODRAW;
获利比:WINNER(C)*100,COLOR0080FF,NODRAW;
量比:V/(REF(MA(V,5),1)),LINETHICK0,COLORRED,NODRAW;
P1:=HSL<=1;
P2:=HSL>1 AND HSL<=3;
P3:=HSL>3 AND HSL<=5;
P4:=HSL>5 AND HSL<=10;
P5:=HSL>10;
STICKLINE(P1,0,HSL,2.0,0),COLOR808080;
STICKLINE(P2,0,1,2.0,0),COLOR808080;
STICKLINE(P2,1,HSL,2.0,0),COLOR008000;
STICKLINE(P3,0,1,2.0,0),COLOR808080;
STICKLINE(P3,1,3,2.0,0),COLOR008000;
STICKLINE(P3,3,HSL,2.0,0),COLOR0080FF;
STICKLINE(P4,0,1,2.0,0),COLOR808080;
STICKLINE(P4,1,3,2.0,0),COLOR008000;
STICKLINE(P4,3,5,2.0,0),COLOR0080FF;
STICKLINE(P4,5,HSL,2.0,0),COLOR0000FF;
STICKLINE(P5,0,1,2.0,0),COLOR808080;
STICKLINE(P5,1,3,2.0,0),COLOR008000;
STICKLINE(P5,3,5,2.0,0),COLOR0080FF;
STICKLINE(P5,5,10,2.0,0),COLOR0000FF;
STICKLINE(P5,10,HSL,2.0,0),COLORGREEN;
M5:MA(HSL,5),COLORWHITE;
M10:MA(HSL,10),COLORYELLOW;
M20:MA(HSL,20),COLORFF00FF;
DRAWICON(换手>25,换手,15);
DRAWTEXT_FIX(ISLASTBAR,0.20,0,0,'★换手率>3红柱!!'),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0.30,0,0,'★换手率>10绿柱!!'),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR,0.40,0,0,'★换手率>25锁定盈利!!'),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.52,0,0,'★股价低位红柱绿柱进货!!'),COLORFFFF00;
DRAWTEXT_FIX(ISLASTBAR,0.66,0,0,'★股价高位绿柱拉高出货!!'),COLORMAGENTA;
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
QZQ:=BARSLAST(REF(MACD,1)<0 AND MACD>0);
QM:=LLVBARS(MACD,QZQ+20);
MQDZ:=IF(QM>QZQ,REF(MACD,QM),0);
QF:=LLVBARS(DIFF,QZQ+20);
DQDZ:=IF(QF>QZQ,REF(DIFF,QF),0);
XG1:=MACD<0 AND MACD>MQDZ AND DIFF<0 AND DIFF>DQDZ
AND CLOSE=LLV(CLOSE,QZQ+20) AND MQDZ<0 AND DQDZ<0;
MACD双背离:REF(XG1,1)=1 AND MACD>REF(MACD,1),LINETHICK2,COLORYELLOW,NODRAW;
DRAWICON(MACD双背离,HSL,26);
{换手率解盘}
FJ1:=1;
FJ2:=2;
FJ3:=3;
FJ4:=5;
FJ5:=8;
FJ6:=15;
FJ7:=25;
HS:=DYNAINFO(37)*100,LINETHICK2,COLORYELLOW;
DRAWTEXT_FIX(HS<FJ1 AND ISLASTBAR,0,0.0,0, '-----地量,小心变盘-----')COLORBROWN;
DRAWTEXT_FIX(HS<FJ2 AND HS>=FJ1 AND ISLASTBAR,0,0.0,0, '-----低靡,无人问津不参与-----'),COLORC080FF;
DRAWTEXT_FIX(HS<FJ3 AND HS>=FJ2 AND ISLASTBAR,0,0.0,0, '-----温和,价量齐升可跟进-----')COLOR0080FF;
DRAWTEXT_FIX(HS<FJ4 AND HS>=FJ3 AND ISLASTBAR,0,0.0,0, '-----活跃,可关注-----')COLORFFFF00;
DRAWTEXT_FIX(HS<FJ5 AND HS>=FJ4 AND ISLASTBAR,0,0.0,0, '-----带量,带量上攻可跟进-----'),COLORGREEN;
DRAWTEXT_FIX(HS<FJ6 AND HS>=FJ5 AND ISLASTBAR,0,0.0,0, '-----放量,低位则进高位出-----'),COLORMAGENTA;
DRAWTEXT_FIX(HS<FJ7 AND HS>=FJ6 AND ISLASTBAR,0,0.0,0, '-----巨量,如在高位请小心-----'),COLORYELLOW;
DRAWTEXT_FIX(HS<100 AND HS>=FJ7 AND ISLASTBAR,0,0.0,0, '-----怪异,如在高位请小心-----'),COLORRED;
DRAWTEXT_FIX(1,0,0.15,0, '解盘说明:'),COLORWHITE;
DRAWTEXT_FIX(1,0.05,0.15,0, '①地量(超级冷门股) 0-1')COLORBROWN;
DRAWTEXT_FIX(1,0.17,0.15,0, '②低糜(冷门) 1-2 '),COLORC080FF;
DRAWTEXT_FIX(1,0.26,0.15,0, '③温和(热身股) 2-3 ')COLOR0080FF;
DRAWTEXT_FIX(1,0.36,0.15,0, '④活跃(活跃) 3-5')COLORFFFF00;
DRAWTEXT_FIX(1,0.45,0.15,0, '⑤带量(高度活跃) 5-8 '),COLORGREEN;
DRAWTEXT_FIX(1,0.56,0.15,0, '⑥放量(热门股) 8-15 '),COLORMAGENTA;
DRAWTEXT_FIX(1,0.665,0.15,0, '⑦巨量(超级热门股)15- 25 '),COLORYELLOW;
DRAWTEXT_FIX(1,0.795,0.15,0, '⑧怪异 25-100 '),COLORRED;

通达信换手率加MACD双背离指标公式

 

相关文章