在线检测未来函数

通达信MACD波段风暴指标公式

来源:Internet,编辑:股旁网,2015-11-23

0,COLORWHITE;
DIFF:=EMA(CLOSE,21)-EMA(CLOSE,34);
DEAA:=EMA(DIFF,8);
MACDD:=3.8*(DIFF-DEAA);
MARDD:=SMA(MACDD,2,1);
STICKLINE(MACDD>MARDD,MACDD,MARDD,3.5,0),COLORMAGENTA;
STICKLINE(MACDD<MARDD,MACDD,MARDD,3.5,0),COLORGREEN;
MACD2:=2*("MACD.DIF"-"MACD.DEA");
STICKLINE(MACD2>=0,0,MACD2,0.5,0),COLORYELLOW;
STICKLINE(MACD2>=0 AND MACD2<REF(MACD2,1),0,MACD2,0.5,0),COLORLIBLUE;
STICKLINE(MACD2<0,0,MACD2,0.5,0),COLORLIBLUE;
STICKLINE(MACD2<0 AND MACD2>REF(MACD2,1),0,MACD2,0.5,0),COLORYELLOW;
DIF:EMA(CLOSE,12)-EMA(CLOSE,26)COLORRED,LINETHICK2;
DEA:EMA(DIF,9)COLORBLUE,LINETHICK2;
DRAWTEXT(ISLASTBAR,DIF,' ←DIF'),COLORRED;
DRAWTEXT(ISLASTBAR,DEA,' ←DEA'),COLORBLUE;
JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
DRAWICON(二次金叉,DEA*0.5,41) ;
DRAWTEXT(二次金叉,DEA*0.5,' 二次金叉'),COLORWHITE;
A1:=BARSLAST(REF(CROSS(DIF,DEA),1));
背离:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA);
DRAWTEXT(底背离,DIF*1,' 底背离'),COLORRED;
DRAWICON(底背离,DIF*1,38);
A2:=BARSLAST(REF(CROSS(DEA,DIF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIF,A2+1)>DIF AND CROSS(DEA,DIF);
DRAWTEXT(顶背离,DIF*1,' 顶背离'),COLORLIBLUE;
DRAWICON(顶背离,DIF*1,39);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9));
K:SMA(RSV,9,3),NODRAW;
D:SMA(K,9,3),NODRAW;
J:3*K-2*D,NODRAW;
A:=CROSS(DIF,DEA) AND CROSS(K,D) AND CROSS(J,D);
DRAWICON(A,DEA*1.2,25);
DRAWTEXT(A,DEA*1.2,' MACD&KDJ共振'),COLORWHITE;

通达信MACD波段风暴指标公式

 

相关文章