在线检测未来函数

通达信结晶主图指标公式

来源:Internet,编辑:股旁网,2015-11-24

{智能辅助线主图}
HHJSJDA:=(3*CLOSE+OPEN+LOW+HIGH)/6;
HHJSJDB:(20*HHJSJDA+19*REF(HHJSJDA,1)+18*REF(HHJSJDA,2)+17*REF(HHJSJDA,3)+16*REF(HHJSJDA,4)+15*REF(HHJSJDA,5)+14*REF(HHJSJDA,6)
+13*REF(HHJSJDA,7)+12*REF(HHJSJDA,8)+11*REF(HHJSJDA,9)+10*REF(HHJSJDA,10)+9*REF(HHJSJDA,11)+8*REF(HHJSJDA,12)
+7*REF(HHJSJDA,13)+6*REF(HHJSJDA,14)+5*REF(HHJSJDA,15)+4*REF(HHJSJDA,16)+3*REF(HHJSJDA,17)+2*REF(HHJSJDA,18)+
REF(HHJSJDA,20))/210,COLORYELLOW;
HHJSJDC:MA(HHJSJDB,5),COLORRED;
SBL:= STRCAT(STRCAT(STRCAT(HYBLOCK,DYBLOCK),GNBLOCK),ZDBLOCK);
DRAWTEXT_FIX(1,0.77,0,0,SBL),COLORYELLOW;
AA:=C/REF(C,1)>1.098;
STICKLINE (AA,C,O,3,0),COLORMAGENTA;
BB:=BARSLAST(AA);
ZG:=HHV(H,BB);
ZD:=REF(L,BB);
ZCW:=(ZD-ZG)*0.25+ZD;
TJCL:=O>ZCW AND L<ZCW AND BB<10;
DRAWTEXT (TJCL,ZCW,'-----------------');
{均线508}
V52:=EMA(CLOSE,1);
主线12:=EMA(V52,5) ;
本12:=EMA(HHV(主线12,5),1);
急进12:=EMA(HHV(本12,5),1);
稳健12:=EMA(HHV(急进12,5),2);
飞天508:EMA(HHV(稳健12,5),3),LINETHICK2,COLORGREEN;
{满仓}
MA2:=EMA(C,2);
MA5:=EMA(C,5);
EMA13:=EMA(C,13);
EMA30:=EMA(C,30);
YCX:=MA5>=REF(MA5,1);
H5:=MAX(MAX(MA5,EMA13),EMA30);
L5:=MIN(MIN(MA5,EMA13),EMA30);
一阳穿三线:= H5<C AND O<L5 AND YCX AND MA2>REF(MA2,1);
DRAWTEXT(一阳穿三线,LOW*0.95,'↑满'),COLORFFFF00;
{青云}
AA05:=MA(C,5);
五日乖离率:=(C-AA05)/AA05*100;
AA30:=MA(C,30);
三拾日乖离率:=(C-AA30)/AA30*100;
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;
DRAWTEXT(FILTER(MR,10),LOW*0.93,'↑青云'),COLOR00FFFF;
{股市行}
MA21:MA(C,21),NODRAW;
EMA5:MA(C,5)COLORGREEN,NODRAW;
大牛:=CROSS(EMA5,MA21);
死牛:=CROSS(MA21,EMA5);
DRAWTEXT(大牛,L,'↖行'),COLORFF00FF,LINETHICK4;
STICKLINE(CROSS(EMA5,MA21),OPEN,CLOSE,3,0),COLOR00FFFF;
{买卖线}
买线:=EMA(CLOSE,2);
卖线:=EMA(SLOPE(CLOSE,32)*20+CLOSE,56),LINETHICK0;
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
DRAWTEXT (BU,LOW*0.989,'点'),COLORYELLOW,LINETHICK3;
STICKLINE(CROSS(买线,卖线),OPEN,CLOSE,2,0),COLORYELLOW;
{绝密买点笑脸主图}
A11:EMA(C,3),NODRAW;
A2:EMA(C,5),NODRAW;
A3:EMA(C,7),NODRAW;
A4:EMA(C,12),NODRAW;
A5:EMA(C,20),NODRAW;
A6:EMA(C,50),NODRAW;
SS:=CROSS(A11,A5) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018 ;
SSS:=CROSS(A11,A5) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018;
DRAWICON(SS ,H+0.25,5);
{次趋势主图}
R1:=(C+L+H)/3;
R2:=EMA(R1,8);
R3:=EMA(R2,5);
次趋势:EMA(R3,13)COLORLIMAGENTA,LINETHICK2;
{MACD局部}
DXJP:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,21)-LLV(LOW,34))*100;
FSZX:=(EMA(DXJP,3)-50)*2,COLORGRAY;
BGTYU:=IF(DATE<=1150530,1,0);
GHYJKU:=BETWEEN((DCLOSE*BGTYU)/(SUM(AMOUNT,BARSCOUNT((DCLOSE*BGTYU)))/SUM(VOL*100,BARSCOUNT((DCLOSE*BGTYU)))),1.05,0.95);
VBNH:=IF(GHYJKU=0,MA((DCLOSE*BGTYU),BARSCOUNT((DCLOSE*BGTYU))),(SUM(AMOUNT,BARSCOUNT((DCLOSE*BGTYU)))/SUM(VOL*100,BARSCOUNT((DCLOSE*BGTYU)))));
DRAWICON(FSZX<=-95,C,38);
DRAWTEXT(CROSS(EXPMA((DCLOSE/VBNH),20),1.04),C,'板'),COLORCYAN;
DRAWTEXT(CROSS(EXPMA((DCLOSE/VBNH),20),1.05),C,'追'),COLORYELLOW;
{暗渡陈仓主}
C1:=REF(C,1);
C2:=REF(C,2);
C3:=REF(C,3);
C4:=REF(C,4);
C5:=REF(C,5);
C6:=REF(C,6);
O1:=REF(O,1);
O2:=REF(O,2);
O3:=REF(O,3);
O4:=REF(O,4);
MA52:MA(C,5),NODRAW;
MA10:MA(C,10),NODRAW;
MA20:MA(C,20),NODRAW;
P11:=C2<=C3 AND C2<=C4 AND C2<=C5 AND C2<=C6;
P22:=C>MA(C,5) AND C>MA(C,10) AND C>MA(C,20);
P33:=C>O AND C1>C2;
P44:=C>C1;
{以下为基本面}
CAP1:=CAPITAL>=8000 AND CAPITAL<=5000000;{流通盘在8000万股到5亿股}
S:=IF(NAMELIKE('S'),1,0)=0;{非S}
ST:=IF(NAMELIKE('ST'),1,0)=0;{非ST}
SST:=IF(NAMELIKE('*S'),1,0)=0;{非*S}
停牌:=IF((C=0 OR V=0),0,1);
PE:=C/FINANCE(33);
SYL:=PE>0;{市盈率为正}
JBM:=S AND ST AND SST AND 停牌 AND SYL;
P:=P11 AND P22 AND P33 AND P44 AND JBM AND C1/C2<=1.05;
{画烟雨阳彩柱}
STICKLINE(P,O,O+0.382*(C-O),3,0),COLORYELLOW;
STICKLINE(P,O+0.382*(C-O),C,3,0),COLORRED;
DRAWTEXT(P,LOW*0.91,'↑暗仓'),COLORWHITE;
{狙杀主图主图}
MA6:MA(C,6),COLORWHITE,LINETHICK2,NODRAW;
MA18:MA(C,18),COLOR0099FF,LINETHICK2,NODRAW;
MA55:MA(C,55),COLORFF00FF,NODRAW;
MA125:MA(C,125),COLORFFCC66,NODRAW;
MA250:MA(C,250),COLORBLUE,NODRAW;
TY:=C;
A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10); C11:=BACKSET(B1,10+1); HD:=FILTER(C11,10);
A21:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A21,10); C23:=BACKSET(B2,10+1); LD:=FILTER(C23,10);
A:=REF(C,BARSLAST(HD)); B:=REF(C,BARSLAST(LD));
T1:=BARSLAST(HD)<BARSLAST(LD) AND NOT(HD) ;
T2:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD);
波峰:IF(T1,A,A),COLORFF00FF,POINTDOT;
STICKLINE(T1,A,A,9,0),COLORFF00FF;
波谷:IF(T2,B,B),COLOR80FF00,POINTDOT;
STICKLINE(T2,B,B,9,0),COLOR80FF00;
买进价:=((C-REF(MA6,1))/6+MA6)*1.004;
买进条件:=CROSS(C,买进价) AND 买进价>REF(买进价,1);
白K买进:IF(买进条件,L,H),COLORWHITE,POINTDOT;
DRAWTEXT(买进条件,LOW*0.95,'↑买'),COLORWHITE;
加码价:=((C-REF(MA18,1))/18+MA18)*1.004;
加码条件:=CROSS(C,加码价) AND 加码价>REF(加码价,1);
黄K加码:IF(加码条件,L,H),COLORYELLOW,POINTDOT;
DRAWTEXT(加码条件,LOW*0.99,'↑加'),COLORWHITE;

通达信结晶主图指标公式

 

相关文章