在线检测未来函数

同花顺趋势涨停买卖指标公式

来源:Internet,编辑:股旁网,2015-11-26

VAR1:=(HIGH+LOW+OPEN+CLOSE)/4;
黄金线:EMA(3*VAR1-2*SMA(VAR1,2,1),13);
CJ:=(3*C+L+O+H)/6;
多空线:(20*CJ+19*REF(CJ,1)+18*REF(CJ,2)+17*REF(CJ,3)+16*REF(CJ,4)+15*REF(CJ,5)+14*REF(CJ,6)+13*REF(CJ,7)+12*REF(CJ,8)+11*REF(CJ,9)+10*REF(CJ,10)+9*REF(CJ,11)+8*REF(CJ,12)+7*REF(CJ,13)+6*REF(CJ,14)+5*REF(CJ,15)+4*REF(CJ,16)+3*REF(CJ,17)+2*REF(CJ,18)+REF(CJ,19))/210;
亚当:=((HIGH + LOW + CLOSE)/3-MA((HIGH + LOW + CLOSE)/3,14))*100/(1.5*AVEDEV((HIGH + LOW + CLOSE)/3,14));
N:=12;
夏娃:=EMA(亚当,N); X2:=亚当; X3:=夏娃;
STICKLINE(X2>=X3,LOW,HIGH,0.1,0),colorred;
STICKLINE(X2>=X3,CLOSE,OPEN,4.5,0),COLOR0000AA;
STICKLINE(X2>=X3,CLOSE,OPEN,3,0),COLOR0000CC;
STICKLINE(X2>=X3,CLOSE,OPEN,2,0),COLOR0000DD;
STICKLINE(X2>=X3,CLOSE,OPEN,1,0),COLOR0000FF;
STICKLINE(X2<X3,CLOSE,OPEN,1,0),COLOREEEE00;
STICKLINE(X2<X3,CLOSE,OPEN,2,0),COLORDDDD00;
STICKLINE(X2<X3,CLOSE,OPEN,3,0),COLORCCCC00;
STICKLINE(X2<X3,CLOSE,OPEN,4.5,0),COLORAAAA00;
STICKLINE(X2<X3,LOW,HIGH,0.1,0),COLORFFFF00;
STICKLINE(X2<X3 AND C>=黄金线 AND 黄金线>=多空线,OPEN,CLOSE,3.5,0),coloryellow;
STICKLINE(X2<X3 AND C>=多空线 AND C<黄金线,OPEN,CLOSE,3.5,0),colorwhite;
C2:=REF(C,1);
涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(涨停,OPEN,CLOSE,10,0),colorpurple;
STICKLINE(涨停,H,L,0,0),colorpurple;
跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(跌停,OPEN,CLOSE,10,0),colorgreen;
STICKLINE(跌停,H,L,0,1),colorgreen;

同花顺趋势涨停买卖指标公式

 

相关文章