在线检测未来函数

大智慧金玉趋势指标公式

来源:Internet,编辑:股旁网,2015-11-26

P1:=7;
P2:=13;
P3:=21;
A1:=MA(CLOSE,P1);
A2:=MA(CLOSE,P2);
A:A1-A2;
STICKLINE(A>=0,A,0,4,1),COLORF00FF0;
STICKLINE(A<0,A,0,4,1),COLORWHITE;
STICKLINE(A<ref(A,1)and A>0,0,A,4,0 ),COLOR00aaff;
STICKLINE(A<ref(A,1)and A>0,0,A,3.3,0 ),COLOR00bbff;
STICKLINE(A<ref(A,1)and A>0,0,A,2.2,0 ),COLOR00ccff;
STICKLINE(A<ref(A,1)and A>0,0,A,1.65,0 ),COLOR00ddff;
STICKLINE(A<ref(A,1)and A>0,0,A,1.1,0 ),COLOR00eeff;
STICKLINE(A<ref(A,1)and A>0,0,A,0.55,0 ),COLOR00ffff;
STICKLINE(A>=ref(A,1)and A>0,0,A,4 ,0 ),COLOR0000aa;
STICKLINE(A>=ref(A,1)and A>0,0,A,3.3 ,0 ),COLOR0011bb;
STICKLINE(A>=ref(A,1)and A>0,0,A,2.2,0 ),COLOr0022cc;
STICKLINE(A>=ref(A,1)and A>0,0,A,1.65 ,0 ),COLOR0033dd;
STICKLINE(A>=ref(A,1)and A>0,0,A,1.1 ,0 ),COLOR0044ee;
STICKLINE(A>=ref(A,1)and A>0,0,A,0.55 ,0 ),COLOR0055ff;
STICKLINE(A>ref(A,1)and A<0,0,A,4,0 ),COLOraa00bb;
STICKLINE(A>ref(A,1)and A<0,0,A,3.3 ,0 ),COLORbb11bb;
STICKLINE(A>ref(A,1)and A<0,0,A,2.2,0 ),COLOrcc22bb;
STICKLINE(A>ref(A,1)and A<0,0,A,1.65,0 ),COLORdd33bb;
STICKLINE(A>ref(A,1)and A<0,0,A,1.1,0 ),COLORee44bb;
STICKLINE(A>ref(A,1)and A<0,0,A,0.55 ,0 ),COLORff55bb;
STICKLINE(A<=ref(A,1)and A<0,0,A,4,0 ),COLOrffaa00;
STICKLINE(A<=ref(A,1)and A<0,0,A,3.3 ,0 ),COLORffbb11;
STICKLINE(A<=ref(A,1)and A<0,0,A,2.2,0 ),COLOrffcc22;
STICKLINE(A<=ref(A,1)and A<0,0,A,1.65 ,0 ),COLORffdd33;
STICKLINE(A<=ref(A,1)and A<0,0,A,1.1 ,0 ),COLORffee44;
STICKLINE(A<=ref(A,1)and A<0,0,A,0.55 ,0 ),COLORffff55;
A3:=EMA((MA(CLOSE,P3)-REF(MA(CLOSE,P3),1))*10,5);
B:EMA(EMA(A3,5),5),color00ff00;

大智慧金玉趋势指标公式

 

相关文章