在线检测未来函数

大智慧非常实用主图指标公式

来源:Internet,编辑:股旁网,2015-11-27

H均线:=WMA(H,5);
L均线:=WMA(L,5);
转折线:=IF(C>REF(H均线,1),L均线-(MA(H,5)-WMA(H,5)),IF(C<REF(L均线,1),H均线+(MA(H,5)-WMA(H,5)),L));{,LINETHICK2,colorFFFFFF,LAYER0;}
看多:=C>转折线;{,linethick0,color0000ff;}
看空:=C<=转折线;{,linethick0,color00ff00;}
看空期:=BARSLAST(看多);
看多期:=BARSLAST(看空);
预买:看多期=1,color00ffff,linethick0;
清仓:看空期=1,colorblue,linethick0;
{STICKLINE(C>转折线,H,L,1,0),colorred;
STICKLINE(C>转折线,O,C,6,0),colorred;
STICKLINE(C>转折线 AND C<O,O,C,6,1),colorred;
STICKLINE(C<=转折线,H,L,1,0),color00ff00;
STICKLINE(C<=转折线,O,C,6,0),color00ff00;
STICKLINE(C<=转折线 AND C>O,O,C,6,1),color00ff00;}
STICKLINE(预买,O,(C+O)/2,6,0),color00ffff;
STICKLINE(清仓,O,(C+O)/2,6,0),colorblue;
{DRAWTEXT(预买>0,L-0.15,'w'),LINETHICK4,ALIGN1,colorred;
DRAWTEXT(清仓>0,H+0.45,'m'),LINETHICK4,ALIGN1,Colorffffff;}
cci:MA(CLOSE,5);
{MA1:MA(CLOSE,6);
MA2:MA(CLOSE,8),LINETHICK1,COLORff00ff;}
工作线:MA(CLOSE,13),LINETHICK2,COLORBLUE;{colorred;}
价角度:ATAN((cci/REF(cci,1)-1)*100)*180/3.1416,COLOR0000FF,LINETHICK0;
DRAWTEXTABS(160,12,'价角度:'+价角度+'度 '),LINETHICK1,Colorffffff;
乖离率 : (CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100,LINETHICK0,colorbbbbbb;
长期: (WMA(c,2)-WMA(c,780))/WMA(c,780)*100,LINETHICK0,colorbbbbbb;
中期:(CLOSE-MA(CLOSE,78))/MA(CLOSE,48)*100,LINETHICK0,colorbbbbbb;
中长期: (WMA(c,2)-WMA(c,280))/WMA(c,280)*100,LINETHICK0,colorbbbbbb;
DRAWTEXTABS(160,24,'乖离率:'+乖离率+'率 '),LINETHICK1,Colorffffff;
DRAWTEXTABS(160,36,'中期:'+中期+'率 '),LINETHICK1,Colorffffff;
DRAWTEXTABS(160,48,'中长期:'+中长期+'率 '),LINETHICK1,Colorffffff;
DRAWTEXTABS(160,60,'长期:'+长期+'率 '),LINETHICK1,Colorffffff;
获利比例:=(WINNER(C)*1000)/10;
平均成本:=(COST(50)*100)/100;
穿透力:=(winner(C)-winner(ref(C,1)))/v*capital;
90%成本:=FLOOR(COST(50-90/2)*100)/100;
~:=CEILING(COST(50+90/2)*100)/100;
90集中度:=INTPART((~-90%成本)/(~+90%成本)*1000)/10;
70%成本:=FLOOR(COST(50-70/2)*100)/100;
~~:=CEILING(COST(50+70/2)*100)/100;
70集中度:=INTPART((~~-70%成本)/(~~+70%成本)*1000)/10;
DRAWTEXTABS(0,12,' 获利比例:'+STR(获利比例)),COLOR44bbff;
DRAWTEXTABS(0,24,' 平均成本:'+STR(平均成本)),COLOR44bbff;
DRAWTEXTABS(0,36,' 穿透力:'+STR(穿透力)),COLOR44bbff;
DRAWTEXTABS(0,48,'90%成本:'+STR(90%成本)+'-'+STR(~)),COLOR44bbff;
DRAWTEXTABS(0,60,'90集中度:'+STR(90集中度)),COLOR44bbff;
DRAWTEXTABS(0,72,'70%成本:'+STR(70%成本)+'-'+STR(~~)),COLOR44bbff;
DRAWTEXTABS(0,84,'70集中度:'+STR(70集中度)),COLOR44bbff;
partline(工作线,工作线>=ref(工作线,1),rgb(255,0,0),工作线<ref(工作线,1),rgb(0,255,0)),linethick1;
partline(cci,cci>=ref(cci,1),rgb(255,0,0),cci<ref(cci,1),rgb(0,255,0)),linethick3;
MID: MA(CLOSE,26),LINETHICK1,coloryellow;{,pointdot;}
UPPER: MID + 2*STD(CLOSE,26),LINETHICK1,Color7F00FF,DOTLINE;
LOWER: MID - 2*STD(CLOSE,26),LINETHICK1,Color7F00FF,DOTLINE;
PARTLINE(MID,(MID>=REF(MID,1))),LINETHICK1,color00ffff;
PARTLINE(MID,(MID<REF(MID,1))),LINETHICK1,COLORWHITE;

大智慧非常实用主图指标公式

 

相关文章