在线检测未来函数

飞狐MACD成本组合指标公式

来源:Internet,编辑:股旁网,2015-11-30

A:=76;
B:=2;
N1:=10;
N2:=20;
N3:=30;
L1:=LLV(HIGH,A);
H1:=HHV(L,A);
C1:=(H1+L1)/2;
D1:=LLV(HIGH,A);
主力成本:=EMA((2*C+H+L)/4,B),COLOR6633FF,LINETHICK2;
RC:=DYNAINFO(3);
S2:=SMA(C,3,1);
S6:=SMA(C,5,1);
DK:=2*(S2-S6);
STICKLINE(DK<REF(DK,1)AND DK>0,RC,RC+DK,1,0 ),COLOR00BBFF;
STICKLINE(DK>=REF(DK,1)AND DK>0,RC,RC+DK,1,0 ),COLOR0011BB;
STICKLINE(DK>REF(DK,1)AND DK<0,RC,RC+DK,1,0),COLORBB11BB;
STICKLINE(DK<=REF(DK,1)AND DK<0,RC,RC+DK,1,0),COLORFFBB11;
RC,COLOR333399;
LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100,COLOR9900FF;
DRAWTEXT(CROSS(RSI1,80),(HIGH * 1.1),'卖'),COLORYELLOW;
DRAWICON(CROSS(RSI1,80),(HIGH)*(1.02),2);
低位金叉:=CROSS(RSI1,50) AND( DK>REF(DK,3));
DRAWTEXT(低位金叉,L-1.04,' 买'),COLORYELLOW;
DRAWICON(CROSS(RSI1,50),L-0.58,1);Var1:=AMOUNT/(100*VOL);
短线成本均线: MA(Var1,N1);
中线成本均线: MA(Var1,N2);
长线成本均线: MA(Var1,N3);
无穷成本均线: DMA(CLOSE,VOL/CAPITAL);MG:=ema(HIGH,3);
ML:=ema(CLOSE,3);
买入:=c>MG;
卖出:=c<ML;
XXL:=ref(买入-卖出,BARSLAST(买入-卖出<>0));
DRAWICON(XXL>0,H,4),align5;
DRAWICON(XXL<0,L,5),align5;

飞狐MACD成本组合指标公式

 

相关文章