在线检测未来函数

同花顺多空主散指标公式

来源:Internet,编辑:股旁网,2015-12-02

x:=(3*C+L+O+H)/6;
多空线:(20*x+19*REF(x,1)+18*REF(x,2)+17*REF(x,3)+16*REF(x,4)+15*REF(x,5)+14*REF(x,6)
+13*REF(x,7)+12*REF(x,8)+11*REF(x,9)+10*REF(x,10)+9*REF(x,11)+8*REF(x,12)
+7*REF(x,13)+6*REF(x,14)+5*REF(x,15)+4*REF(x,16)+3*REF(x,17)+2*REF(x,18)+
REF(x,20))/210,coloryellow;
AA1:=(C-MA(C,6))/MA(C,6)*100;
AA2:=(C-MA(C,12))/MA(C,12)*100;
AA3:=(C-MA(C,24))/MA(C,24)*100;
AA4:=(AA1+2*AA2+3*AA3)/6;
AA5:=MA(AA4,3);
注意:=IF(AA5<-6 AND AA5>=-12,6,0);
STICKLINE(AA5<-6 AND AA5>=-12,OPEN,L,6,0),COLOR33ffcc;
加一:=IF(AA5<-12 AND AA5>=-18,12,0);
STICKLINE(AA5<-12 AND AA5>=-18,H,L,15,1) ,COLORBB00BB;
DRAWTEXT(AA5<-12 AND AA5>=-18,L*0.98,'底?'),colorred;
加二:=IF(AA5<-18,18,0);
STICKLINE(AA5<-18,L,H,15 ,0) ,COLORBB00BB;
平均价:=(HIGH+4*LOW+OPEN+CLOSE)/7;
均价差:= EMA(平均价,13) - EMA(平均价,34);
移动均价:= EMA(均价差,5);
差:=(均价差-移动均价)*5;
A:=IF(差>=1000 ,1000 ,IF(差<=平均价,平均价,差) );
分水岭:FORCAST(FORCAST(A,31),10),linethick1,colorwhite;
上升趋势:IF(A>分水岭,A,分水岭),colorred,LINETHICK1;
下降趋势:IF(A<分水岭,A,分水岭),colorblue,LINETHICK1;
AAA1:=AMOUNT/VOL/1000;
BBB2:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
DDD3:=SUM(AMOUNT,13)/AAA1/1000;
EEE4:=DMA(BBB2,VOL/DDD3);
买了就赢:=(CLOSE-EEE4)/EEE4*1000;
极低:=(CROSS(买了就赢,-166)),colorcyan,LINETHICK0;
RSI:=SMA(MAX(CLOSE-REF(CLOSE,1),0),5,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;
抛压:=CROSS(84,RSI),COLORff00aa,LINETHICK0;
VARFF:=100-3*SMA((CLOSE-LLV(LOW,66))/(HHV(HIGH,66)-LLV(LOW,66))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,66))/(HHV(HIGH,66)-LLV(LOW,66))*100,20,1),15,1);
VARJJJ:=100-3*SMA((OPEN-LLV(LOW,66))/(HHV(HIGH,66)-LLV(LOW,66))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,66))/(HHV(HIGH,66)-LLV(LOW,66))*100,20,1),15,1);
VARH:=VARFF<REF(VARJJJ,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
资金:=(VARH AND COUNT(VARH,30)=1),COLOR00DDFF,LINETHICK0;
JJ:=(CLOSE+HIGH+LOW)/3;
A:=EMA(JJ,10);
B:=REF(A,1);
STICKLINE(A>B ,A ,B ,10 ,0 ),coloryellow;
STICKLINE(A<B ,B ,A ,10 ,0 ),colorwhite;
R:=((CLOSE - LLV(LOW,9))/(HHV(HIGH,9) - LLV(LOW,9)))*(100);
K:=EMA(R,3);
D:=EMA(K,3);
陡峭度:=IF((BARSCOUNT(CLOSE) > 7),(100)*((MA(CLOSE,7))/(LLV(MA(CLOSE,7),7)) - 1),1);
N:=IF((陡峭度 > 0.35),6,65);
VAR1:=((-((100)*(HHV(HIGH,N) - CLOSE))/(HHV(HIGH,N) - LLV(LOW,N))));
VAR1A:=((-((100)*(HHV(HIGH,N) - CLOSE))/(HHV(HIGH,N) - LLV(LOW,N))) + 100);
获利盘:=(WINNER(CLOSE))*(100);
获利线:=FORCAST(获利盘,7);
线:=(FORCAST(VAR1A,7))*((DATE < 20070110));
出击:=CROSS(线,20) AND IF((COUNT(CROSS(K,D),3) = 1) AND (D < 40),1,(线 > D) OR (K > D) AND (D < 60)) AND IF((N = 6),(获利盘 < 70),(获利盘 < 40)) AND (COUNT((获利线 > 20),20) > 0);
狂喜:=(30)*(CROSS(VAR1,(-2)));
恐慌:=(20)*(VAR1 < -94);
极度恐慌:=(-40)*(VAR1 = (-100));
介入:=(CROSS(C,分水岭));
止:=(CROSS(分水岭,C));
均价:=(3*C+H+L+O)/6;
VAR1:=(8*均价+7*REF(均价,1)+6*REF(均价,2)+5*REF(均价,3)+4*REF(均价,4)+3*REF(均价,5)+2*REF(均价,6)+REF(均价,8))/36;
VAR2:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
SZ1:=REF(VAR1,1)=REF(VAR2,1) AND VAR1>VAR2 AND CLOSE>VAR1;
SZ2:=VAR1>VAR2 AND VAR1>REF(VAR1,1) AND VAR2>REF(VAR2,1) AND H/VAR1<1.1 AND L>VAR2 AND CLOSE>VAR1;
SZ3:=VAR1>VAR2 AND VAR1>REF(VAR1,1) AND VAR2>=REF(VAR2,1) AND H/VAR1>1.1;
SZ4:=VAR1>VAR2 AND VAR1>REF(VAR1,1) AND VAR2>REF(VAR2,1) AND CLOSE>VAR2 AND CLOSE<VAR1;
SZ5:=(VAR1>VAR2 AND VAR2>REF(VAR2,1) AND VAR1<>REF(VAR1,1) AND CLOSE<VAR2) OR (VAR1>VAR2 AND VAR1<REF(VAR1,1) AND VAR2<REF(VAR2,1) AND CLOSE<VAR2);;
SZ6:=REF(VAR1,1)>REF(VAR2,1) AND VAR1=VAR2 AND CLOSE<VAR2;
XD1:=VAR1=VAR2 AND CLOSE<VAR2 OR (VAR1<REF(VAR1,1) AND VAR2<REF(VAR2,1) AND REF(VAR1,1)=REF(VAR2,1) AND CLOSE<VAR2);
XD2:=VAR1=VAR2 AND CLOSE>VAR1;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0),COLOR000084;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7,0),COLOR000095;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0),COLOR0000A2;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0),COLOR0000B3;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0),COLOR0000C8;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0),COLOR0000D7;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0),COLOR0000EA;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0),COLOR0000FF;
STICKLINE(CLOSE<OPEN,H,L,0,0),colorgreen;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,8,0),COLOR007700;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,7,0),COLOR008E00;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,6,0),COLOR009900;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,5,0),COLOR00A600;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,4,0),COLOR00B500;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,3,0),COLOR00C600;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,2,0),COLOR00D500;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,1,0),COLOR00E600;
DRAWTEXT(CROSS(买了就赢,-166),L*0.99,'极低'),colorcyan;
DRAWTEXT(CROSS(买了就赢,-120),H*1.01,'较低'),coloryellow;
DRAWTEXT(CROSS(买了就赢,-88),H,'稍低'),colorgreen;
STICKLINE(CROSS(买了就赢,-166),CLOSE,OPEN,10,1),colorgreen;
STICKLINE(CROSS(买了就赢,-120),OPEN,H,4,1),coloryellow ;
STICKLINE(CROSS(买了就赢,-88),L,CLOSE,2,1),coloryellow ;
STICKLINE(CROSS(84,RSI),H ,CLOSE,9,0),COLORFF0033;
STICKLINE(CROSS(84,RSI),H ,CLOSE,8,0),COLORFF0044;
STICKLINE(CROSS(84,RSI),H ,CLOSE,7,0),COLORff0055;
STICKLINE(CROSS(84,RSI),H ,CLOSE,6,0),COLORff0066;
STICKLINE(CROSS(84,RSI),H,CLOSE,5,0),COLORff0077;
STICKLINE(CROSS(84,RSI),H ,CLOSE,4,0),COLORFF0088;
STICKLINE(CROSS(84,RSI),H,CLOSE,3,0),COLORff0099;
STICKLINE(CROSS(84,RSI),H ,CLOSE,2,0),COLORff00aa;
STICKLINE(CROSS(84,RSI),H ,CLOSE,1,0),COLORff00bb;
STICKLINE(VARH AND COUNT(VARH,30)=1,L ,C,11,0),COLOR106FFF;
STICKLINE(VARH AND COUNT(VARH,30)=1,L ,C,10,0),COLOR000095;
STICKLINE(VARH AND COUNT(VARH,30)=1,L ,C,9,0),COLOR00AAFF;
STICKLINE(VARH AND COUNT(VARH,30)=1,L ,C,5,0),COLOR00CCFF;
STICKLINE(VARH AND COUNT(VARH,30)=1,L ,C,3,0),COLOR00DDFF;
STICKLINE(VARH AND COUNT(VARH,30)=1,L ,C,2,0),COLOR00EEFF;
STICKLINE(VARH AND COUNT(VARH,30)=1,L,C,1,0),COLOR00FFFF;
STICKLINE(出击,OPEN,CLOSE,3,1),Color44BB00;
DRAWTEXT(出击,CLOSE,'出击'),colorgreen;
STICKLINE(狂喜,OPEN,CLOSE,3,1),colorblack;
DRAWTEXT(狂喜,(L*0.99),'要涨停'),coloryellow;
STICKLINE(恐慌,OPEN,(CLOSE),3,0),ColorC1C1C1;
STICKLINE(极度恐慌,OPEN,(CLOSE),4,0),Color800000;
DRAWTEXT(介入,L*0.999,'介入'),colorred;
PARTLINE(分水岭,分水岭>REF(分水岭,1),RGB(250,30,30),分水岭<=REF(分水岭,1),RGB(30,250,30)),LINETHICK2;
PARTLINE(多空线,多空线>REF(多空线,1),RGB(250,30,30),多空线<=REF(多空线,1),RGB(30,250,30)),LINETHICK3;
DRAWTEXT(止,L,'止'),CROSSDOT,LINETHICK3,colorgreen;
varA:=((AMOUNT)/(VOL))/(100);
varB:=((3)*(HIGH)+LOW+OPEN+(2)*(CLOSE))/(7);
varC:=((SUM(AMOUNT,7))/(varA))/(100);
varDD:=DMA(varB,(VOL)/(varC));
varE:=((CLOSE-varDD)/(varDD))*(100);
varF:=((CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)))*(100);
varJJ:=MA(varE,20)+STD(varE,20);
BIAS18:=((CLOSE-MA(CLOSE,18))/(MA(CLOSE,18)))*(100);
KK:=SMA(varF,3,1);
KKJ:=(REF(BIAS18,1)>=5) AND CROSS(varJJ,varE) AND (KK>79);
DRAWTEXT(REF(BIAS18,1)>=5 AND CROSS(varJJ,varE) AND KK>79,H*1.02,'风险'),coloryellow;
KKK:= 600*(EMA(CLOSE,3)-EMA(LOW,30))/EMA(LOW,30);
风险:=EMA(KKK,7);
DRAWTEXT(CROSS(KKK,风险) AND (BETWEEN(风险,-55,-120)),L,'▲'),CROSSDOT,LINETHICK5,colorred;
DRAWTEXT((CROSS(风险,KKK)) AND (风险>55),H*1.02,'▼'),CROSSDOT,LINETHICK5,colorgreen;
DRAWTEXT(KKJ,H*1.01,'顶'),CROSSDOT,LINETHICK5,colorgreen;
KKL:=IF(COUNT(AA5<-12,10)>=1,10,0);
STICKLINE(KKL=10,OPEN,L,2,0),COLORBB00BB;
DRAWTEXT(KKL=10,L,'加'),coloryellow;

同花顺多空主散指标公式

 

相关文章