在线检测未来函数

通达信刀口舔血主图指标公式

来源:Internet,编辑:股旁网,2015-12-04

N:=10;
M1:=11;
M2:=9;
上轨1:=(1+M1/100)*MA(C,N);
下轨1:=(1-M2/100)*MA(C,N);
中轨1:=(上轨1+下轨1)/2;
STICKLINE(CLOSE>中轨1 AND CLOSE<上轨1,H,L,0,0),COLORMAGENTA,LINETHICK1;
STICKLINE(CLOSE>中轨1 AND CLOSE<上轨1,CLOSE,OPEN,2.4,0),COLORMAGENTA;
STICKLINE(CLOSE>中轨1 AND CLOSE<上轨1,CLOSE,OPEN,1.2,0),COLORMAGENTA;
STICKLINE(CLOSE>中轨1 AND CLOSE<上轨1,CLOSE,OPEN,0.6,0),COLORMAGENTA;
STICKLINE(CLOSE>中轨1 AND CLOSE<上轨1,CLOSE,OPEN,0,0),COLORMAGENTA;
STICKLINE(CLOSE>下轨1 AND CLOSE<中轨1,H,L,0,0),COLORYELLOW,LINETHICK1;
STICKLINE(CLOSE>下轨1 AND CLOSE<中轨1,CLOSE,OPEN,2.4,0),COLORYELLOW;
STICKLINE(CLOSE>下轨1 AND CLOSE<中轨1,CLOSE,OPEN,1.2,0),COLORYELLOW;
STICKLINE(CLOSE>下轨1 AND CLOSE<中轨1,CLOSE,OPEN,0.6,0),COLORYELLOW;
STICKLINE(CLOSE>下轨1 AND CLOSE<中轨1,CLOSE,OPEN,0,0),COLORYELLOW;
STICKLINE(CLOSE<下轨1,H,L,0,0),COLORBLUE,LINETHICK1;
STICKLINE(CLOSE<下轨1,CLOSE,OPEN,2.4,0),COLORBLUE;
STICKLINE(CLOSE<下轨1,CLOSE,OPEN,1.2,0),COLORBLUE;
STICKLINE(CLOSE<下轨1,CLOSE,OPEN,0.6,0),COLORBLUE;
STICKLINE(CLOSE<下轨1,CLOSE,OPEN,0,0),COLORBLUE;
STICKLINE(CLOSE>上轨1,H,L,0,0),COLORGREEN,LINETHICK1;
STICKLINE(CLOSE>上轨1,CLOSE,OPEN,2.4,0),COLORGREEN;
STICKLINE(CLOSE>上轨1,CLOSE,OPEN,1.2,0),COLORGREEN;
STICKLINE(CLOSE>上轨1,CLOSE,OPEN,0.6,0),COLORGREEN;
STICKLINE(CLOSE>上轨1,CLOSE,OPEN,0,0),COLORGREEN;
上轨:(1+M1/100)*MA(C,N),COLORMAGENTA;
下轨:(1-M2/100)*MA(C,N),COLORGREEN;
中轨:(上轨+下轨)/2,COLORWHITE;

通达信刀口舔血主图指标公式

 

相关文章