在线检测未来函数

通达信RSI看趋势支撑压力背离指标公式

来源:Internet,编辑:股旁网,2015-12-09

N:=14;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),N,1)/SMA(ABS(CLOSE-LC),N,1)*100;
DRAWLINE(RSI>=HHV(RSI,10),RSI,RSI<=LLV(RSI,3),HHV(RSI,3),1),COLORFF6000,LINETHICK1;
AA0:=REF(RSI,N)=HHV(RSI,2*N+1);
QY0:=BACKSET(AA0,N+1);
CC0:=FILTER(QY0,N) AND RSI=HHV(RSI,N+1);
DRAWICON(CC0,RSI,2);
AA1:=REF(RSI,N)=LLV(RSI,2*N+1);
QY1:=BACKSET(AA1,N+1);
CC1:=FILTER(QY1,N) AND RSI=LLV(RSI,N+1);
DRAWICON(CC1,RSI,1);
Q:=5;
AA:=REF(RSI,Q)=HHV(RSI,2*Q+1);
BB:=FILTER(AA,Q);
CC:=BACKSET(BB,Q+1);
DD:=FILTER(CC,Q);
AAA:=REF(RSI,Q)=LLV(RSI,2*Q+1);
BBB:=FILTER(AAA,Q);
CCC:=BACKSET(BBB,Q+1);
DDD:=FILTER(CCC,Q);
R11:=BACKSET(ISLASTBAR,BARSLAST(DD)+1);
S11:=R11>REF(R11,1);
压力:DRAWLINE(DD,RSI,S11,RSI,1),LINETHICK1,COLOR00FF00;
T11:=BACKSET(ISLASTBAR,BARSLAST(DDD)+1);
U11:=T11>REF(T11,1);
支撑:DRAWLINE(DDD,RSI,U11,RSI,1),LINETHICK1,COLOR0088FF;
我的RSI:RSI,COLORFFFFFF;
IF(RSI>65,RSI,DRAWNULL),COLOR0000FF;
IF(RSI<35,RSI,DRAWNULL),COLORFF00FF;
CONST(RSI),COLOR00FFFF,DOTLINE;

通达信RSI看趋势支撑压力背离指标公式

 

相关文章