在线检测未来函数

通达信强庄主图指标公式

来源:Internet,编辑:股旁网,2015-12-09

强势线:EMA(((SLOPE(CLOSE,21) * 20) + CLOSE),42),POINTDOT,COLORFF00FF,;
M1:MA(强势线,17)+ABS(MA(强势线,17)-REF(MA(强势线,17),1)),COLORGREEN;
M2:MA(强势线,17)+MA(强势线,17)-REF(MA(强势线,17),1),COLORYELLOW,LINETHICK1;
M3:IF(MA(强势线,17)<M2,M2,MA(强势线,17)),COLORLIMAGENTA,LINETHICK2;
M4:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4),0.9);
M5:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));
M6:=(IF((CLOSE>OPEN),(M4*(HIGH-LOW)),IF((CLOSE<OPEN),(M4*((HIGH-OPEN)+(CLOSE-LOW))),(VOL/2)))+IF((CLOSE>OPEN),(0-(M5*((HIGH-CLOSE)+(OPEN-LOW)))),IF((CLOSE<OPEN),(0-(M5*(HIGH-LOW))),(0-(VOL/2)))));
M7:(VOL/CAPITAL);
M8:=((M6/20)/1.15);
DRAWICON(FILTER(((M8* 0.4) >= 0),13),L*0.98,1);
DRAWICON(FILTER(((M8* 0.4) < 0),13),H*1.02,2);
STICKLINE(FILTER(((M8* 0.4) < 0),5),CLOSE,OPEN,3,0),COLORGREEN;
STICKLINE(FILTER(((M8*0.4)>=0),5),CLOSE,OPEN,3,0),COLORYELLOW;
STICKLINE(FILTER(((M8* 0.4) >= 0),5),L,H,0,0),COLOR8000FF;
STICKLINE(FILTER(((M8* 0.4) >= 0),1),CLOSE,OPEN,3,0),COLOR990099;
STICKLINE(FILTER(((M8*0.4)>=0),5),LLV(L,3),LLV(L,3),13,1),COLORRED,LINETHICK3;
STICKLINE(FILTER(((M8*0.4)<1),15),HHV(H,10),HHV(H,10),28,1),COLORFFFF80,LINETHICK3;
DRAWTEXT(FILTER(((M8*0.4)<1),15),HHV(H,10),' 减仓'),COLOR0080FF;

通达信强庄主图指标公式

 

相关文章