在线检测未来函数

通达信优化MACD指标公式

来源:Internet,编辑:股旁网,2015-12-09

DIF1:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA1:=EMA(DIF1,9);
MACD1:=2*(DIF1-DEA1),STICK;
MACD2:EMA(MACD1,5),NODRAW;
蓝:STICKLINE(MACD1<MACD2 AND MACD1<0,0,MACD1,1,0),COLORBLUE;
粉:STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,1,1),COLORMAGENTA;
红:STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,1,1),COLORRED;
绿:STICKLINE(MACD1<MACD2 AND MACD1>0,0,MACD1,1,0),COLORGREEN;
A:DRAWTEXT(CROSS(粉,蓝),MACD1 -0.1,'买')COLORGREEN;
B:DRAWTEXT(CROSS(绿,红),MACD2 -0.01,'卖')COLORYELLOW;

通达信优化MACD指标公式

 

相关文章