在线检测未来函数

通达信塔罗三线2015年顶底ABC主图指标公式

来源:Internet,编辑:股旁网,2015-12-08

{底部三线}
AD:=1130218;
BD:=1130529;
下降趋势线:DRAWLINE(DATE=AD,H,DATE=BD,H,1)DOTLINE,COLORCYAN;
CD:=1130912;
止跌整理:DRAWLINE(DATE=BD,H,DATE=CD,H,1)DOTLINE,COLORYELLOW;
起涨整理:DRAWLINE(DATE=CD,H,REF(DATE=CD,1),REF(H,1),1),COLORRED;
DRAWBAND(下降趋势线,RGB(200,80,0),止跌整理,RGB(200,0,200));
DRAWBAND(止跌整理,RGB(180,80,0),起涨整理,RGB(100,0,0));
{顶部三线}
A点:=1141027;
B点:=1150209;
上涨趋势线:DRAWLINE(DATE=A点,L,DATE=B点,L,1)DOTLINE,COLORRED;
C点:=1150709;
强势整理线:DRAWLINE(DATE=B点,L,DATE=C点,L,1)DOTLINE,COLORYELLOW;
弱势整理线:DRAWLINE(DATE=C点,L,REF(DATE=C点,1),REF(L,1),1),COLORLIBLUE;
STICKLINE(上涨趋势线>强势整理线,上涨趋势线,强势整理线,5,0),COLORLICYAN;
STICKLINE(强势整理线>弱势整理线,强势整理线,弱势整理线,5,0),COLORBLUE;
DRAWTEXT(DATE=1150529 AND 强势整理线,上涨趋势线*0.99,'强势整理区'),COLORYELLOW;
DRAWTEXT(DATE=1150922 AND 弱势整理线,强势整理线*0.99,'弱势整理区'),COLORYELLOW;
{近顶三线}
A2点:=1150929;
B2点:=1151103;
上涨趋势线2:DRAWLINE(DATE=A2点,L,DATE=B2点,L,1)DOTLINE,COLORRED;
C2点:=1151130;
强势整理线2:DRAWLINE(DATE=B2点,L,DATE=C2点,L,1)DOTLINE,COLORYELLOW;
弱势整理线2:DRAWLINE(DATE=C2点,L,REF(DATE=C2点,1),REF(L,1),1),COLORBLUE;
STICKLINE(上涨趋势线2>强势整理线2,上涨趋势线2,强势整理线2,1,0),COLORLIBLUE;
上升轨道支撑:DRAWLINE(DATE=1150826,L,DATE=1150929,L,1),COLORRED;
STICKLINE(上升轨道支撑>弱势整理线2,上升轨道支撑,弱势整理线2,4,0),COLORGRAY;
STICKLINE(强势整理线2>弱势整理线2,强势整理线2,弱势整理线2,1,0),COLORBLUE;
DRAWTEXT(DATE=1151113 AND 强势整理线2,上涨趋势线2,'强势整理区'),COLORYELLOW;
DRAWTEXT(DATE=1151204 AND 弱势整理线2,强势整理线2,'弱势整理区'),COLORYELLOW;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE) ;

通达信塔罗三线2015年顶底ABC主图指标公式

 

相关文章