在线检测未来函数

通达信漂亮彩K主图指标公式

来源:Internet,编辑:股旁网,2015-12-11

STICKLINE(C>O,H,L,0,0),COLORFFBBFF;
STICKLINE(C>O,O,C,3,0),COLOR0000AA;
STICKLINE(C>O,O,C,2,0),COLOR0000DD;
STICKLINE(C>O,O,C,1,0),COLOR0055FF;
STICKLINE(C>O,O,C,0.1,0),COLOR0088FF;
STICKLINE(C<O,H,L,0,0),COLOR00FF00;
STICKLINE(C<O,O,C,3,0),COLOR888800;
STICKLINE(C<O,O,C,2,0),COLORFFAA00;
STICKLINE(C<O,O,C,1,0),COLORFFCC00;
STICKLINE(C<O,O,C,0.1,0),COLORFFFF00;
STICKLINE(C<O,O,C,0,0),COLORFFFF58;
STICKLINE(C=REF(C,1),H,L,0,0),COLORFFFFFF;
STICKLINE(C=REF(C,1),O,C,3,0),COLOR888888;
STICKLINE(C=REF(C,1),O,C,2,0),COLORAAAAAA;
STICKLINE(C=REF(C,1),O,C,1,0),COLORCCCCCC;
STICKLINE(C=REF(C,1),O,C,0,0),COLORFFFFFF;
{K线类别}
VAR9Q:=C=HHV(C,4)AND (REF(C,1)>=REF(C,2)OR REF(C,1)>=REF(C,3))
OR REF(C,1)=HHV(C,4)AND CLOSE>=REF(C,2)OR REF(C,2)=HHV(C,4)
AND REF(C,3)=LLV(C,4)AND C>=REF(C,1)OR REF(C,3)=HHV(C,4)AND C>=REF(C,1)
AND C>=REF(C,2);
红持:=VAR9Q;
STICKLINE(VAR9Q,C,(O+C)/2,3,0),COLOR000088;
STICKLINE(VAR9Q,C,(O+C)/2,2,0),COLOR0000AA;
STICKLINE(VAR9Q,C,(O+C)/2,1,0),COLOR0000BB;
STICKLINE(VAR9Q,C,(O+C)/2,0.1,0),COLOR0000FF;
VARAQ:=C=HHV(C,4)AND REF(C,1)=LLV(C,4);
粉变:=VARAQ;
STICKLINE(VARAQ,C,(O+C)/2,3,0),COLOR981198;
STICKLINE(VARAQ,C,(O+C)/2,2,0),COLORCC55CC;
STICKLINE(VARAQ,C,(O+C)/2,1,0),COLORFF99FF;
STICKLINE(VARAQ,C,(O+C)/2,0.1,0),COLORFFDDFF;
VARBQ:=C=LLV(C,4)AND(REF(C,1)<REF(C,2)OR REF(C,1)<REF(C,3))
OR REF(C,1)=LLV(C,4)AND C<REF(C,2)OR REF(C,2)=LLV(C,4)
AND REF(C,1)!=HHV(C,4)AND C<REF(C,1)OR REF(C,3)=LLV(C,4)AND C<REF(C,1)
AND C<REF(C,2);
灰跌:=VARBQ;
STICKLINE(VARBQ AND C>O,O,C-(C-O)/2,3,0),COLOR888888;
STICKLINE(VARBQ AND C>O,O,C-(C-O)/2,2,0),COLORAAAAAA;
STICKLINE(VARBQ AND C>O,O,C-(C-O)/2,1,0),COLORCCCCCC;
STICKLINE(VARBQ AND C>O,O,C-(C-O)/2,0.1,0),COLORFFFFFF;
STICKLINE(VARBQ AND C<O,C,O-(O-C)/2,3,0),COLOR888888;
STICKLINE(VARBQ AND C<O,C,O-(O-C)/2,2,0),COLORAAAAAA;
STICKLINE(VARBQ AND C<O,C,O-(O-C)/2,1,0),COLORCCCCCC;
STICKLINE(VARBQ AND C<O,C,O-(O-C)/2,0.1,0),COLORFFFFFF;
VARCQ:=REF(C,1)=LLV(C,4)AND C>=REF(C,2)OR REF(C,2)=LLV(C,4)
AND REF(C,1)<=REF(C,3)AND REF(C,2)<REF(C,4)AND C>=REF(C,1); 绿买:=VARCQ;
STICKLINE(VARCQ,O,(O+C)/2,3,0),COLOR008800;
STICKLINE(VARCQ,O,(O+C)/2,2,0),COLOR00AA00;
STICKLINE(VARCQ,O,(O+C)/2,1,0),COLOR00CC00;
STICKLINE(VARCQ,O,(O+C)/2,0.1,0),COLOR00FF00;
VARDQ:=REF(C,1)=HHV(C,4)AND C<REF(C,2)OR(REF(C,2)=HHV(C,4)
AND REF(C,1)>REF(C,3)OR REF(C,3)=HHV(C,4)AND REF(C,1)>REF(C,2))
AND REF(C,2)>=REF(C,4)AND C<REF(C,1);
蓝抛:=VARDQ;
STICKLINE(VARDQ,O,(O+C)/2,3,0),COLORFF5500;
STICKLINE(VARDQ,O,(O+C)/2,2,0),COLORFF8800;
STICKLINE(VARDQ,O,(O+C)/2,1,0),COLORFFAA00;
STICKLINE(VARDQ,O,(O+C)/2,0.1,0),COLORFFCC00;

通达信漂亮彩K主图指标公式

 

相关文章