在线检测未来函数

飞狐夹道欢迎主图指标公式

来源:Internet,编辑:股旁网,2015-12-14

N:=20;
M:=32;
P1:=80;
P2:=100;
VAR1:=(C+H+O+L)/4;
卖出:WMA(VAR1,N)*(1+P1/1000),COLORGREEN,LINETHICK2;
买入:WMA(VAR1,M)*(1-P2/1000),COLORMAGENTA,LINETHICK2;
幅度:100*(卖出-买入)/买入,LINETHICK;
MA1:=MA(VAR1,3);
STICKLINE(卖出>LOW AND 卖出<HIGH,卖出,MAX(卖出,MAX(OPEN,CLOSE)),7,0),COLORGREEN;
STICKLINE(卖出>MIN(C,O) AND 卖出<MAX(C,O),卖出,MAX(OPEN,CLOSE),7,0),COLORGREEN;
STICKLINE(卖出>LOW AND 卖出<HIGH,卖出,HIGH,0,0),COLORGREEN;
STICKLINE(卖出<LOW,OPEN,CLOSE,7,0),COLORGREEN;
STICKLINE(卖出<LOW,HIGH,LOW,0,0),COLORGREEN;
STICKLINE(买入>LOW AND 买入<HIGH,买入,MIN(MIN(OPEN,CLOSE),买入),7,0),COLORMAGENTA;
STICKLINE(买入>MIN(C,O) AND 买入<MAX(C,O),买入,MIN(OPEN,CLOSE),7,0),COLORMAGENTA;
STICKLINE(买入>LOW AND 买入<HIGH,买入,LOW,0,0),COLORMAGENTA;
STICKLINE(买入>HIGH,OPEN,CLOSE,7,0),COLORMAGENTA;
STICKLINE(买入>HIGH,HIGH,LOW,0,0),COLORMAGENTA;
DRAWTEXT(CROSS(LOW,买入),LOW*0.95,'B'),COLORRED,LINETHICK2;
DRAWTEXT(CROSS(卖出,HIGH),HIGH*1.02,'S'),COLORGREEN;
多头线:EMA(C,3),COLORYELLOW;
空头线:EMA(C,5),COLOR00FF00;
均衡线:EMA(空头线,5),COLORWHITE,;
PartLine(多头线>=REF(多头线,1) AND 多头线>=空头线,多头线),ColorFF00FF,LINETHICK3;
VAR1:=IF(CLOSE/REF(CLOSE,1)>1.050 AND HIGH/CLOSE<1.010 AND IF(CLOSE>REF(CLOSE,1),88,0)>0, 91, 0);
DRAWTEXT(VAR1>90,LOW*1,'买'),COLORFF00FF;
VAR2:=REF(EMA(DMA((((HIGH + LOW) + (CLOSE * 2)) / 4.09),0.9),3),1);
DRAWTEXT(CROSS(CLOSE,VAR2),LOW,'S'),COLORYELLOW;
DRAWTEXT(CROSS(VAR2,CLOSE),HIGH*1.01,'卖'),COLORWHITE;
VAR3:=REF(CLOSE,1);
VAR4:=SMA(MAX(CLOSE-VAR3,0),6,1)/SMA(ABS(CLOSE-VAR3),6,1)*100;
DRAWTEXT(CROSS(84,VAR4),H*1.03,'逃顶'),COLORYELLOW ;
VAR5:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR6:=SMA(ABS(LOW-VAR5),13,1)/SMA(MAX(LOW-VAR5,0),10,1);
VAR7:=EMA(VAR6,10);
VAR8:=LLV(LOW,33);
VAR9:=EMA(IF(LOW<=VAR8,VAR7,0),5);
主力进场:=FILTER(VAR9>REF(VAR9,1),5);
{DRAWTEXT(FILTER(VAR9>REF(VAR9,1),5),LOW*0.995,'↑'),COLOR0000FF;}
DRAWTEXT(FILTER(VAR9>REF(VAR9,1),5),LOW*1,'主\n力\n进'),COLOR0000FF;
DRAWTEXT(FILTER(VAR5>REF(VAR5,1),5),LOW*1.08,'主\n力\n出'),COLOR70DB93;
STICKLINE(C>=O,C,O,4,0),Color000064;
STICKLINE(C>=O,C,O,3,0),Color000091;
STICKLINE(C>=O,C,O,2,0),Color0000C4;
STICKLINE(C>=O,H,L,1,0),Color0B0BFF;
STICKLINE(C<=O,C,O,4,0),Color3E3E00;
STICKLINE(C<=O,C,O,3,0),Color5E5E00;
STICKLINE(C<=O,C,O,2,0),Color979700;
STICKLINE(C<=O,H,L,1,0),ColorB0B000;

飞狐夹道欢迎主图指标公式

 

相关文章