在线检测未来函数

通达信决策主图指标公式

来源:Internet,编辑:股旁网,2015-12-15

DRAWGBK(OPEN>0,RGB(8,88,188),RGB(0,0,0),0,'02',0);
VAR3:=LLV(HIGH,240);
VAR4:=100*(CLOSE-VAR3)/VAR3;
VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;
VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;
VAR7:=0;
VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
买1:=VAR10;
买2:=(VAR11+VAR13+VAR15+VAR17);
卖1:=(VAR12+VAR14+VAR16+VAR18);
B:IF(买1>0 OR 买2>0,LOW*0.99,DRAWNULL),CROSSDOT,LINETHICK5,COLOR0800FF;
DRAWTEXT(买1>0 OR 买2>0,LOW*0.98,'↖深筹'),COLORRED;
S:IF(卖1>0,HIGH*1.03,DRAWNULL),CROSSDOT,LINETHICK5,COLOR008800;
DRAWTEXT(卖1>0,HIGH*1.03,'↙卖出'),COLORGREEN;
DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),LOW*0.97,34) ;
DRAWICON((ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)>=REF(ZIG(3,5),3)),HIGH*1.01,35);
ZB:=EMA(EMA(VAR3,5),5)*3, COLORSTICK;
VARA:=IF(VAR9 AND CROSS(MA(CLOSE,3),MA(CLOSE,5)),20,0);
K:=EMA(VAR7,5)*2, , COLORFF00FF;
D:=EMA(K,5), , COLORWHITE;
J:=K*3-D*2, ,COLORYELLOW;
VARB:=BETWEEN(CLOSE,MA(CLOSE,3),MA(CLOSE,5)) AND J>10;
HS:=VOL/CAPITAL*100, , COLORGREEN;
VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
DRAWTEXT(VAR11 AND COUNT(VAR11,30)=1,LOW*0.96,'↖股海'),LINETHICK1,COLORFF00FF;
VAR1A:=IF(VARE>0,VARE,0);
VAR1B:=IF(VAR14>=200 AND VAR13>=150,15,IF(VAR14<=-200 AND VAR13<=-150,-15,VAR16))+60;
VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR19<100;
DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,LOW*0.95,'关注') COLORWHITE;
N:=IF(BARSCOUNT(C)>=8,8,BARSCOUNT(C));
AMOV:=VOL*(C+L+H)/3;
MN:=SUM(AMOV,N)/SUM(VOL,N);
NOTEXT1:IF(C>=MN,MN,DRAWNULL),LINETHICK3,COLORRED;
NOTEXT2:IF(C<MN,MN,DRAWNULL),LINETHICK3,COLORGREEN;
DRAWBAND(MA(CLOSE,3),RGB(188,0,43),MA(CLOSE,24),RGB(0,72,46));
QQ2:=(CLOSE-LLV(LOW, 18))/(HHV(HIGH, 18)-LLV(LOW, 18))*100;
QQ3:=SMA(QQ2, 9, 1);
QQ4:=SMA(QQ3, 3, 1);
趋势:=3*QQ3-2*QQ4,COLORWHITE,LINETHICK3;
趋势线:=EMA(QQ3, 3),COLORRED,LINETHICK3;
金叉:= CROSS(长趋势,趋势线);
AAAA1:=AMOUNT/V;
BBB1:=L<AAAA1*0.9;
CCC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DDD1:=L<MA(C,5)*0.921;
EEE1:=V<MA(V,5)*1.5;
老鼠仓:=BBB1 AND CCC1 AND DDD1 AND EEE1,,NODRAW;
DRAWICON(老鼠仓 OR 金叉,(LOW - (LOW * 0.01)),9);
AA05:=MA(C,5),COLOR0099CC;
BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3),NODRAW;
AA10:=MA(C,10);
AA20:=MA(C,20);BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416;
AA30:=MA(C,30);
三拾日乖离率:=(C-AA30)/AA30*100;
加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND
AA05>REF(AA05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND
AA10>REF(AA10,1)
AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ;
DRAWICON(加仓,L*0.99,23);
DRAWKLINE(H,O,L,C);
TJ:=VOL>=REF(V,1)*1.91 AND C>REF(C,1)*1.01;
DRAWTEXT(TJ,L,'↖亮箭'),COLORYELLOW;
STICKLINE(TJ,OPEN,CLOSE,1.5,0),COLORYELLOW;
K1:=SUMBARS(TJ,1);
STICKLINE(K1,REF(C,K1-1),REF(C,K1-1),10,0),COLORYELLOW;
MA30:=MA(C,30);
支撑价:MA(REF(LLV(C,30),1),2),DOTLINE,COLORFF00FF;
DRAWTEXT(ISLASTBAR,支撑价,'↖支撑'),COLORFF00FF;
现价:CLOSE,COLORWHITE,LINETHICK1;
压力价:MA(REF(HHV(C,30),1),2),DOTLINE,COLORGREEN;
DRAWTEXT(ISLASTBAR,压力价,'↖压力'),COLORGREEN;
短线交易:MA(REF(LLV(C,3),1),2),DOTLINE,COLORRED;
DRAWTEXT(ISLASTBAR,短线交易,'↖交易'),COLORRED;
B1:=REF(CLOSE,1);
B2:=REF(CLOSE,2);
B3:=REF(CLOSE,3);
B4:=REF(CLOSE,4);
CMAX:=MAX(MAX(MAX(CLOSE,B1),B2),B3);
CMIN:=MIN(MIN(MIN(CLOSE,B1),B2),B3);
持股:=(CLOSE=CMAX AND (B1>=B2 OR B1>=B3)) OR ((B1=CMAX AND (B2=CMIN OR B3=CMIN)) AND CLOSE>=B2) OR
(B2=CMAX AND B3=CMIN AND CLOSE>=B1) OR (B3=CMAX AND CLOSE>=B1 AND CLOSE>=B2);
变盘:=CLOSE=CMAX AND B1=CMIN;
STICKLINE(变盘,B2,CLOSE,2,0),COLORFF88FF;
下跌:=(CLOSE=CMIN AND (B1<B2 OR B1<B3)) OR ((B1=CMIN AND (B2=CMAX OR B3=CMAX)) AND CLOSE<B2) OR
(B2=CMIN AND B3=CMAX AND CLOSE<B1) OR (B3=CMIN AND CLOSE<B1 AND CLOSE<B2);
买入:=(B1=CMIN AND CLOSE>=B2) OR ((B2=CMIN AND B1<=B3) OR
(B3=CMIN AND B1<=B2) AND B2<B4 AND CLOSE>=B1);
STICKLINE(买入,B1,B2,3.0,0),COLOR000033;
STICKLINE(买入,B1,B2,2.5,0),COLOR000055;
STICKLINE(买入,B1,B2,2.0,0),COLOR000077;
STICKLINE(买入,B1,B2,1.5,0),COLOR0000BB;
STICKLINE(买入,B1,B2,1.0,0),COLOR0000DD;
STICKLINE(买入,B1,B2,0.5,0),COLORCC66FF;
DRAWTEXT(HIGH>=REF(CLOSE,1)*1.095,H*1.02,'←涨停'),COLORMAGENTA;
STICKLINE(V/REF(V,1)>2,OPEN,CLOSE,1,0),COLOR00FFFF;
DRAWTEXT(REF(CLOSE,1)>=LOW*1.095,LOW,'←跌停'),COLORGREEN;
DRAWTEXT_FIX(1,0,0,0,'【KS】㊣千股千评:'),COLORYELLOW;
DRAWTEXT_FIX(C>0,0.12,0,0,EXTERNSTR(0,1)),COLORRED,LINETHICK2;
DRAWTEXT_FIX(1,0,0.05,0,'【总股本(万股)】'),COLORWHITE;
DRAWNUMBER_FIX(1,0.12,0.05,0,CONST(FINANCE(1)/10000)),COLORMAGENTA;
DRAWTEXT_FIX(1,0,0.1,0,'【所属板块】'),COLORWHITE;
DRAWTEXT_FIX(1,0.12,0.1,0,HYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(1,0.21,0.1,0,DYBLOCK),COLOR0080FF;
DRAWTEXT_FIX(1,0,0.25,0,'【莸利比例】'),COLORWHITE;
DRAWNUMBER_FIX(1,0.12,0.25,0,CONST(WINNER(C )*100)),COLORYELLOW;
DRAWTEXT_FIX(1,0,0.30,0,'【每股收益(元)】'),COLORWHITE;
DRAWNUMBER_FIX(1,0.12,0.30,0,CONST(FINANCE(33))),COLORYELLOW;
DRAWTEXT_FIX(1,0,0.2,0,'【市盈率】'),COLORWHITE;
DRAWNUMBER_FIX(1,0.12,0.20,0,CONST(DYNAINFO(39))),COLORYELLOW;
{量能饱和}
SAT:=IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100);
DRAWTEXT_FIX(1,0,0.15,0,'【量能饱和度】')COLORWHITE;
DRAWNUMBER_FIX(1,0.12,0.15,0,CONST(SAT)),COLORYELLOW;

通达信决策主图指标公式

 

相关文章