在线检测未来函数

飞狐虎口拨牙指标公式

来源:Internet,编辑:股旁网,2015-12-16

A0:=(2*C+H+L)/4;
均线:=ma(A0,3)>ref(ma(A0,3),1);
A1:=(CLOSE-LLV(LOW,7))/(HHV(HIGH,7)-LLV(LOW,7))*100;
A2:=EMA(WINNER(C)*100,5);
A3:=MA(SMA(C-REF(C,1),3,1)/SMA(H-REF(C,1),3,1),3)*100;
K:MA(3*SMA(A1,6,1)-2*SMA(SMA(A1,5,1),5,1),3),LINETHICK2,colorf00ff0;
D:MA(K,3),colorff0000,LINETHICK2;
J:3*K-2*D,LINETHICK2;
A4:=SMA(MAX(C-REF(C,2),0),6,1)/SMA(ABS(C-REF(C,2)),6,1)*100;
A5:=MA(3*SMA((C-LLV(L,21))/(HHV(H,21)-LLV(L,21))*100,5,1)-2*SMA(SMA((C-LLV(L,21))/(HHV(H,21)-LLV(L,21))*100,5,1),3,1),3);
低吸:if(cross(A4,14) or A5>ref(A5,1) and cross(K,A2)and K<40,10,0);
if(A2>80 and cross(95,K),85,100);
跌幅较大:K<5 and llv(c,3)/hhv(c,20)<0.8,color00ff00;
STICKLINE(跌幅较大,0,abs(K*7),6,0),color00ff00;
A6:=count(cross(K,A2),2)=1 and cross(K,A5)and A5/ref(A5,1)>0.9 and K<50;
A7:=cross(K,D)AND D<10 or cross(K,D)AND cross(K,A5)AND D<18;
DRAWTEXT(FILTER((A6 OR A7)and K>ref(K,1),5)and 均线 ,D,'金叉');
DRAWTEXT(cross(D,K)AND cross(A5,K)AND D>85,D,'死叉');
DRAWTEXT(FILTER(K>ref(K,1)and (cross(K,10)or cross(K,A2))and count(A4<14,3)>=1,3),15,'虎口拔牙');
无限风光:A2>85 and K>85 or A2>90 or K>90,LINETHICK0,colorffff00;
STICKLINE(无限风光,max(A2,K),100,6,1),colorffff00;
DRAWICON(cross(A3,-300)and K<10,5,1);
A8:=BARSLAST(REF(CROSS(K,D),1));
二次金叉:=(A8<15 AND D<50 AND K>REF(K,A8+1) AND CROSS(K,D)AND A5<60);
DRAWTEXT(二次金叉 and 均线,K,'二次金叉');
A9:=LLV(C,2)<ref(LLV(C,15),2);
DRAWTEXT(二次金叉 and A9,K,'底背离'),COLORMAGENTA;
DRAWTEXT(LONGCROSS(J,K,7)AND CROSS(J,A2)AND A2<30 AND A2>REF(A2,1),K,'穿三线');
DRAWTEXT(CROSS(84,A4)AND CROSS(K,A4),90,'虎口脱险'),COLOR00FF00;
A10:=MA((A0-MA(A0,13))/(0.15*AVEDEV(A0,13)),3);
DRAWICON(CROSS(A10,-15)AND J>REF(J,1),5,1);
DRAWICON(CROSS(20,A10),100,2);

飞狐虎口拨牙指标公式

 

相关文章