在线检测未来函数

通达信周易算术主图指标公式

来源:Internet,编辑:股旁网,2015-12-16

开盘:=IF(O>REF(O,1),1,2);
收盘:=IF(C>REF(C,1),1,2);
最高:=IF(H>REF(H,1),1,2);
最低:=IF(L>REF(L,1),1,2);
收阳:=IF(C>O,1,2);
量能:=IF(V>REF(V,1),1,2);
八卦:=开盘*100000+收盘*10000+最高*1000+最低*100+收阳*10+量能*1;
{全卦}
乾:=八卦=111111;
履:=八卦=111211;
同人:=八卦=111121;
无妄:=八卦=111221;
姤:=八卦=111112;
讼:=八卦=111212;
遁:=八卦=111122;
否:=八卦=111222;
夬:=八卦=211111;
兑:=八卦=211211;
革:=八卦=211121;
随:=八卦=211221;
大过:=八卦=211112;
困:=八卦=211212;
咸:=八卦=211122;
萃:=八卦=211222;
大有:=八卦=121111;
睽:=八卦=121211;
离:=八卦=121121;
噬嗑:=八卦=121221;
鼎:=八卦=121112;
未济:=八卦=121212;
旅:=八卦=121122;
晋:=八卦=121222;
大壮:=八卦=221111;
归妹:=八卦=221211;
丰:=八卦=221121;
震:=八卦=221221;
恒:=八卦=221112;
解:=八卦=221212;
小过:=八卦=221122;
豫:=八卦=221222;
小畜:=八卦=112111;
中孚:=八卦=112211;
家人:=八卦=112121;
益:=八卦=112221;
巽:=八卦=112112;
涣:=八卦=112212;
渐:=八卦=112122;
观:=八卦=112222;
需:=八卦=212111;
节:=八卦=212211;
既济:=八卦=212121;
屯:=八卦=212221;
井:=八卦=212112;
坎:=八卦=212212;
蹇:=八卦=212122;
比:=八卦=212222;
大畜:=八卦=122111;
损:=八卦=122211;
贲:=八卦=122121;
颐:=八卦=122221;
蛊:=八卦=122112;
蒙:=八卦=122212;
艮:=八卦=122122;
剥:=八卦=122222;
泰:=八卦=222111;
临:=八卦=222211;
明夷:=八卦=222121;
复:=八卦=222221;
升:=八卦=222112;
师:=八卦=222212;
谦:=八卦=222122;
坤:=八卦=222222;
DRAWTEXT(履,L*0.98,'履');
DRAWTEXT(同人,L*0.98,'同人');
DRAWTEXT(无妄,L*0.98,'无妄');
DRAWTEXT(讼,L*0.98,'讼');
DRAWTEXT(夬,L*0.98,'夬');
DRAWTEXT(革,L*0.98,'革');
DRAWTEXT(随,L*0.98,'随');
DRAWTEXT(大过,L*0.98,'大过');
DRAWTEXT(困,L*0.98,'困');
DRAWTEXT(咸,L*0.98,'咸');
DRAWTEXT(萃,L*0.98,'萃');
DRAWTEXT(大有,L*0.98,'大有');
DRAWTEXT(睽,L*0.98,'睽');
DRAWTEXT(噬嗑,L*0.98,'噬嗑');
DRAWTEXT(鼎,L*0.98,'鼎');
DRAWTEXT(未济,L*0.98,'未济');
DRAWTEXT(旅,L*0.98,'旅');
DRAWTEXT(晋,L*0.98,'晋');
DRAWTEXT(大壮,L*0.98,'大壮');
DRAWTEXT(归妹,L*0.98,'归妹');
DRAWTEXT(丰,L*0.98,'丰');
DRAWTEXT(恒,L*0.98,'恒');
DRAWTEXT(解,L*0.98,'解');
DRAWTEXT(小过,L*0.98,'小过');
DRAWTEXT(豫,L*0.98,'豫');
DRAWTEXT(中孚,L*0.98,'中孚');
DRAWTEXT(家人,L*0.98,'家人');
DRAWTEXT(益,L*0.98,'益');
DRAWTEXT(涣,L*0.98,'涣');
DRAWTEXT(渐,L*0.98,'渐');
DRAWTEXT(观,L*0.98,'观');
DRAWTEXT(需,L*0.98,'需');
DRAWTEXT(节,L*0.98,'节');
DRAWTEXT(既济,L*0.98,'既济');
DRAWTEXT(屯,L*0.98,'屯');
DRAWTEXT(井,L*0.98,'井');
DRAWTEXT(蹇,L*0.98,'蹇');
DRAWTEXT(比,L*0.98,'比');
DRAWTEXT(大畜,L*0.98,'大畜');
DRAWTEXT(损,L*0.98,'损');
DRAWTEXT(贲,L*0.98,'贲');
DRAWTEXT(颐,L*0.98,'颐');
DRAWTEXT(蛊,L*0.98,'蛊');
DRAWTEXT(蒙,L*0.98,'蒙');
DRAWTEXT(明夷,L*0.98,'明夷');
DRAWTEXT(升,L*0.98,'升');
DRAWTEXT(师,L*0.98,'师');
DRAWTEXT(谦,L*0.98,'谦');
{特殊}
STICKLINE(遁,O,C,2,0),COLORFF00FF;{遁,洋红色}
DRAWTEXT(遁,L*0.98,'遁'),COLORFF00FF;
STICKLINE(临,O,C,2,0),COLORFF00FF;{临,洋红色}
DRAWTEXT(临,L*0.98,'临'),COLORFF00FF;
STICKLINE(泰,O,C,2,0),COLORFF00FF;{泰,洋红色}
DRAWTEXT(泰,L*0.98,'泰'),COLORFF00FF;
DRAWICON(泰,L*0.95,26),COLORRED;
STICKLINE(否,O,C,2,0),COLORFF00FF;{否,洋红色}
DRAWTEXT(否,L*0.98,'否'),COLORFF00FF;
DRAWICON(否,H,26),COLORRED;
STICKLINE(姤,O,C,2,0),COLORFF00FF;{姤,洋红色}
DRAWTEXT(姤,L*0.98,'姤'),COLORFF00FF;
STICKLINE(小畜,O,C,2,0),COLOR8080FF;{小畜,土红色}
DRAWTEXT(小畜,L*0.98,'小畜'),COLOR8080FF;
STICKLINE(复,O,C,2,0),COLOR00FF00;{复,亮绿色};
DRAWTEXT(复,L*0.98,'复'),COLOR00FF00;
STICKLINE(剥,O,C,2,0),COLOR80FF80;{剥,浅绿色};
DRAWTEXT(剥,L*0.98,'剥'),COLOR80FF80;
STICKLINE(夬,O,C,2,0),COLOR9060CD;
STICKLINE(履,O,C,2,0),COLOR3333CD;
STICKLINE(井,O,C,2,0),COLORCD96CD;
{五行}
金_乾:=八卦=111111;
金_兑:=八卦=211211;
木_震:=八卦=221221;
木_巽:=八卦=112112;
水_坎:=八卦=212212;
火_离:=八卦=121121;
土_坤:=八卦=222222;
土_艮:=八卦=122122;
{五行}
STICKLINE(金_乾,O,C,2,0),COLOR00FFFF;{黄色}
DRAWTEXT(金_乾,H*1.02,'金'),COLOR00FFFF;
DRAWTEXT(金_乾,L*0.98,'乾'),COLOR00FFFF;
STICKLINE(金_兑,O,C,2,0),COLOR00FFFF;{黄色}
DRAWTEXT(金_兑,H*1.02,'金'),COLOR00FFFF;
DRAWTEXT(金_兑,L*0.98,'兑'),COLOR00FFFF;
STICKLINE(木_震,O,C,2,0),COLOR008000;{绿色}
DRAWTEXT(木_震,H*1.02,'木'),COLOR008000;
DRAWTEXT(木_震,L*0.98,'震'),COLOR008000;
STICKLINE(木_巽,O,C,2,0),COLOR008000;{绿色}
DRAWTEXT(木_巽,H*1.02,'木'),COLOR008000;
DRAWTEXT(木_巽,L*0.98,'巽'),COLOR008000;
STICKLINE(水_坎,O,C,2,0),COLORFF8000;{蓝色}
DRAWTEXT(水_坎,H*1.02,'水'),COLORFF8000;
DRAWTEXT(水_坎,L*0.98,'坎'),COLORFF8000;
STICKLINE(火_离,O,C,2,0),COLOR0000FF;{红色}
DRAWTEXT(火_离,H*1.02,'火'),COLOR0000FF;
DRAWTEXT(火_离,L*0.98,'离'),COLOR0000FF;
STICKLINE(土_坤,O,C,2,0),COLOR0080FF;{褐色};
DRAWTEXT(土_坤,H*1.02,'土'),COLOR0080FF;
DRAWTEXT(土_坤,L*0.98,'坤'),COLOR0080FF;
STICKLINE(土_艮,O,C,2,0),COLOR0080FF;{褐色};
DRAWTEXT(土_艮,H*1.02,'土'),COLOR0080FF;
DRAWTEXT(土_艮,L*0.98,'艮'),COLOR0080FF;
MA5:MA(C,5);
MA10:MA(C,10);
MA20:MA(C,20);
MA30:MA(C,30);

通达信周易算术主图指标公式

 

相关文章