在线检测未来函数

通达信新交易量指标公式

来源:Internet,编辑:股旁网,2015-12-21

M1:=3;
M2:=5;
M3:=10;
涨幅百分比:=1.25;
验证宽容期:=1;
尾部验证期:=240;
交易量:VOL,COLORRED,NODRAW;
{红}
红色条件0:=C>=O;
红色条件1:=0;
红色条件2:=VOL;
STICKLINE(红色条件0,红色条件1,红色条件2,3.0,0),COLOR0000FF;
STICKLINE(红色条件0,红色条件1,红色条件2,2.7,0),COLOR000077;
STICKLINE(红色条件0,红色条件1,红色条件2,2.1,0),COLOR000099;
STICKLINE(红色条件0,红色条件1,红色条件2,1.5,0),COLOR0000BB;
STICKLINE(红色条件0,红色条件1,红色条件2,0.9,0),COLOR0000DD;
STICKLINE(红色条件0,红色条件1,红色条件2,0.3,0),COLOR0000FF;
{青}
青色条件0:=C<O;
青色条件1:=0;
青色条件2:=VOL;
STICKLINE(青色条件0,青色条件1,青色条件2,3.0,0),COLOREEEE00;
STICKLINE(青色条件0,青色条件1,青色条件2,2.7,0),COLOR666600;
STICKLINE(青色条件0,青色条件1,青色条件2,2.1,0),COLOR888800;
STICKLINE(青色条件0,青色条件1,青色条件2,1.5,0),COLORAAAA00;
STICKLINE(青色条件0,青色条件1,青色条件2,0.9,0),COLORCCCC00;
STICKLINE(青色条件0,青色条件1,青色条件2,0.3,0),COLOREEEE00;
{倍量柱}
倍量柱:=VOL>=REF(VOL,1)*1.91 AND C>REF(C,1)*1.01;
{粉}
粉色条件0:=倍量柱;
粉色条件1:=0;
粉色条件2:=VOL;
STICKLINE(粉色条件0,粉色条件1,粉色条件2,3.0,0),COLORFF99FF;
STICKLINE(粉色条件0,粉色条件1,粉色条件2,2.7,0),COLORFF55FF;
STICKLINE(粉色条件0,粉色条件1,粉色条件2,2.1,0),COLORFF66FF;
STICKLINE(粉色条件0,粉色条件1,粉色条件2,1.5,0),COLORFF77FF;
STICKLINE(粉色条件0,粉色条件1,粉色条件2,0.9,0),COLORFF88FF;
STICKLINE(粉色条件0,粉色条件1,粉色条件2,0.3,0),COLORFF99FF;
{黄}
黄色条件0:=FILTER(倍量柱,3);
黄色条件1:=0;
黄色条件2:=VOL;
STICKLINE(黄色条件0,黄色条件1,黄色条件2,3.0,0),COLOR00FFFF;
STICKLINE(黄色条件0,黄色条件1,黄色条件2,2.7,0),COLOR0033FF;
STICKLINE(黄色条件0,黄色条件1,黄色条件2,2.1,0),COLOR0066FF;
STICKLINE(黄色条件0,黄色条件1,黄色条件2,1.5,0),COLOR0099FF;
STICKLINE(黄色条件0,黄色条件1,黄色条件2,0.9,0),COLOR00CCFF;
STICKLINE(黄色条件0,黄色条件1,黄色条件2,0.3,0),COLOR00FFFF;
背离:IF(VOL<REF(VOL,1) AND C>REF(C,1) AND REF(BARSLASTCOUNT(C<O)>=3,1),1,0),COLORWHITE;
STICKLINE(量背离,0,VOL,0,0),COLORWHITE;
MA03:MA(交易量,M1),COLORWHITE;
MA05:MA(交易量,M2),COLORYELLOW;
MA10:MA(交易量,M3),COLORMAGENTA;
XG:=量背离;
{买入条件}
买入条件:=XG>0;
{买入验证条件}
比较收盘价:=C+(C*涨幅百分比/100);
买入宽容条件:=IF(验证宽容期=1,REFX(C,1)>比较收盘价,
IF(验证宽容期=2,(REFX(C,1)>比较收盘价 OR REFX(C,2)>比较收盘价),
IF(验证宽容期=3,(REFX(C,1)>比较收盘价 OR REFX(C,2)>比较收盘价 OR REFX(C,3)>比较收盘价),
IF(验证宽容期=4,(REFX(C,1)>比较收盘价 OR REFX(C,2)>比较收盘价 OR REFX(C,3)>比较收盘价 OR REFX(C,4)>比较收盘价),
IF(验证宽容期=5,(REFX(C,1)>比较收盘价 OR REFX(C,2)>比较收盘价 OR REFX(C,3)>比较收盘价 OR REFX(C,4)>比较收盘价 OR REFX(C,5)>比较收盘价),
IF(验证宽容期=6,(REFX(C,1)>比较收盘价 OR REFX(C,2)>比较收盘价 OR REFX(C,3)>比较收盘价 OR REFX(C,4)>比较收盘价 OR REFX(C,5)>比较收盘价 OR REFX(C,6)>比较收盘价),
IF(验证宽容期=7,(REFX(C,1)>比较收盘价 OR REFX(C,2)>比较收盘价 OR REFX(C,3)>比较收盘价 OR REFX(C,4)>比较收盘价 OR REFX(C,5)>比较收盘价 OR REFX(C,6)>比较收盘价 OR REFX(C,7)>比较收盘价),
IF(验证宽容期=8,(REFX(C,1)>比较收盘价 OR REFX(C,2)>比较收盘价 OR REFX(C,3)>比较收盘价 OR REFX(C,4)>比较收盘价 OR REFX(C,5)>比较收盘价 OR REFX(C,6)>比较收盘价 OR REFX(C,7)>比较收盘价 OR REFX(C,8)>比较收盘价),
IF(验证宽容期=9,(REFX(C,1)>比较收盘价 OR REFX(C,2)>比较收盘价 OR REFX(C,3)>比较收盘价 OR REFX(C,4)>比较收盘价 OR REFX(C,5)>比较收盘价 OR REFX(C,6)>比较收盘价 OR REFX(C,7)>比较收盘价 OR REFX(C,8)>比较收盘价 OR REFX(C,9)>比较收盘价),DRAWNULL)))))))));
买入验证:=买入条件 AND 买入宽容条件;
{买入标记}
DRAWICON(买入条件,0,1);
DRAWICON(买入验证,0,9);
{买入统计}
全部周期:=TOTALBARSCOUNT,COLORRED,NODRAW;
间隔周期:=INTPART(全部周期/COUNT(买入条件,-1)),COLORGREEN,NODRAW;
买入次数:=COUNT(买入条件,-1);
正确次数:=COUNT(买入验证,-1);
正确率%:=正确次数/买入次数*100,COLOR17ACFD,NODRAW;
显示字符串:=STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(
'全部周期=',
CON2STR(全部周期,0)),
' 间隔周期='),
CON2STR(间隔周期,0)),
' 买入次数='),
CON2STR(买入次数,0)),
' 涨幅百分比%='),
CON2STR(涨幅百分比,2)),
' 正确次数='),
CON2STR(正确次数,0)),
' 正确率%='),
CON2STR(正确次数/买入次数*100,0)),
' 尾部验证期='),
CON2STR(尾部验证期,0)),
' 尾部正确率%='),
CON2STR(COUNT(买入验证,尾部验证期)/COUNT(买入条件,尾部验证期)*100,0));
DRAWTEXT_FIX(1,0.2,0.02,0,显示字符串),COLOR038CBA;

通达信新交易量指标公式

 

相关文章