在线检测未来函数

飞狐综合看盘指标公式

来源:Internet,编辑:股旁网,2015-12-23

N:=5;
DRAWGBK(1,COLORRGB(265,0,0),COLORRGB(265,285,0),0);
A0:=NUMTOSTR(MA(VOL,5),2);
B0:=NUMTOSTR(MA(VOL/CAPITAL*100,5)*5,2);
TYP:=(HIGH+LOW+CLOSE)/3;
LL:=LLV(LOW,12);
HH:=HHV(HIGH,12);
WR:=TYP+TYP-LL;
WS:=TYP-(HH-TYP);
WA:=NUMTOSTR(WR,2);
WB:=NUMTOSTR(WS,2);
DRAWTEXT(BARPOS=SYSPARAM(2),HIGH,STKNAME+'\n'+STKLABEL+'\n'+BLKNAME),ALIGN4,colorFF00;
KZF:=OPEN/REF(CLOSE,1)*100-100;
TZF:=OPEN/CLOSE*100-100;
KZF>8.5 AND TZF>5 AND CLOSE>REF(CLOSE,1) AND VOL/REF(VOL,1)>2 AND HIGH=OPEN;
MACD:="MACD.MACD";
X:=MACD<0 AND MACD>REF(MACD,1);
SUM(X,SUMBARS(CROSS(0,MACD),1))=1 AND X;
VQ1:=(HIGH+LOW+OPEN+2*CLOSE)/5;
VQ2:=REF(VQ1,1);
VQ3:=(SMA(MAX(VQ1-VQ2,0),N,1))/(SMA(ABS(VQ1-VQ2),N,1))*100;
HY:=IF((COUNT(VQ3<20,7))>=1 AND (COUNT(VQ1=LLV(VQ1,5),5))>=1 AND CLOSE>OPEN AND REF(CLOSE,1)>REF(OPEN,1) AND VOL>REF(VOL,1),1,0);
GD:=IF(HY>0,1,0);
VAR1:=EMA(CLOSE,5)/EMA(CLOSE,10);
VAR2:=EMA(INDEXC,5)/EMA(INDEXC,10);
关注:(VAR1*VAR2-1)*1000,COLORSTICK;
LI:DRAWTEXT(GD,20,'☆关注 '),colorFFFF;
VAR1:=REF(CLOSE,2);
A2:(SMA(MAX(CLOSE-VAR1,0),7,1))/(SMA(ABS(CLOSE-VAR1),7,1))*100,colorFFFFFF;
考虑补仓:IF(A2<12,30,0),colorFF0000;
VAR2:=REF(CLOSE,1);
VAR3:=(SMA(MAX(CLOSE-VAR2,0),7,1))/(SMA(ABS(CLOSE-VAR2),7,1))*100;
及时回补:IF(VAR3<12,30,0),colorFFFF;
逢高派发:STICKLINE(A2>80,A2+1,A2-1,8,0),colorFF;
落袋为安:IF(A2<REF(A2,1) AND A2>79,A2,0),colorFF00FF;
趋势线:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
见底信号:=10;
买点准备:IF(趋势线<=10,50,0),colorFFFF00;
买入时间:IF(CROSS(趋势线,见底信号),50,0),colorFF00;
VAR1:=3;
VAR2:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
机构建增补仓区域:IF(VAR2<5,45,0),colorFFFFFF;
R1:=MA(WINNER(CLOSE*0.9)*100*CLOSE,3);
资金比:=(IF(R1>5,R1,0))/2;
资金均量:=MA(资金比,5);
VAR01:=REF(CLOSE,1);
VAR02:=(SUM(IF(CLOSE>VAR01,VOL,0),26))/(SUM(IF(CLOSE<VAR01,VOL,0),26))*100;
股价比:=EMA(VAR02,5);
EXPLAIN(1=1,'【资金分析】'),colorFFFF;
EXPLAIN(股价比<40,'该股处在底部区;'),colorFFCC66;
EXPLAIN(股价比>=40 AND 股价比<80,'该股处在低位区;'),colorFFCC66;
EXPLAIN(股价比>=80 AND 股价比<160,'该股处在盘整区;'),colorFFCC66;
EXPLAIN(股价比>=160,'该股处在获利区;'),colorFFCC66;
EXPLAIN(资金比>10 AND 资金比>资金均量,'有增量资金进入;'),colorFFCC66;
EXPLAIN(资金比>10 AND 资金比<REF(资金比,1) AND 资金比<资金均量,'存量资金减量;'),colorFFCC66;
EXPLAIN(1=1,'【股价预测】'),colorFFFF;
VAR011:=(CLOSE+HIGH+LOW)/3;
VAR012:=HIGH-LOW;
VAR014:=VAR011+VAR012;
VAR015:=VAR011-VAR012;
VAR016:=2*VAR011-LOW;
VAR017:=2*VAR011-HIGH;
明日转:=REF(CLOSE,2)*2-REF(CLOSE,5);
EXPLAINEX(VOL>0,'【明天生命】=',明日转,1,0),colorFFFFFF;
EXPLAINEX(VOL>0,'【明天最高】=',VAR014,1,0),colorFFFF;
EXPLAINEX(VOL>0,'【范围上限】=',VAR016,1,0),colorFF00FF;
EXPLAINEX(VOL>0,'【范围下限】=',VAR017,1,0),colorFFFF00;
EXPLAINEX(VOL>0,'【明天最低】=',VAR015,1,0),colorFF00;
AA:=VOL/((HIGH-LOW)*2-(ABS(CLOSE-OPEN)));
主动买盘:=IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*(HIGH-OPEN+CLOSE-LOW),VOL/2));
主动卖盘:=IF(CLOSE>OPEN,-AA*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,-AA*(HIGH-LOW),-VOL/2));
促进指数MFL:(HIGH-LOW)*1000000/VOL,LINETHICK0,colorFF;
MFI:=(HIGH-LOW)*1000000/VOL;
绿灯:=MFI>=REF(MFI,1) AND VOL>=REF(VOL,1);
衰退:=MFI<=REF(MFI,1) AND VOL<=REF(VOL,1);
伪装:=MFI>=REF(MFI,1) AND VOL<=REF(VOL,1);
蛰伏:=MFI<=REF(MFI,1) AND VOL>=REF(VOL,1);
卖盘:=VOL-主动买盘;
卖盘大:=(卖盘-主动买盘)/卖盘>0.6;
买盘大:=(主动买盘-卖盘)/主动买盘>0.6;
WJ:=(HIGH+LOW+CLOSE)/3;
VD1:=IF(HIGH=LOW,1,HIGH-MAX(OPEN,CLOSE));
VD2:=IF(HIGH=LOW,1,MAX(CLOSE,OPEN)-WJ);
VD3:=IF(HIGH=LOW,1,MIN(OPEN,CLOSE)-LOW);
VD4:=IF(HIGH=LOW,1,WJ-MIN(CLOSE,OPEN));
VD5:=VOL/(IF(HIGH=LOW,4,HIGH-LOW));
VD6:=VD1*VD5;
VD7:=VD2*VD5;
VD8:=VD3*VD5;
VD9:=VD4*VD5;
买入量:=VD9+VD8;
卖出量:=-VD6+VD7;
卖量:=VOL-买入量;
卖量大:=(卖量-买入量)/卖量>0.4;
买量大:=(买入量-卖量)/买入量>0.4;
EXPLAIN(1=1,'【买卖盘解量】'),colorFFFF;
EXPLAIN(绿灯,'[绿灯]+实计交易量增加。+MFI促进指数增加。'),colorFF;
EXPLAIN(衰退,'[衰退]-实计交易量减少。-MFI促进指数减少。'),colorFF00;
EXPLAIN(伪装,'[伪装]-实计交易量减少。+MFI促进指数增加。'),color9900;
EXPLAIN(蛰伏,'[蛰伏]+实计交易量增加。-MFI促进指数减少。'),colorFFFF;
EXPLAIN(卖盘大,'★主动卖盘大于主动买盘60%以上;'),color9900;
EXPLAIN(买盘大,'★主动买盘大于主动卖盘60%以上;'),colorFFFF;
EXPLAIN(卖量大,'☆卖出量大于买入量40%以上;'),color9900;
EXPLAIN(买量大,'☆买入量大于卖出量40%以上;'),colorFFFF;
EXPLAIN(1=1,'【控盘情况】'),colorFFFF;
EXPLAINEX(1=1,'当日主动买卖盘(手)=',VOL,2,0),colorFFCCFF;
EXPLAINEX(1=1,'其中主动买盘(手)=',主动买盘,2,0),colorFFCCFF;
EXPLAINEX(1=1,'主动卖盘(手)=',主动卖盘,2,0),colorFFCCFF;
EXPLAINEX(1=1,'当日买卖量(手)=',VOL,2,0),colorFFCCFF;
EXPLAINEX(1=1,'其中买入量(手)=',买入量,2,0),colorFFCCFF;
EXPLAINEX(1=1,'卖出量(手)=',卖出量,2,0),colorFFCCFF;

飞狐综合看盘指标公式

 

相关文章