在线检测未来函数

飞狐区间分类指标公式

来源:Internet,编辑:股旁网,2015-12-24

DRAWGBK(1,COLORRGB(265,0,0),COLORRGB(265,285,0),0);
IF MARKETLABEL<>'SH' THEN
DRAWTEXTEX(CLOSE,1,5,20,''+STKLABEL),colorFFFF;
P:=SYSPARAM(1);
A2:=SYSPARAM(2);
A3:=SYSPARAM(3);
KS:=SYSPARAM(3)-SYSPARAM(2);
Z:=KS/140;
W1:=ROUND(70*Z);
VERTLINE(BARPOS=A2+ROUND(42*Z)),colorFF00FF;
VERTLINE(BARPOS=A2+ROUND(68*Z)),colorFF00FF;
总股本:=CAPITAL;
基数:=CAPITAL/5000000;
基准股:=总股本*0.1;
DRAWTEXT(BARPOS=A2+ROUND(5*Z),-4,'区间分类:'),ALIGN0,colorFFFF;
DRAWTEXT(BARPOS=A2+ROUND(74*Z),-4,'0.1万'),ALIGN0,colorFF;
DRAWTEXT(BARPOS=A2+ROUND(82*Z),-4,'1万'),ALIGN0,colorFF;
DRAWTEXT(BARPOS=A2+ROUND(90*Z),-4,'5万'),ALIGN0,colorFF;
DRAWTEXT(BARPOS=A2+ROUND(98*Z),-4,'10万'),ALIGN0,colorFF;
DRAWTEXT(BARPOS=A2+ROUND(106*Z),-4,'50万'),ALIGN0,colorFF;
DRAWTEXT(BARPOS=A2+ROUND(112*Z),-4,'100万'),ALIGN0,colorFF;
DRAWTEXT(BARPOS=A2+ROUND(120*Z),-4,'500万'),ALIGN0,colorFF;
DRAWTEXT(BARPOS=A2+ROUND(129*Z),-4,'1000万'),ALIGN0,colorFF;
DRAWTEXT(BARPOS=A2+ROUND(138*Z),-4,'1000万以上'),ALIGN0,colorED;
XX:=A3-P;
KDCM:=100*WINNER(REF(CLOSE,XX));
SHTL:=100*(1-WINNER(REF(CLOSE,XX)));
DDCM:=EMA(100*WINNER(REF(CLOSE,XX)),13);
总:=总股本;
券基:=DDCM*总*0.003+KDCM*总*0.004;
普通:=SHTL*总*0.008,LINETHICK0;
法人:=ABS(总-券基-普通);
虚拟总:=券基+普通+法人;
券基户数:=INTPART(ABS(DDCM)*基数*0.008);
法人户数:=INTPART(ABS(KDCM)*基数*0.02);
普通户数:INTPART(SHTL*20*基数),LINETHICK0;
总户数:=券基户数+法人户数+普通户数;
STICKLINE(BARPOS=A2+ROUND(62*Z),20,20*(券基/虚拟总)+20,15,0),colorFF;
STICKLINE(BARPOS=A2+ROUND(56*Z),20,20*(法人/虚拟总)+20,15,0),colorFFFF;
STICKLINE(BARPOS=A2+ROUND(48*Z),20,20*(普通/虚拟总)+20,15,0),colorFF00;
DRAWTEXT(BARPOS=A2+ROUND(62*Z),-4,'券基'),ALIGN0,colorFF;
DRAWTEXT(BARPOS=A2+ROUND(56*Z),-4,'法人'),ALIGN0,colorFFFF;
DRAWTEXT(BARPOS=A2+ROUND(48*Z),-4,'普通'),ALIGN0,colorFF00;
DRAWTEXT(BARPOS=A2+ROUND(62*Z),6,NUMTOSTR(券基户数,0)),ALIGN0,colorFFFFFF;
DRAWTEXT(BARPOS=A2+ROUND(56*Z),6,NUMTOSTR(法人户数,0)),ALIGN0,colorFFFFFF;
DRAWTEXT(BARPOS=A2+ROUND(48*Z),6,NUMTOSTR(普通户数,0)),ALIGN0,colorFFFFFF;
DRAWTEXT(BARPOS=A2+ROUND(62*Z),15,NUMTOSTR(券基,0)),ALIGN0,colorFF;
DRAWTEXT(BARPOS=A2+ROUND(56*Z),15,NUMTOSTR(法人,0)),ALIGN0,colorFFFF;
DRAWTEXT(BARPOS=A2+ROUND(48*Z),15,NUMTOSTR(普通,0)),ALIGN0,colorFF00;
特大:=MAX(DDCM,0)*总*0.009,LINETHICK0;
大户:=KDCM*总*0.003+DDCM*总*0.001;
散户:=SHTL*总*0.008;
中户:=ABS(总-特大-大户-散户);
特大比:特大/散户,LINETHICK0;
散户比:散户/特大,LINETHICK0;
ZZ:=特大+大户+散户+中户;
户数过渡:=RAND(20);
特大户数:=ABS(券基户数-户数过渡);
大户户数:=法人户数+户数过渡;
中户户数:=2*户数过渡;
散户户数:=普通户数;
STICKLINE(BARPOS=A2+ROUND(36*Z),20,20*(特大/ZZ)+20,15,0),colorFF;
STICKLINE(BARPOS=A2+ROUND(29*Z),20,20*(大户/ZZ)+20,15,0),colorFFFF;
STICKLINE(BARPOS=A2+ROUND(22*Z),20,20*(中户/ZZ)+20,15,0),colorFF00;
STICKLINE(BARPOS=A2+ROUND(15*Z),20,20*(散户/ZZ)+20,15,0),color18A4FF;
DRAWTEXT(BARPOS=A2+ROUND(36*Z),-4,'特大'),ALIGN0,colorFF;
DRAWTEXT(BARPOS=A2+ROUND(29*Z),-4,'大户'),ALIGN0,colorFFFF;
DRAWTEXT(BARPOS=A2+ROUND(22*Z),-4,'中户'),ALIGN0,colorFF00;
DRAWTEXT(BARPOS=A2+ROUND(15*Z),-4,'散户'),ALIGN0,color18A4FF;
DRAWTEXT(BARPOS=A2+ROUND(36*Z),6,NUMTOSTR(特大户数,0)),ALIGN0,colorFFFFFF;
DRAWTEXT(BARPOS=A2+ROUND(29*Z),6,NUMTOSTR(大户户数,0)),ALIGN0,colorFFFFFF;
DRAWTEXT(BARPOS=A2+ROUND(22*Z),6,NUMTOSTR(中户户数,0)),ALIGN0,colorFFFFFF;
DRAWTEXT(BARPOS=A2+ROUND(15*Z),6,NUMTOSTR(散户户数,0)),ALIGN0,colorFFFFFF;
DRAWTEXT(BARPOS=A2+ROUND(36*Z),15,NUMTOSTR(特大,0)),ALIGN0,colorFF;
DRAWTEXT(BARPOS=A2+ROUND(29*Z),15,NUMTOSTR(大户,0)),ALIGN0,colorFFFF;
DRAWTEXT(BARPOS=A2+ROUND(22*Z),15,NUMTOSTR(中户,0)),ALIGN0,colorFF00;
DRAWTEXT(BARPOS=A2+ROUND(15*Z),15,NUMTOSTR(散户,0)),ALIGN0,color18A4FF;
A1K:=SHTL*总*0.008+基准股*0.5+DDCM*总*0.001;
A1W:=SHTL*总*0.004+基准股*0.7+DDCM*总*0.002;
A5W:=SHTL*总*0.002+基准股*0.9+DDCM*总*0.002;
A10W:=基准股*0.15+KDCM*总*0.0002;
A50W:=基准股*0.3+KDCM*总*0.0001;
A100W:=基准股*0.1+KDCM*总*0.0001;
A500W:=DDCM*总*0.01+KDCM*总*0.0001;
A1000W:=DDCM*总*0.02+KDCM*总*0.0002;
A1000WP:=DDCM*总*0.05,LINETHICK0;
总价:=A1K+A1W+A5W+A10W+A50W+A100W+A500W+A1000W+A1000WP,LINETHICK0;
B1000w:=A1000W/总价*100,LINETHICK0;
B1000WP:A1000WP/总价*100,LINETHICK0;
B1K:(A1K/总价)*100,LINETHICK0;
{特大比:B1000WP/B1K,LINETHICK0;
散户比:B1K/B1000WP,LINETHICK0;}
STICKLINE(BARPOS=A2+ROUND(74*Z),20,20*(A1K/总价)+20,15,0),colorFFFFFF;
STICKLINE(BARPOS=A2+ROUND(82*Z),20,20*(A1W/总价)+20,15,0),color18A4FF;
STICKLINE(BARPOS=A2+ROUND(90*Z),20,20*(A5W/总价)+20,15,0),colorFFFF;
STICKLINE(BARPOS=A2+ROUND(98*Z),20,20*(A10W/总价)+20,15,0),colorFF00;
STICKLINE(BARPOS=A2+ROUND(106*Z),20,20*(A50W/总价)+20,15,0),colorFFFF00;
STICKLINE(BARPOS=A2+ROUND(112*Z),20,20*(A100W/总价)+20,15,0),colorFFA826;
STICKLINE(BARPOS=A2+ROUND(120*Z),20,20*(A500W/总价)+20,15,0),colorFF69B4;
STICKLINE(BARPOS=A2+ROUND(129*Z),20,20*(A1000W/总价)+20,15,0),color9732F6;
STICKLINE(BARPOS=A2+ROUND(137*Z),20,20*(A1000WP/总价)+20,15,0),colorFF;
FILLRGN(CLOSE,-7,-7-0.01);
DRAWTEXT(BARPOS=A2+ROUND(74*Z),12,NUMTOSTR(A1K,0)),ALIGN0,colorFF;
DRAWTEXT(BARPOS=A2+ROUND(82*Z),12,NUMTOSTR(A1W,0)),ALIGN0,colorFF0000;
DRAWTEXT(BARPOS=A2+ROUND(90*Z),12,NUMTOSTR(A5W,0)),ALIGN0,colorFF00;
DRAWTEXT(BARPOS=A2+ROUND(98*Z),12,NUMTOSTR(A10W,0)),ALIGN0,colorFFFF;
DRAWTEXT(BARPOS=A2+ROUND(106*Z),12,NUMTOSTR(A50W,0)),ALIGN0,color808080;
DRAWTEXT(BARPOS=A2+ROUND(114*Z),12,NUMTOSTR(A100W,0)),ALIGN0,colorFF00;
DRAWTEXT(BARPOS=A2+ROUND(122*Z),12,NUMTOSTR(A500W,0)),ALIGN0,colorFF00;
DRAWTEXT(BARPOS=A2+ROUND(130*Z),12,NUMTOSTR(A1000W,0)),ALIGN0,colorFF;
DRAWTEXT(BARPOS=A2+ROUND(137*Z),12,NUMTOSTR(A1000WP,0)),ALIGN0,colorFF;
DRAWTEXT(BARPOS=A2+ROUND(5*Z),25,'分类持仓%:'),ALIGN0,colorFFFF;
DRAWTEXT(BARPOS=A2+ROUND(74*Z),18,NUMTOSTR(A1K/总价*100,2)+'%'),ALIGN0,colorFFFFFF;
DRAWTEXT(BARPOS=A2+ROUND(82*Z),18,NUMTOSTR(A1W/总价*100,2)+'%'),ALIGN0,color18A4FF;
DRAWTEXT(BARPOS=A2+ROUND(90*Z),18,NUMTOSTR(A5W/总价*100,2)+'%'),ALIGN0,colorFFFF;
DRAWTEXT(BARPOS=A2+ROUND(98*Z),18,NUMTOSTR(A10W/总价*100,2)+'%'),ALIGN0,colorFF00;
DRAWTEXT(BARPOS=A2+ROUND(106*Z),18,NUMTOSTR(A50W/总价*100,2)+'%'),ALIGN0,colorFFFF00;
DRAWTEXT(BARPOS=A2+ROUND(112*Z),18,NUMTOSTR(A100W/总价*100,2)+'%'),ALIGN0,colorFFA826;
DRAWTEXT(BARPOS=A2+ROUND(121*Z),18,NUMTOSTR(A500W/总价*100,2)+'%'),ALIGN0,colorFF69B4;
DRAWTEXT(BARPOS=A2+ROUND(129*Z),18,NUMTOSTR(A1000W/总价*100,2)+'%'),ALIGN0,color9732F6;
DRAWTEXT(BARPOS=A2+ROUND(137*Z),18,NUMTOSTR(A1000WP/总价*100,2)+'%'),ALIGN0,colorFF;
DRAWTEXT(BARPOS=A2+ROUND(5*Z),6,'参数:'),ALIGN0,colorFFFF;
VARIABLE:WDAY[7]='星期六';
WDAY[1]:='星期日';
WDAY[2]:='星期一';
WDAY[3]:='星期二';
WDAY[4]:='星期三';
WDAY[5]:='星期四';
WDAY[6]:='星期五';
FY:=YEAR;
FM:=MONTH;
FD:=DAY;
WD:=WEEKDAY;
STR1:=''+' '+NUMTOSTR(FY[P],0)+'年'+NUMTOSTR(FM[P],0)+'月'+NUMTOSTR(FD[P],0)+'日 '+WDAY[WD[P]+1]+' '+' ';
DRAWTEXTEX(CLOSE,1,680,0,''+STR1);
DRAWTEXTEX(CLOSE,1,880,0,' '),colorFF;

飞狐区间分类指标公式

 

相关文章