在线检测未来函数

通达信大单BBD指标公式

来源:Internet,编辑:股旁网,2016-01-07

AL:=(C+L+H)/3;
AO:=SMA(AL,13,1)-SMA(AL,34,1);
BBD:(AO-SMA(AO, 5,1))*100,COLORFFCCFF,NODRAW;
BBDA:SMA(BBD,5,2),COLORRED,LINETHICK0;
RSV1:=BBD;
RSV2:=BBDA;
{BBD彩色柱体}
VAR11:=IF(DATE<1091230 AND DATE>900101,1,0);
BBD1:=IF(BBD>=REF(BBD,1)*VAR11,BBD,DRAWNULL);
BBD2:=IF(BBD<REF(BBD,1)*VAR11,BBD,DRAWNULL);
STICKLINE(BBD1,0,BBD,3,0),COLOR000088;
STICKLINE(BBD1,0,BBD,1.5,0),COLOR0000AA;
STICKLINE(BBD1,0,BBD,1,0),COLOR0000CC;
STICKLINE(BBD1,0,BBD,0.5,0),COLOR0000FF;
STICKLINE(BBD2,0,BBD,3,0),COLOR888800;
STICKLINE(BBD2,0,BBD,1.5,0),COLORAAAA00;
STICKLINE(BBD2,0,BBD,1,0),COLORCCCC00;
STICKLINE(BBD2,0,BBD,0.5,0),COLORFFFF00;
{SV1:=BARSLAST(REF(CROSS(RSV1,RSV2),1));
SV1A:=REF(CLOSE,SV1+1)>CLOSE AND RSV1>REF(RSV1,SV1+1) AND
CROSS(RSV1,RSV2);
上涨BBD:IF(SV1A,RSV2,DRAWNULL),COLORRED;
DRAWTEXT(SV1A,RSV2,'─B底背'),COLOR0033FF;
SV2:=BARSLAST(REF(CROSS(RSV2,RSV1),1));
SV2A:=REF(CLOSE,SV2+1)<CLOSE AND REF(RSV1,SV2+1)>RSV1 AND CROSS(RSV2,RSV1);
下跌BBD:IF(SV2A,RSV2,DRAWNULL),COLORFFFF00;}
DRAWICON(((((LLV(BBD,4) > 0) AND (BBD < REF(BBD,1)))
AND (REF(BBD,1) > REF(BBD,2))) AND (REF(BBD,2) > REF(BBD,3)))
,BBD,2);
DRAWICON(((((HHV(BBD,4) < 0) AND (BBD > REF(BBD,1))) AND (REF(BBD,1) < REF(BBD,2))) AND (REF(BBD,2) <
REF(BBD,3))),BBD,1);

通达信大单BBD指标公式

 

相关文章