在线检测未来函数

通达信2016第一个好的主图指标公式

来源:Internet,编辑:股旁网,2016-01-11

DA:(3*CLOSE+OPEN+LOW+HIGH)/6,POINTDOT;
X2:(20*DA+19*REF(DA,1)+18*REF(DA,2)+17*REF(DA,3)+16*REF(DA,4)+15*REF(DA,5)+14*REF(DA,6)+13*REF(DA,7)+12*REF(DA,8)+11*REF(DA,9)+10*REF(DA,10)+9*REF(DA,11)+8*REF(DA,12)+7*REF(DA,13)+6*REF(DA,14)+5*REF(DA,15)+4*REF(DA,16)+3*REF(DA,17)+2*REF(DA,18)+REF(DA,20))/210,COLORF0F000;
X3:MA(X2,5),COLORYELLOW,LINETHICK1;
X1:=(C+L+H)/3;
买:=CROSS(X2,X3);
卖:=CROSS(X3,X2);
DRAWICON(买,L*0.95,1);
DRAWICON(CROSS(X2,X3),L*0.97,7);
DRAWICON(卖,H*1.04,2);
DRAWICON(CROSS(X3,X2),H*1.02,8);
STICKLINE(X2>=X3,LOW,HIGH,0,1),COLORRED;
STICKLINE(X2>=X3,CLOSE,OPEN,3.2,2),COLORRED;
STICKLINE(X2<X3,LOW,HIGH,0,1),COLOR00FF00;
STICKLINE(X2<X3,CLOSE,OPEN,3.2,2),COLOR00FF00;
STICKLINE(CROSS(X3,X2),OPEN,CLOSE,3.2,0),COLOR00FF00;
STICKLINE(CROSS(X2,X3),OPEN,CLOSE,3.2,0),COLORRED;
STICKLINE((CLOSE>OPEN) AND (X2<X3),CLOSE,OPEN,3.2,2)COLOR00FF00;
STICKLINE((CLOSE>OPEN) AND (X2>=X3),CLOSE,OPEN,3.2,2)COLORRED;
STICKLINE((CLOSE<OPEN) AND (X2<X3),CLOSE,OPEN,3.2,0)COLOR00FF00;
STICKLINE((CLOSE<OPEN) AND (X2>=X3),CLOSE,OPEN,3.2,0)COLORRED;
止损价:STICKLINE(ISLASTBAR,HHV(C,5)*0.95,HHV(C,5)*0.95,20,2)LINETHICK2;
止盈价:H*0.95,LINETHICK0.5,COLORRED;
{止盈价盘中破掉三十分钟不再站上来,立即止盈出局}
阻力价:HHV(HIGH,19),LINETHICK1,NODRAW;
Y:=(MA(C,5)-MA(C,30))/MA(C,5)*100;
YY1:=C>MA(C,5) AND OPEN<MA(C,5);{龙出海}
YY3:=C>MA(C,10) AND OPEN<MA(C,10);
YY5:=C>MA(C,30) AND OPEN<MA(C,30);
DRAWTEXT(YY1 AND YY5 AND YY3,LOW-0.2,'←龙出海'),COLORYELLOW;
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210;
主力成本:EMA(X,13),COLORFF00FF,LINETHICK0;
ZZ:=(O+H+L)/3;
YC:=(H+L)/2;
YCHJX:=(EMA(ZZ,4))+(YC-REF(ZZ,3))/4;
今日买点:EMA(ZZ,3),COLORYELLOW,LINETHICK0;
明日买点:YCHJX,LINETHICK0;
昨测今日买点:REF(YCHJX,1),LINETHICK0;

通达信2016第一个好的主图指标公式

 

相关文章