在线检测未来函数

飞狐时间密码主图指标公式

来源:Internet,编辑:股旁网,2016-01-12

立春:=FILTER(MONTH=2 AND (DAY=4 OR DAY=6 ),2);
雨水:=FILTER(MONTH=2 AND (DAY=19 OR DAY=21),2);
惊蛰:=FILTER(MONTH=3 AND (DAY=6 OR DAY=8 ),2);
春分:=FILTER(MONTH=3 AND (DAY=21 OR DAY=23),2);
清明:=FILTER(MONTH=4 AND (DAY=5 OR DAY=7 ),2);
谷雨:=FILTER(MONTH=4 AND (DAY=20 OR DAY=22),2);
立夏:=FILTER(MONTH=5 AND (DAY=7 OR DAY=9 ),2);
小满:=FILTER(MONTH=5 AND (DAY=21 OR DAY=23),2);
芒种:=FILTER(MONTH=6 AND (DAY=6 OR DAY=8 ),2);
夏至:=FILTER(MONTH=6 AND (DAY=21 OR DAY=23),2);
小暑:=FILTER(MONTH=7 AND (DAY=7 OR DAY=9 ),2);
大暑:=FILTER(MONTH=7 AND (DAY=23 OR DAY=25),2);
立秋:=FILTER(MONTH=8 AND (DAY=8 OR DAY=10 ),2);
处暑:=FILTER(MONTH=8 AND (DAY=23 OR DAY=25),2);
白露:=FILTER(MONTH=9 AND (DAY=8 OR DAY=10 ),2);
秋分:=FILTER(MONTH=9 AND (DAY=23 OR DAY=25),2);
寒露:=FILTER(MONTH=10 AND (DAY=8 OR DAY=10 ),2);
霜降:=FILTER(MONTH=10 AND (DAY=23 OR DAY=25),2);
立冬:=FILTER(MONTH=11 AND (DAY=8 OR DAY=10 ),2);
小雪:=FILTER(MONTH=11 AND (DAY=23 OR DAY=25),2);
大雪:=FILTER(MONTH=12 AND (DAY=7 OR DAY=9 ),2);
冬至:=FILTER(MONTH=12 AND (DAY=22 OR DAY=24),2);
小寒:=FILTER(MONTH=1 AND (DAY=6 OR DAY=8 ),2);
大寒:=FILTER(MONTH=1 AND (DAY=20 OR DAY=22),2);
寅月:=立春;
卯月:=惊蛰;
辰月:=清明;
巳月:=立夏;
午月:=芒种;
未月:=小暑;
申月:=立秋;
酉月:=白露;
戌月:=寒露;
亥月:=立冬;
子月:=大雪;
丑月:=小寒;
DRAWTEXT(寅月,LOW*0.96,'寅'),COLORGREEN,ALIGN0;
DRAWTEXT(卯月,LOW*0.96,'卯'),COLORGREEN,ALIGN0;
DRAWTEXT(辰月,LOW*0.96,'辰'),COLOR0099FF,ALIGN0;
DRAWTEXT(巳月,LOW*0.96,'巳'),COLORMAGENTA,ALIGN0;
DRAWTEXT(午月,LOW*0.96,'午'),COLORMAGENTA,ALIGN0;
DRAWTEXT(未月,LOW*0.96,'未'),COLOR0099FF,ALIGN0;
DRAWTEXT(申月,LOW*0.96,'申'),COLORYELLOW,ALIGN0;
DRAWTEXT(酉月,LOW*0.96,'酉'),COLORYELLOW,ALIGN0;
DRAWTEXT(戌月,LOW*0.96,'戌'),COLOR0099FF,ALIGN0;
DRAWTEXT(亥月,LOW*0.96,'亥'),COLORBLUE,ALIGN0;
DRAWTEXT(子月,LOW*0.96,'子'),COLORBLUE,ALIGN0;
DRAWTEXT(丑月,LOW*0.96,'丑'),COLOR0099FF,ALIGN0;
STICKLINE(立春,HIGH,LOW,0.1,1),colorgreen;
STICKLINE(立春,OPEN,CLOSE,2,1),linethick1,colorgreen;
DRAWTEXT(立春,HIGH*1.02,'立春'),COLORgreen,ALIGN0;
STICKLINE(雨水,HIGH,LOW,0.1,1),colorgreen;
STICKLINE(雨水,OPEN,CLOSE,2,1),linethick1,colorgreen;
DRAWTEXT(雨水,HIGH*1.02,'雨水'),COLORgreen,ALIGN0;
STICKLINE(惊蛰,HIGH,LOW,0.1,1),colorgreen;
STICKLINE(惊蛰,OPEN,CLOSE,2,1),linethick1,colorgreen;
DRAWTEXT(惊蛰,HIGH*1.02,'惊蛰'),COLORgreen,ALIGN0;
STICKLINE(春分,HIGH,LOW,0.1,1),colorgreen;
STICKLINE(春分,OPEN,CLOSE,2,1),linethick1,colorgreen;
DRAWTEXT(春分,HIGH*1.02,'春分'),COLORgreen,ALIGN0;
STICKLINE(清明,HIGH,LOW,0.1,1),colorgreen;
STICKLINE(清明,OPEN,CLOSE,2,1),linethick1,colorgreen;
DRAWTEXT(清明,HIGH*1.02,'清明'),COLORgreen,ALIGN0;
STICKLINE(谷雨,HIGH,LOW,0.1,1),colorgreen;
STICKLINE(谷雨,OPEN,CLOSE,2,1),linethick1,colorgreen;
DRAWTEXT(谷雨,HIGH*1.02,'谷雨'),COLORgreen,ALIGN0;
STICKLINE(立夏,HIGH,LOW,0.1,1),COLORMAGENTA;
STICKLINE(立夏,OPEN,CLOSE,2,1),linethick1,COLORMAGENTA;
DRAWTEXT(立夏,HIGH*1.02,'立夏'),COLORMAGENTA,ALIGN0;
STICKLINE(小满,HIGH,LOW,0.1,1),COLORMAGENTA;
STICKLINE(小满,OPEN,CLOSE,2,1),linethick1,COLORMAGENTA;
DRAWTEXT(小满,HIGH*1.02,'小满'),COLORMAGENTA,ALIGN0;
STICKLINE(芒种,HIGH,LOW,0.1,1),COLORMAGENTA;
STICKLINE(芒种,OPEN,CLOSE,2,1),linethick1,COLORMAGENTA;
DRAWTEXT(芒种,HIGH*1.02,'芒种'),COLORMAGENTA,ALIGN0;
STICKLINE(夏至,HIGH,LOW,0.1,1),COLORMAGENTA;
STICKLINE(夏至,OPEN,CLOSE,2,1),linethick1,COLORMAGENTA;
DRAWTEXT(夏至,HIGH*1.02,'夏至'),COLORMAGENTA,ALIGN0;
STICKLINE(小暑,HIGH,LOW,0.1,1),COLORMAGENTA;
STICKLINE(小暑,OPEN,CLOSE,2,1),linethick1,COLORMAGENTA;
DRAWTEXT(小暑,HIGH*1.02,'小暑'),COLORMAGENTA,ALIGN0;
STICKLINE(大暑,HIGH,LOW,0.1,1),COLORMAGENTA;
STICKLINE(大暑,OPEN,CLOSE,2,1),linethick1,COLORMAGENTA;
DRAWTEXT(大暑,HIGH*1.02,'大暑'),COLORMAGENTA,ALIGN0;
STICKLINE(立秋,HIGH,LOW,0.1,1),COLORYELLOW;
STICKLINE(立秋,OPEN,CLOSE,2,1),linethick1,COLORYELLOW;
DRAWTEXT(立秋,HIGH*1.02,'立秋'),COLORYELLOW,ALIGN0;
STICKLINE(处暑,HIGH,LOW,0.1,1),COLORYELLOW;
STICKLINE(处暑,OPEN,CLOSE,2,1),linethick1,COLORYELLOW;
DRAWTEXT(处暑,HIGH*1.02,'处暑'),COLORYELLOW,ALIGN0;
STICKLINE(白露,HIGH,LOW,0.1,1),COLORYELLOW;
STICKLINE(白露,OPEN,CLOSE,2,1),linethick1,COLORYELLOW;
DRAWTEXT(白露,HIGH*1.02,'白露'),COLORYELLOW,ALIGN0;
STICKLINE(秋分,HIGH,LOW,0.1,1),COLORYELLOW;
STICKLINE(秋分,OPEN,CLOSE,2,1),linethick1,COLORYELLOW;
DRAWTEXT(秋分,HIGH*1.02,'秋分'),COLORYELLOW,ALIGN0;
STICKLINE(寒露,HIGH,LOW,0.1,1),COLORYELLOW;
STICKLINE(寒露,OPEN,CLOSE,2,1),linethick1,COLORYELLOW;
DRAWTEXT(寒露,HIGH*1.02,'寒露'),COLORYELLOW,ALIGN0;
STICKLINE(霜降,HIGH,LOW,0.1,1),COLORYELLOW;
STICKLINE(霜降,OPEN,CLOSE,2,1),linethick1,COLORYELLOW;
DRAWTEXT(霜降,HIGH*1.02,'霜降'),COLORYELLOW,ALIGN0;
STICKLINE(立冬,HIGH,LOW,0.1,1),colorwhite;
STICKLINE(立冬,OPEN,CLOSE,2,1),linethick1,colorwhite;
DRAWTEXT(立冬,HIGH*1.02,'立冬'),COLORWHITE,ALIGN0;
STICKLINE(小雪,HIGH,LOW,0.1,1),colorwhite;
STICKLINE(小雪,OPEN,CLOSE,2,1),linethick1,colorwhite;
DRAWTEXT(小雪,HIGH*1.02,'小雪'),COLORWHITE,ALIGN0;
STICKLINE(大雪,HIGH,LOW,0.1,1),colorwhite;
STICKLINE(大雪,OPEN,CLOSE,2,1),linethick1,colorwhite;
DRAWTEXT(大雪,HIGH*1.02,'大雪'),COLORWHITE,ALIGN0;
STICKLINE(冬至,HIGH,LOW,0.1,1),colorwhite;
STICKLINE(冬至,OPEN,CLOSE,2,1),linethick1,colorwhite;
DRAWTEXT(冬至,HIGH*1.02,'冬至'),COLORWHITE,ALIGN0;
STICKLINE(小寒,HIGH,LOW,0.1,1),colorwhite;
STICKLINE(小寒,OPEN,CLOSE,2,1),linethick1,colorwhite;
DRAWTEXT(小寒,HIGH*1.02,'小寒'),COLORWHITE,ALIGN0;
STICKLINE(大寒,HIGH,LOW,0.1,1),colorwhite;
STICKLINE(大寒,OPEN,CLOSE,2,1),linethick1,colorwhite;
DRAWTEXT(大寒,HIGH*1.02,'大寒'),COLORWHITE,ALIGN0;
M3:MA(CLOSE,3),ColorFFFfff;
M5:MA(CLOSE,5),ColorFFff00;
m7:ma(c,7);
m14:ma(c,14),POINTDOT,linethick3;
m28:ma(c,28),POINTDOT,linethick3;
m49:ma(c,49);
m64:ma(c,64);
m98:ma(c,98);
E1:=BARSCOUNT(C);
AH:=HHV(H,200);
AL:=LLV(L,200);
B0:=(AH-AL)/40;
KB1:=H+B0;
KB2:=L-B0;
STICKLINE((E1+0)/34=FLOOR((E1+0)/34),KB2,KB2-0.8*B0,1,0),COLORYELLOW,LINETHICK3;
DRAWTEXT((E1+0)/34=FLOOR((E1+0)/34),KB2-B0,'满窗'),ALIGN0,COLORYELLOW;
STICKLINE((E1+0)/17=FLOOR((E1+0)/17),KB2,KB2-0.8*B0,1,0),COLORYELLOW,LINETHICK3;
DRAWTEXT((E1+0)/17=FLOOR((E1+0)/17),KB2-B0,'半窗'),ALIGN0,COLORYELLOW;

飞狐时间密码主图指标公式

 

相关文章