在线检测未来函数

通达信MACD中枢指标公式

来源:Internet,编辑:股旁网,2016-01-12

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:2*(DIF-DEA),COLORSTICK;
DRAWBAND(DIF,RGB(255,0,128),DEA,RGB(0,128,128));
HMJ:=IF(DIF>DEA,SUM(MACD,BARSLAST(CROSS(DIF,DEA))),DRAWNULL);
LMJ:=IF(DIF<DEA,SUM(MACD,BARSLAST(CROSS(DEA,DIF))),DRAWNULL);
DRAWNUMBER(CROSS(DIF,DEA),DEA,REF(LMJ,1)),COLORGREEN;
DRAWNUMBER(CROSS(DEA,DIF),DEA,REF(HMJ,1)),COLORLIRED;
红柱数:IF(DIF>DEA AND ISLASTBAR,BARSLAST(CROSS(DIF,DEA))+1,DRAWNULL),COLORLIRED,NODRAW;
绿柱数:IF(DIF<DEA AND ISLASTBAR,BARSLAST(CROSS(DEA,DIF))+1,DRAWNULL),COLORCYAN,NODRAW;

通达信MACD中枢指标公式

 

相关文章