在线检测未来函数

通达信梦中仙分时主图指标公式

来源:Internet,编辑:股旁网,2016-01-18

SZPOW:=POW(1+0.1,1);
XDPOW:=POW(1-0.1,1);
ZTJ :=DYNAINFO(3)*SZPOW;
DTJ :=DYNAINFO(3)*XDPOW;
IFM010 :=IF(BARSCOUNT(C)<27 ,27,BARSCOUNT(C));
IFHHV0 :=IF(HHV(H ,IFM010)>0,HHV(H ,IFM010),DRAWNULL);
IFLLV0 :=IF(LLV(L ,IFM010)>0,LLV(L ,IFM010),DRAWNULL);
IFHHV :=(ZTJ+IFHHV0*2)/3;
IFLLV :=(DTJ+IFLLV0*2)/3;
HHVV :IF(BARSCOUNT(C)<3,IFHHV,IFHHV0),LINETHICK5;
LLVV :IF(BARSCOUNT(C)<3,IFLLV,IFLLV0),LINETHICK5;
X:=DYNAINFO(3);
DQ:=IF(DYNAINFO(14)<0.06,0,1);
DRAWNUMBER(PERIOD=0 AND ISLASTBAR,HHVV,HHVV-DYNAINFO(7));
DRAWNUMBER(PERIOD=0 AND ISLASTBAR,LLVV,DYNAINFO(7)-LLVV);
DRAWTEXT_FIX (PERIOD=0,0.94 , 1,1,'X = 昨日收盘 = ');
DRAWNUMBER_FIX(PERIOD=0,0.99, 1,1,X);
DRAWTEXT_FIX (PERIOD=0,0.94, 0.89,1,'X * 0.002 = ');
DRAWNUMBER_FIX(PERIOD=0,0.99, 0.89,1,X*0.002);
DRAWTEXT_FIX (PERIOD=0,0.94, 0.83,1,'X * 0.005 = ');
DRAWNUMBER_FIX(PERIOD=0,0.99, 0.83,1,X*0.005);
DRAWTEXT_FIX (PERIOD=0,0.94 , 0.76,1,'X * 0.01 = ');
DRAWNUMBER_FIX(PERIOD=0,0.99, 0.76,1,X*0.01);
DRAWTEXT_FIX (PERIOD=0,0.94, 0.69,1,'X * 0.02 = ');
DRAWNUMBER_FIX(PERIOD=0,0.99 , 0.69,1,X*0.02);
DRAWTEXT_FIX (PERIOD=0,0.94, 0.62,1,'X * 0.03 = ');
DRAWNUMBER_FIX(PERIOD=0,0.99 , 0.62,1,X*0.03);
DRAWTEXT_FIX (PERIOD=0,0.94, 0.55,1,'X * 0.04 = ');
DRAWNUMBER_FIX(PERIOD=0,0.99 , 0.55,1,X*0.04);
DRAWTEXT_FIX (PERIOD=0,0.94, 0.48,1,'X * 0.05 = ');
DRAWNUMBER_FIX(PERIOD=0,0.99 , 0.48,1,X*0.05);
DRAWTEXT_FIX (PERIOD=0,0.94, 0.41,1,'X * 0.06 = ');
DRAWNUMBER_FIX(PERIOD=0,0.99 , 0.41,1,X*0.06);
DRAWTEXT_FIX (PERIOD=0,0.94, 0.34,1,'X * 0.07 = ');
DRAWNUMBER_FIX(PERIOD=0,0.99 , 0.34,1,X*0.07);
DRAWTEXT_FIX (PERIOD=0,0.94, 0.27,1,'X * 0.08 = ');
DRAWNUMBER_FIX(PERIOD=0,0.99 , 0.27,1,X*0.08);
DRAWTEXT_FIX (PERIOD=0,0.94, 0.20,1,'X * 0.09 = ');
DRAWNUMBER_FIX(PERIOD=0,0.99 , 0.20,1,X*0.09);
DRAWTEXT_FIX (PERIOD=0,0.80, 0.89,1,'白粗线= ');
DRAWNUMBER_FIX(PERIOD=0 AND ISLASTBAR,0.83 , 0.89,1,HHVV);
DRAWTEXT_FIX (PERIOD=0,0.80, 1,1,'黄粗线= ');
DRAWNUMBER_FIX(PERIOD=0 AND ISLASTBAR,0.83 , 1,1,LLVV);
DRAWTEXT_FIX (PERIOD=0,0.70, 0.89,1,'今日高价= ');
DRAWNUMBER_FIX(PERIOD=0,0.73 , 0.89,1,DYNAINFO(5));
DRAWTEXT_FIX (PERIOD=0,0.70, 1,1,'今日低价= ');
DRAWNUMBER_FIX(PERIOD=0,0.73 , 1,1,DYNAINFO(6));

通达信梦中仙分时主图指标公式

 

相关文章