在线检测未来函数

飞狐底部抄顶部逃指标公式

来源:Internet,编辑:股旁网,2016-01-20

N:=2;
M:=8;
主力:=32;
Var1:=SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),14,1);
Var2:=HIGH-REF(HIGH,1);
Var3:=REF(LOW,1)-LOW;
Var4:=SMA(IF(Var2>0 AND Var2>Var3,Var2,0),12,1);
Var5:=SMA(IF(Var3>0 AND Var3>Var2,Var3,0),12,1);
Var6:=Var4*100/Var1;
Var7:=Var5*100/Var1;
Var8:=SMA(ABS(Var7-Var6)/(Var7+Var6)*100,12,1);
Var9:=(Var8+REF(Var8,5))/2;
VarA:=SUM(HIGH-OPEN,12)/SUM(OPEN-LOW,12)*100;
VarB:=SUM(MAX(0,HIGH-REF(CLOSE,1)),12)/SUM(MAX(0,REF(CLOSE,1)-LOW),12)*100;
VarC:=AMOUNT/VOL/100;
VarD:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
VarE:=SUM(AMOUNT,5)/VarC/100;
VarF:=SUM(AMOUNT,13)/VarC/100;
Var10:=SUM(AMOUNT,34)/VarC/100;
Var11:=SUM(AMOUNT,209)/VarC/100;
Var12:=REF(VOL,1)+REF(VOL,2)+REF(VOL,3)+REF(VOL,4);
Var13:=Var12/CAPITAL;
Var14:=VOL/CAPITAL*VarD+Var13*REF(VarC,1);
Var15:=DMA(VarD,VOL/VarE);
Var16:=DMA(VarD,VOL/VarF);
Var17:=DMA(VarD,VOL/Var10);
Var18:=DMA(VarD,VOL/CAPITAL);
Var19:=MA(HHV(HIGH,488),18);
Var1A:=MA(HHV(HIGH,220),18);
Var1B:=MA(HHV(HIGH,98),18);
Var1C:=MA(LLV(LOW,488),18);
Var1D:=MA(LLV(LOW,220),18);
Var1E:=MA(LLV(LOW,98),18);
Var1F:=MA((Var1C*0.96+Var1D*0.96+Var1E*0.96+Var19*0.558+Var1A*0.558+Var1B*0.558)/6,18);
Var20:=MA((Var1C*1.25+Var1D*1.23+Var1E*1.2+Var19*0.55+Var1A*0.55+Var1B*0.65)/6,18);
Var21:=MA((Var1C*1.3+Var1D*1.3+Var1E*1.3+Var19*0.68+Var1A*0.68+Var1B*0.68)/6,18);
Var22:=MA((Var1F*3+Var20*2+Var21)/6*1.738,18);
Var23:=IF(DATE<=1021231,Var22,Var22*DAY);
Var24:=LOW;
Var25:=REF(LOW,1);
Var26:=SMA(ABS(Var24-Var25),3,1)/SMA(MAX(Var24-Var25,0),3,1)*100;
Var27:=MA(IF(CLOSE*1.35<=Var23,Var26*10,Var26/10),3);
Var28:=LLV(LOW,30);
Var29:=HHV(Var27,30);
Var2A:=IF(LOW<=Var28,(Var27+Var29*2)/2,0);
Var31:=MA(HHV(HIGH,488),18);
Var32:=MA(HHV(HIGH,220),18);
Var33:=MA(HHV(HIGH,98),18);
Var34:=MA(LLV(LOW,488),18);
Var35:=MA(LLV(LOW,220),18);
Var36:=MA(LLV(LOW,98),18);
Var37:=MA((Var34*0.96+Var35*0.96+Var36*0.96+Var31*0.558+Var32*0.558+Var33*0.558)/6,18);
Var38:=MA((Var34*1.25+Var35*1.23+Var36*1.2+Var31*0.55+Var32*0.55+Var33*0.65)/6,18);
Var39:=MA((Var34*1.3+Var35*1.3+Var36*1.3+Var31*0.68+Var32*0.68+Var33*0.68)/6,18);
Var40:=MA((Var37*3+Var38*2+Var39)/6*1.738,18);
Var41:=Var40;
Var42:=LOW;
Var43:=REF(LOW,1);
Var44:=SMA(ABS(Var42-Var43),3,1)/SMA(MAX(Var42-Var43,0),3,1)*100;
Var45:=MA(IF(CLOSE*1.35<=Var41,Var44*10,Var44/10),3);
Var46:=LLV(LOW,30);
Var47:=HHV(Var45,30);
Var49:=IF(LOW<=Var46,(Var45+Var47*2)/2,0);
见底:STICKLINE(MA(Var49 AND CLOSE<COST(1),3),0,0.14,1,0)LINETHICK6,colorFFFF00;
买入:MA(Var2A AND CLOSE<COST(1),3) AND (CLOSE-Var16)/Var16*100<N-13,LINETHICK2 ,COLORFF99FF;
v2:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
v3:=MA(VOL,2)/MA(VOL,10);
v4:=VOL/CAPITAL;
a1:=0.0068*V2-0.0072*V3-0.5676*V4-0.0105;
a2:=0.0015*V2-0.0124*V3+1.7461*V4-0.0074;
a3:=-0.0003*V2+0.0470*V3-0.5734*V4-0.0549;
买63:-12.2401*a1-1.0000*a2+0.3210<0,colorff00ff;
金指63:IF((REF(CLOSE,13)-CLOSE)/REF(CLOSE,13)*100>15 AND SUM(VOL/CAPITAL,13)*100<18
AND VOL/CAPITAL*100<2.5 AND (REF(CLOSE,1)-CLOSE)/REF(CLOSE,1)*100<8,0.6,0),LINETHICK2,coloryellow;
{黑马金指}
b1:=(CLOSE-MA(CLOSE,27))/MA(CLOSE,27)<-0.16;
{品股利剑}
出击72:STICKLINE(b1 ,0 ,0.3 ,2 ,0 ),LINETHICK5,,colorred;
Var51:=(CLOSE-LLV(LOW,主力))/(HHV(HIGH,主力)-LLV(LOW,主力))*100;
Var52:=SMA(Var51,4,1);
Var53:=SMA(Var52,6,1);
Var54:=VOL/CAPITAL*34;
Var55:=REF(Var54,1);
主力建仓:STICKLINE(Var53<7 AND Var52<11,0,0.3,1,0), , ,LINETHICK2 ,color99cc00 ;
大户减仓: STICKLINE(Var55>4 AND Var55<4.2,1,0.85,8,0), ,colorffffff ;
机构减仓:STICKLINE(Var53>89.5 AND Var52>91,1,0.95,6,0) ,LINETHICK1 ,colorFFB210 ;
主力出货: STICKLINE(Var53>88.5 AND Var52>94.6,1,0.5,8,0),,colorFF1010 , ;
Var57:=(HIGH+LOW+OPEN+2*CLOSE)/5;
Var58:=REF(Var57,1);
Var59:=SMA(MAX(Var57-Var58,0),10,1)/SMA(ABS(Var57-Var58),10,1)*100;
底部: IF(COUNT(Var59<20,5)>=1 AND COUNT(Var57=LLV(Var57,10),10)>=1 AND CLOSE>OPEN AND REF(CLOSE,1)>REF(OPEN,1) AND VOL>REF(VOL,1),0.4,0),LINETHICK2 ,color0099FF ;
VaraA:=IF(LLV(LOW,5)<=CLOSE,LLV(LOW,5),CLOSE);
VaraB:=IF(LLV(LOW,10)<=VaraA,LLV(LOW,10),VaraA);
VaraC:=IF(LLV(LOW,20)<=VaraB,LLV(LOW,20),VaraB);
VaraD:=IF(LLV(LOW,30)<=VaraC,LLV(LOW,30),VaraC);
VaraE:=IF(LLV(LOW,40)<=VaraD,LLV(LOW,40),VaraD);
VaraF:=IF(LLV(LOW,50)<=VaraE,LLV(LOW,50),VaraE);
Var60:=IF(LLV(LOW,60)<=VaraF,LLV(LOW,60),VaraF);
Var61:=IF(LLV(LOW,100)<=Var60,LLV(LOW,100),Var60);
Var62:=IF(LLV(LOW,150)<=Var61,LLV(LOW,150),Var61);
Var63:=SUM(MA(CLOSE/Var62,1)-1.1,5);
金刀: CROSS(Var63,0),LINETHICK2 ,colorCCFFFF ;
RSV:= (CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9));
FASTK:=SMA(RSV,3,1);
K:SMA(FASTK,3,1);
D:SMA(K,5,1);
STICKLINE(K<d ,k,d,0,1),color10FF10,pointDOT;
Var64:=AMOUNT/VOL;
Var65:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,5);
Var66:="1A0001$VOL"*"1A0001$CLOSE";
Var67:=EMA(Var66,5)/EMA("1A0001$VOL",5);
Var68:=("1A0001$CLOSE"-Var67)/Var67*100;
Var69:=INDEXC;
Var22A:=MA(Var69,5);
Var2B:=MA(Var69,20);
Var2C:=MA(Var69,30);
Var2D:=Var2C>Var22A*1.08 AND Var2B>Var22A*1.055;
Var2E:=Var22A>Var69*1.03 AND Var2B>Var69*1.13;
Var2F:=Var68<=-2 AND Var2E;
黑林强盗: STICKLINE(Var65<6,0,0.1,6,0), ,color00ff99 ;
出鞘必杀:= Var65<6 AND Var68<-2 AND Var2F,colorCCFF00 ,;
Var70:=(CLOSE*2+HIGH+LOW)/4;
Var71:=MA(Var70,13)-EMA(Var70,21);
Var72:=EMA(Var71,2);
Var73:=(Var71-Var72)*12;
Var74:=(Var71-Var72)*(-13.8);
ma5:ma(k,1);
bb5:=ma5-ref(ma5,1);
ma10:ma(d,1);
bb10:=ma10-ref(ma10,1);
PARTLINE(bb5>0,MA5),colorcc00ff,LINETHICK1;
PARTLINE(bb5<=0,MA5),colorff9999,LINETHICK1;
PARTLINE(bb10>0,MA10),color0066ff,LINETHICK1;
PARTLINE(bb10<=0,MA10),color00ff33,LINETHICK1;
底线:0.1,POINTDOT,colorwhite;

飞狐底部抄顶部逃指标公式

 

相关文章