在线检测未来函数

通达信精确MDI+KDJ指标公式

来源:Internet,编辑:股旁网,2016-01-27

DRAWTEXT_FIX(1,0,0.07,0,'(1)白线在黄线上方时,股价处于上升趋势,此时白黄线之间出现红虚线段;'),COLOR99CC32;
DRAWTEXT_FIX(1,0,0.12,0,'(2)黄线在白线上方时,股价处于下降趋势,此时黄白线之间出现绿虚线段;'),COLOR99CC32;
DRAWTEXT_FIX(1,0,0.17,0,'(3)当粉红线从低位(使之-50以下)向上金叉绿线之后再金叉灰白虚线,股价趋势从下降转向上升;'),COLOR99CC32;
DRAWTEXT_FIX(1,0,0.22,0,'(4)当粉红线从高位(数值50以上)向下死叉绿线之后再死叉灰白虚线,股价趋势从上升转向下降; '),COLOR99CC32;
轴距4:50,COLOR545454,DOTLINE;
轴距11:-50,COLOR545454,DOTLINE;
MTR:=EMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),13);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),13);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),13);
PDI:=DMP*100/MTR;
MDI:=DMM*100/MTR;
D:=PDI-22;
K:=MDI-22;
A:=D-K;
STICKLINE(A>0 ,D,K,0,-1),COLORRED;
STICKLINE(A<=0,K,D,0,-1),COLORCYAN;
多:D,COLORWHITE;
空:K,COLORYELLOW;
ADX:EXPMEMA((PDI-MDI)/(MDI+PDI)*100,3),COLORMAGENTA;
ADXR:EXPMEMA(ADX,5),COLORGREEN;
趋势:EMA(ADX,13),DOTLINE,COLORGRAY;

通达信精确MDI+KDJ指标公式

 

相关文章