在线检测未来函数

飞狐成交量主图指标公式

来源:Internet,编辑:股旁网,2016-02-01

N:=if(DATATYPE=7,3,if(DATATYPE=6,24,if(DATATYPE=5,96,if(DATATYPE=4,192,if(DATATYPE=3,384,1000)))));
EMA6:=MA(C,6),COLORRED LINETHICK2;
EMA18:=MA(C,18),COLORYELLOW;
EMA144:=MA(C,144),COLORGREEN;
EMA288:=MA(C,288),COLORBLUE;
中线【18日均线买入】:=COUNT(CLOSE<EMA18,5)=4 AND CLOSE/EMA18>1.004 AND CROSS(CLOSE,EMA18) AND EMA18>=REF(EMA18,1),LINETHICK,COLORRED;
股价平台1:=IF(CLOSE>10,1.004,0);
股价平台2:=IF(CLOSE>8 AND CLOSE<=10,1.006,0);
股价平台3:=IF(CLOSE>6 AND CLOSE<=8,1.008,0);
股价平台4:=IF(CLOSE>4 AND CLOSE<=6,1.010,0);
股价平台5:=IF(CLOSE>2 AND CLOSE<=4,1.012,0);
股价平台6:=IF(CLOSE<=2,1.015,0);
股价平台:=股价平台1+股价平台2+股价平台3+股价平台4+股价平台5+股价平台6;
中线JM:=(CLOSE-REF(CLOSE,18))/18+EMA18*股价平台,LINETHICK2,COLORMAGENTA;
sbr:SMA(中线JM,N,1),COLORRED;
DRAWTEXT(ISLASTBAR,sbr,'sbr'),COLORWHITE;
Zcb1:=累加到指定值周期数(成交量 ,流通盘大小*1);{累计换手=100%的周期}
Zcb2:=求和(成本分布(10),Zcb1)/Zcb1;{在A周期里获利10%的平均价}
Zcb3:=求和(成本分布(20),Zcb1)/Zcb1;{在A周期里获利20%的平均价}
Zcb4:=求和(成本分布(30),Zcb1)/Zcb1;{在A周期里获利30%的平均价}
Zcb5:=求和(成本分布(40),Zcb1)/Zcb1;{在A周期里获利40%的平均价}
Zcb6:=求和(成本分布(50),Zcb1)/Zcb1;{在A周期里获利50%的平均价}
庄家成本:(5*Zcb2+4*Zcb3+3*Zcb4+2*Zcb5+Zcb6)/15,PRECISION2,LINETHICK0,COLORYELLOW;{求出庄家成本}
DRAWTEXT(ISLASTBAR,庄家成本,'庄家成本'),COLORRED;
STICKLINE(庄家成本>ref(庄家成本,1),庄家成本*0.995 ,ref(庄家成本,1),6,0), COLORGREEN;
STICKLINE(庄家成本<ref(庄家成本,1),庄家成本*0.995 ,ref(庄家成本,1),6,0),COLORYELLOW;
diff:=ema(close,12)-ema(close,26);
dea:=ema(diff,9);
STICKLINE(diff<=dea AND CLOSE>=OPEN,HIGH,LOW,0.1,0), COLORGREEN;
STICKLINE(diff<=dea AND CLOSE>=OPEN,CLOSE,OPEN,8,0),COLORGREEN;
STICKLINE(diff<=dea AND CLOSE<OPEN,HIGH,LOW,0.1,0),COLORGREEN;
STICKLINE(diff<=dea AND CLOSE<OPEN,CLOSE,OPEN,8,0), COLORBLUE;
STICKLINE(diff>dea AND CLOSE>=OPEN,HIGH,LOW,0.1,0),COLORRED;
STICKLINE(diff>dea AND CLOSE>=OPEN,CLOSE,OPEN,8,0),COLORRED;
STICKLINE(diff>dea AND CLOSE<OPEN,HIGH,LOW,0.1,0),COLORRED;
STICKLINE(diff>dea AND CLOSE<OPEN,CLOSE,OPEN,8,0), COLORYELLOW;
DRAWTEXT(cross(diff,dea),l*0.999,'B'),colorwhite;
DRAWTEXT(cross(dea,diff),h*1.008,'S'),colorgreen;
DRAWTEXTEX(CLOSE,1,20,20,STKLABEL+' '+STKNAME+' '+STRLEFT(BLKNAME,40)),ColorFFB060;
A1:=COST(0.37);A2:=COST(6);A3:=COST(15);A4:=COST(55);A5:=COST(95);
【90%成本】:=COST(90);【70%成本】:=COST(12);获利:=WINNER(C)*100;
sjj:=STKTYPE=1 or STKTYPE=2 or STKTYPE=3 or STKTYPE=5 or STKTYPE=11;
套牢:=100-WINNER(C)*100;底出击★:=a1;稳建仓:=a2;快刀手:=a3;预测★:=a5;
升浪:=a4;Q:=WEEKDAY;P:=SYSPARAM(1);
DRAWTEXTEX(c,1,0,45,' \n获利盘:'+NUMTOSTR(获利[sysparam(1)],2)+' %'),align4,Colorff00ff;
DRAWTEXTEX(c,1,0,45,' \n \n套牢盘:'+NUMTOSTR(套牢[sysparam(1)],2)+' %'),align4,Colorffbb00;
DRAWTEXTEX(c,1,0,45,' \n \n \n■底击:'+NUMTOSTR(底出击★[sysparam(1)],2)+' 元'),align4,Colorred;
DRAWTEXTEX(c,1,0,45,' \n \n \n \n■稳仓:'+NUMTOSTR(稳建仓[sysparam(1)],2)+' 元')PXDN0,align4,Coloryellow;
DRAWTEXTEX(c,1,0,45,' \n \n \n \n \n■快刀:'+NUMTOSTR(快刀手[SYSPARAM(1)],2)+' 元')PXDN0,align4,COLORgreen;
DRAWTEXTEX(c,1,0,45,' \n \n \n \n \n \n■升浪:'+NUMTOSTR(升浪[sysparam
(1)],2)+' 元')PXDN0,align4,Colorffffff;
DRAWTEXTEX(c,1,0,45,' \n \n \n 、\n \n \n \n■预测:'+NUMTOSTR(预测★[sysparam(1)],2)+' 元')PXDN0,align4,Colorffbbff;
DRAWTEXTEX(c,1,0,45,' \n \n \n \n 、\n \n \n \n90成本:'+NUMTOSTR(【90%成本】[sysparam(1)],2)+' 元')PXDN0,align4,Colorffeeff;
DRAWTEXTEX(c,1,0,45,' \n \n \n \n 、\n \n \n \n \n70成本:'+NUMTOSTR(【70%成本】[sysparam(1)],2)+' 元')PXDN0,align4,Colorffccff;

飞狐成交量主图指标公式

 

相关文章