在线检测未来函数

飞狐黄金柱主图指标公式

来源:Internet,编辑:股旁网,2016-02-03

DRAWTEXT((SYSPARAM(2) = BARPOS),CLOSE,('版块:' + BLKNAME)),ALIGN4;
DRAWTEXTEX(c,1,10,50,'收益: '+ NUMTOSTR(FINANCE(33),2)+' 元'),ColorFFB060;
DRAWTEXTEX(c,1,200,50,'净资产: '+NUMTOSTR(FINANCE(34),2 )+' 元'),ColorFFB060;
DRAWTEXTEX(c,1,10,100,'流通股:'+ NUMTOSTR(FINANCE(7)/10000,2)+' 亿'),ColorFFB060;
DRAWTEXTEX(c,1,200,100,'占总股本:'+NUMTOSTR(FINANCE(7)/FINANCE(1)*100 ,2)+' %'),ColorFFB060;
{均线系统}
MA5:MA(CLOSE,5);
MA10:MA(CLOSE,10);
MA20:MA(CLOSE,20);
MA60:MA(CLOSE,60);
割肉线MA160:MA(CLOSE,160);
{通用条件}
LASTK:=(REFX(ISLASTBAR,2)=0);
上涨:=CLOSE>REF(CLOSE,1);
未跌破:=REFX(CLOSE,1)>LOW AND REFX(CLOSE,2)>LOW AND REFX(CLOSE,3)>LOW;
缩量:=VOL>0.35*(REFX(VOL,1)+REFX(VOL,2)+REFX(VOL,3)) AND VOL>REFX(VOL,1);{1.05/3,5%}
逐级缩量:=VOL>REFX(VOL,1) AND REFX(VOL,1)>REFX(VOL,2) AND REFX(VOL,2)>REFX(VOL,3);
逐级价升:=CLOSE<REFX(CLOSE,1) AND REFX(CLOSE,1)<REFX(CLOSE,2) AND REFX(CLOSE,2)<REFX(CLOSE,3);
{倍量柱}
倍量柱:VOL>=(REF(VOL,1)+REF(VOL,1))*0.9,LINETHICK0,COLORWHITE;
{高量柱}
高量柱:VOL>0.3*(REF(SUM(VOL,3),1)+REFX(SUM(VOL,3),3)) AND VOL>REF(VOL,1) AND VOL>REFX(VOL,1),LINETHICK0,COLORWHITE;{1.8/6,1.8倍}
{平量柱}
平量柱:VOL>REFX(VOL,1)*0.97 AND VOL<REFX(VOL,1)*1.03 AND VOL>=2*REF(VOL,1),LINETHICK0,COLORWHITE;
{梯量柱}
梯量柱:VOL>REF(VOL,1) AND REF(VOL,1)>REF(VOL,2) AND CLOSE>REF(CLOSE,1) AND REF(CLOSE,1)>REF(CLOSE,2),LINETHICK0,COLORWHITE;{虽然是梯量柱,但也不能太小}
{将军柱}
将军柱:LASTK AND 上涨 AND 未跌破 AND (倍量柱 OR 高量柱 OR 平量柱 OR 梯量柱),LINETHICK0,COLORYELLOW;
{黄金柱}
黄金柱:将军柱 AND 缩量,LINETHICK0,COLORYELLOW;
{标准黄金柱}
标准黄金柱:黄金柱 AND 逐级缩量 AND 逐级价升,LINETHICK0,COLORRED;
{输出}
DRAWICON(黄金柱 AND 标准黄金柱=0 AND BARSLAST(REF(黄金柱,1))>1,LOW,8),COLORRED;
DRAWICON(标准黄金柱,LOW,4),COLORRED;
DRAWICON(将军柱 AND BARSLAST(REF(将军柱,1))>1 AND BARSLAST(黄金柱)>1,LOW,10),COLORRED;
MA135:=MA(VOL,135);
TJ1:=(VOL=HHV(VOL,10) AND VOL>1.7*REF(VOL,1) AND C>=REF(C,1) AND C>=O AND VOL<=MA135*3.5);
LJL:=FILTER(TJ1,3);
TJ3:=IF(BARSLAST(LJL)=1 AND CLOSE>REF(LOW,3),1,0);
ST:=TJ3=1;
CL:=FILTER(ST,3);
STICKLINE(C,REF(L,BARSLAST(CL)),REF(L,BARSLAST(CL)),5,0),COLORYELLOW;
STICKLINE(CLOSE,REF(L,BARSLAST(LJL)),REF(L,BARSLAST(LJL)),5,0),COLORCYAN;
STICKLINE(LJL,OPEN,CLOSE,6,0),COLORYELLOW;
DRAWTEXT(LJL,L*0.99,'支撑'),COLORF00FF0;
GJTJ1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
GJTJ2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
GJTJ3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));
GJTJ4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
BAIJIN1:=BARSLAST(CROSS(30,GJTJ1))<2 AND BARSLAST(CROSS(GJTJ1,50))<2;
BAIJIN2:=BARSLAST(CROSS(GJTJ4,GJTJ1))<2 AND GJTJ1>GJTJ4;
BAIJIN3:=GJTJ1>60 AND GJTJ4>70;
DRAWTEXT(BAIJIN1 AND BAIJIN2 AND BAIJIN3,L-0.02,'白金');
HUANGJIN1:=BARSLAST(CROSS(50,GJTJ1))<3 AND BARSLAST(CROSS(GJTJ1,50))<3;
HUANGJIN2:=BARSLAST(CROSS(GJTJ4,GJTJ1))<2 AND GJTJ1>GJTJ4;
DRAWTEXT(HUANGJIN1 AND HUANGJIN2,L-0.03,'黄金');
XG:=BARSLAST(CROSS(GJTJ4,GJTJ1))<5 AND GJTJ1>GJTJ4;
DRAWTEXT(COUNT(XG,3)=1 AND XG AND C>MA(C,20),L-0.02,'暴涨启动'),COLORRED;
ZHENCANG1:=BARSLAST(CROSS(GJTJ4,GJTJ1))>3 AND BARSLAST(CROSS(GJTJ1,GJTJ4))<3;
ZHENCANG2:=BARSLAST(CROSS(GJTJ4,GJTJ2));
ZHENCANG3:=GJTJ3<GJTJ4 AND GJTJ2<GJTJ4;
ZHENCANG4:=BARSLAST(CROSS(GJTJ4,GJTJ3))>3 AND BARSLAST(CROSS(GJTJ1,GJTJ4))<3;
ZHENCANG5:=GJTJ2<GJTJ3 AND GJTJ1=100;
ZCB1:=ZHENCANG1>0 AND REF(ZHENCANG1,1)=0 AND REF(ZHENCANG1,2)>0;
DRAWTEXT(ZHENCANG1 AND ZHENCANG2 AND ZHENCANG3 AND ZHENCANG4 AND ZHENCANG5,L-0.05,'震仓启点');
AA:=BARSLAST(CROSS(97,GJTJ1))<=1 AND BARSLAST(CROSS(GJTJ1,85))<=1;
BB:=BARSLAST(CROSS(97,GJTJ2))<=1 AND BARSLAST(CROSS(GJTJ2,85))<=1;
AA1:=AA AND BB;
AAA:=BARSLAST(CROSS(97,GJTJ1))<=2 AND BARSLAST(CROSS(GJTJ1,85))<=1;
BAA:=BARSLAST(CROSS(97,GJTJ2))<=2 AND BARSLAST(CROSS(GJTJ2,85))<=1;
AA2:=AA AND BB ;
AAAA:=BARSLAST(CROSS(97,GJTJ1))<=3 AND BARSLAST(CROSS(GJTJ1,85))<=1;
BAAA:=BARSLAST(CROSS(97,GJTJ2))<=3 AND BARSLAST(CROSS(GJTJ2,85))<=1;
AA3:=AAAA AND BAAA ;
BB1:=REF(AA1,1);
BB2:=REF(AA2,1);
BB3:=REF(AA3,1);
DD1:=GJTJ1=100 AND GJTJ2=100 AND AA1 ;
DD2:=GJTJ1=100 AND GJTJ2=100 AND AA2 ;
DD3:=GJTJ1=100 AND GJTJ2=100 AND AA3 ;
DRAWTEXT(DD1 OR DD2 OR DD3,L-0.02,'短线追涨');
AW:=BARSLAST(CROSS(95,GJTJ1))<=2;
BW:=BARSLAST(CROSS(95,GJTJ2))<=2;
EW:= GJTJ4<GJTJ1 AND GJTJ1<GJTJ3;
FW:=GJTJ2>50 AND GJTJ3>50;
GW:=GJTJ1=100 AND GJTJ2=100;
TXW:=COUNT(GW,2)=1;
DRAWTEXT(AW AND BW AND EW AND FW AND TXW,L-0.03,'起涨首日');
AQ:=GJTJ3=100;
BQ:=GJTJ4<90;
DRAWTEXT(COUNT(AQ,2) = 2 AND BQ,L-0.02,'波启前兆');
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
DRAWTEXT(C-O>=0 AND O/L>1.05 AND L<=LLV(L,30),L,'★<-绝底'),COLORMAGENTA;
a1:=cost(95);
a2:=cost(5);
天眼通:=(a1-a2)*100/(a1+a2);
drawicon(天眼通>ref(天眼通,1), l*0.98,8)ALIGN5;

飞狐黄金柱主图指标公式

 

相关文章