在线检测未来函数

通达信RSILB划线指标公式

来源:Internet,编辑:股旁网,2016-02-03

N1:=2,120,6;N2:=2,250,12;N3:=2,500,24;
P:=1,20,2;{支撑压力线的周期参数 P可调}
LC:=REF(CLOSE,1);
换手:VOL/CAPITAL*100,NODRAW;
{正常换手:换手<3, COLORADEAEA,NODRAW;
活跃换手:换手>3 AND 换手<15,COLOR7F00FF,NODRAW;
异常换手:换手>15,COLOR00FF7F,NODRAW;
STICKLINE(换手<3,10,换手+10,2,0),COLORADEAEA;
STICKLINE(换手>3 AND 换手<15,10,换手+10,2,0)COLOR7F00FF;
STICKLINE(换手>15,10,换手+10,2,0),COLOR00FF7F};
AA:=VOL;
BB:=REF(MA(VOL,5),1);
CC:=AA/BB;
AA1:=CC>=0.001 AND CC<1.3;
AA2:=CC>=1.3 AND CC<2.5;
AA3:=CC>=2.5 AND CC<4;
AA4:=CC>=4;
正常量比:STICKLINE(AA1,10,CC*4+10,2.75,0),COLOREAEAEA;
温和放量:STICKLINE(AA2,10,CC*4+10,2.75,0),COLORRED;
活跃放量:STICKLINE(AA3,10,CC*4+10,2.75,0),COLOR00AAFF;
异常放量:STICKLINE(AA4,10,CC*4+10,2.75,0),COLORFFC010;
今日量比:VOL/REF(MA(VOL,5),1),COLORFFFFFF,NODRAW;
{RSI划线}
RSI5:SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100,NODRAW,COLORFFAAFF;
OB:=RSI5;
A1:=REF(OB,P)=HHV(OB,2*P+1);
B1:=FILTER(A1,P);
C1:=BACKSET(B1,P+1);
D1:=FILTER(C1,P);{高点}
A2:=REF(OB,P)=LLV(OB,2*P+1);
B2:=FILTER(A2,P);
C2:=BACKSET(B2,P+1);
D2:=FILTER(C2,P);{低点}
R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1);
S11:=R11>REF(R11,1);
压力线:=DRAWLINE(D1,OB,S11,OB,1),LINETHICK1,COLORCC33CC;
T11:=BACKSET(ISLASTBAR,BARSLAST(D2)+1);
U11:=T11>REF(T11,1);
支撑线:DRAWLINE(D2,OB,U11,OB,1)LINETHICK1,COLORYELLOW DOTLINE;
DRAWTEXT(CURRBARSCOUNT=60,35,'强弱用来看趋势背离用来看顶底'),COLORCC99FF;
DRAWTEXT(CURRBARSCOUNT=60,25,'支撑压力辨起落 设定周期参数 P'),COLORCC99FF;
QSX:50 POINTDOT;
JSX:80 POINTDOT;
N:=6;
RSI:=SMA(MAX(CLOSE-LC,0),N,1)/SMA(ABS(CLOSE-LC),N,1)*100;
压力:DRAWLINE( RSI>=HHV(RSI,10),RSI,RSI<=LLV(RSI,3),HHV(RSI,3),1),COLORFFFF00,LINETHICK1 DOTLINE;
RSI1:SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100 COLORRED;
RSI2:SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100 COLORWHITE;
RSI3:SMA(MAX(CLOSE-LC,0),24,1)/SMA(ABS(CLOSE-LC),24,1)*100 COLORGREEN;

通达信RSILB划线指标公式

 

相关文章