在线检测未来函数

通达信股市红绿灯主图指标公式

来源:Internet,编辑:股旁网,2016-02-12

n:=20;
CC:=ZIG(3,N);
GT1:PEAKBARS(1,N,1),NODRAW;
DT1:=TROUGHBARS(2,N,1);
H1:DRAWLINE(CURRBARSCOUNT=CONST(GT1)+1,H,ISLASTBAR,REF(H,CONST(GT1)),0),DOTLINE,LINETHICK1,COLORWHITE;
L1:DRAWLINE(CURRBARSCOUNT=CONST(DT1)+1,L,ISLASTBAR,REF(L,CONST(DT1)),0),DOTLINE,LINETHICK1,COLORCYAN;
HX0:=IF(H/L>1.04 AND V>=HHV(V,BARSLAST(CURRBARSCOUNT=CONST(GT1)+1)+1) AND LLV(L,N)=L,L,99);
HXW:=CONST(LLV(HX0,N))=L AND NOT(ISLASTBAR);
BW:=CURRBARSCOUNT=CONST(BARSLAST(HXW))+1;
YZX:REF(H,BARSLAST(BW))DOTLINE,COLORGREEN;
YZA:REF(L,BARSLAST(BW))DOTLINE,COLORYELLOW;
YZU:REF((H+L)/2,BARSLAST(BW))DOTLINE,COLORRED;
DRAWTEXT(BW,L*0.97,VAR2STR(L,2));
DRAWTEXT(ISLASTBAR,H1,'近期高点')COLORWHITE;
DRAWTEXT(ISLASTBAR,L1,'近期低点')COLORCYAN;
DRAWTEXT(ISLASTBAR,YZX,'上线就买')COLORGREEN;
DRAWTEXT(ISLASTBAR,(YZX+YZA)/2,'中线观望')COLORYELLOW;
DRAWTEXT(ISLASTBAR,YZA,'下线就卖')COLORRED;
DRAWICON(CROSS(C>YZX,0.5),H,1);
DRAWICON(CROSS(C<YZA,0.5),L,2);
IF(BW,H,DRAWNULL)COLORGREEN,CIRCLEDOT,LINETHICK3;
IF(BW,(H+L)/2,DRAWNULL)COLORYELLOW,CIRCLEDOT,LINETHICK3;
IF(BW,L,DRAWNULL)COLORRED,CIRCLEDOT,LINETHICK3;

通达信股市红绿灯主图指标公式

 

相关文章