在线检测未来函数

通达信分流资金升级版指标公式

来源:Internet,编辑:股旁网,2016-02-16

STICKLINE(C>0,80,80,10,0),COLORAAAA00;
STICKLINE(C>0,20,20,10,0),COLOR006010;
STICKLINE(C>0,50,50,10,0),colorFF9F99;
STICKLINE(C>0,110,110,10,0),colorFF9F99;
YC:=CLOSE;
YH:=HIGH;
YL:=LOW;
市价:=INDEXA/(INDEXV*100);
pc:=市价;
pH:=市价*((INDEXH*0.01+PC*0.99)/(INDEXC*0.01+PC*0.99));
pL:=市价*((INDEXL*0.01+pc*0.99)/(INDEXC*0.01+PC*0.99));
JGL0:=100*((YC-LLV(YL,18))/(HHV(YH,18)-LLV(YL,18))+(YC-LLV(YL,27))/(HHV(YH,27)-LLV(YL,27)))/2;
MH01:=(EMA(JGL0+SLOPE(JGL0,7),7)+EMA(JGL0+SLOPE(JGL0,5),5)+EMA(JGL0+SLOPE(JGL0,9),9))/3;
主0:=(EMA(MH01+SLOPE(MH01,2),2)+EMA(MH01+SLOPE(MH01,3),3))/2;
SGL0:=100*((PC-LLV(PL,18))/(HHV(PH,18)-LLV(PL,18))+(PC-LLV(PL,27))/(HHV(PH,27)-LLV(PL,27)))/2;
MH02:=(EMA(SGL0+SLOPE(SGL0,7),7)+EMA(SGL0+SLOPE(SGL0,5),5)+EMA(SGL0+SLOPE(SGL0,9),9))/3;
市0:=(EMA(MH02+SLOPE(MH02,2),2)+EMA(MH02+SLOPE(MH02,3),3))/2;
PJL0:=100*((INDEXC-LLV(INDEXL,18))/(HHV(INDEXH,18)-LLV(INDEXL,18))+(INDEXC-LLV(INDEXL,27))/(HHV(INDEXH,27)-LLV(INDEXL,27)))/2;
MH03:=(EMA(PJL0+SLOPE(PJL0,7),7)+EMA(PJL0+SLOPE(PJL0,5),5)+EMA(PJL0+SLOPE(PJL0,9),9))/3;
非0:=(EMA(MH03+SLOPE(MH03,2),2)+EMA(MH03+SLOPE(MH03,3),3))/2;
JGL1:=100*((YC-LLV(YL,36))/(HHV(YH,36)-LLV(YL,36))+(YC-LLV(YL,45))/(HHV(YH,45)-LLV(YL,45)))/2;
MH11:=(EMA(JGL1+SLOPE(JGL1,7),7)+EMA(JGL1+SLOPE(JGL1,5),5)+EMA(JGL1+SLOPE(JGL1,9),9))/3;
主1:=(EMA(MH11+SLOPE(MH11,4),4)+EMA(MH11+SLOPE(MH11,5),5))/2;
SGL1:=100*((PC-LLV(PL,36))/(HHV(PH,36)-LLV(PL,36))+(PC-LLV(PL,45))/(HHV(PH,45)-LLV(PL,45)))/2;
MH12:=(EMA(SGL1+SLOPE(SGL1,7),7)+EMA(SGL1+SLOPE(SGL1,5),5)+EMA(SGL1+SLOPE(SGL1,9),9))/3;
市1:=(EMA(MH12+SLOPE(MH12,4),4)+EMA(MH12+SLOPE(MH12,5),5))/2;
PJL1:=100*((INDEXC-LLV(INDEXL,36))/(HHV(INDEXH,36)-LLV(INDEXL,36))+(INDEXC-LLV(INDEXL,45))/(HHV(INDEXH,45)-LLV(INDEXL,45)))/2;
MH13:=(EMA(PJL1+SLOPE(PJL1,7),7)+EMA(PJL1+SLOPE(PJL1,5),5)+EMA(PJL1+SLOPE(PJL1,9),9))/3;
非1:=(EMA(MH13+SLOPE(MH13,4),4)+EMA(MH13+SLOPE(MH13,5),5))/2;
JGL2:=100*(YC-LLV(YL,81))/(HHV(YH,81)-LLV(YL,81));
MH21:=(EMA(JGL2+SLOPE(JGL2,7),7)+EMA(JGL2+SLOPE(JGL2,5),5)+EMA(JGL2+SLOPE(JGL2,9),9))/3;
主2:=EMA(MH21+SLOPE(MH21,9),9);
SGL2:=100*(PC-LLV(PL,81))/(HHV(PH,81)-LLV(PL,81));
MH22:=(EMA(SGL2+SLOPE(SGL2,7),7)+EMA(SGL2+SLOPE(SGL2,5),5)+EMA(SGL2+SLOPE(SGL2,9),9))/3;
市2:=EMA(MH22+SLOPE(MH22,9),9);
PJL2:=100*(INDEXC-LLV(INDEXL,81))/(HHV(INDEXH,81)-LLV(INDEXL,81));
MH23:=(EMA(PJL2+SLOPE(PJL2,7),7)+EMA(PJL2+SLOPE(PJL2,5),5)+EMA(PJL2+SLOPE(PJL2,9),9))/3;
非2:=EMA(MH23+SLOPE(MH23,9),9);
JGL3:=100*(YC-LLV(YL,162))/(HHV(YH,162)-LLV(YL,162));
MH31:=(EMA(JGL3+SLOPE(JGL3,7),7)+EMA(JGL3+SLOPE(JGL3,5),5)+EMA(JGL3+SLOPE(JGL3,9),9))/3;
主3:=EMA(MH31+SLOPE(MH31,18),18);
SGL3:=100*(PC-LLV(PL,162))/(HHV(PH,162)-LLV(PL,162));
MH32:=(EMA(SGL3+SLOPE(SGL3,7),7)+EMA(SGL3+SLOPE(SGL3,5),5)+EMA(SGL3+SLOPE(SGL3,9),9))/3;
市3:=EMA(MH32+SLOPE(MH32,18),18);
PJL3:=100*(INDEXC-LLV(INDEXL,162))/(HHV(INDEXH,162)-LLV(INDEXL,162));
MH33:=(EMA(PJL3+SLOPE(PJL3,7),7)+EMA(PJL3+SLOPE(PJL3,5),5)+EMA(PJL3+SLOPE(PJL3,9),9))/3;
非3:=EMA(MH33+SLOPE(MH33,18),18);
JGL4:=100*(YC-LLV(YL,324))/(HHV(YH,324)-LLV(YL,324));
MH41:=(EMA(JGL4+SLOPE(JGL4,7),7)+EMA(JGL4+SLOPE(JGL4,5),5)+EMA(JGL4+SLOPE(JGL4,9),9))/3;
主4:=EMA(MH41+SLOPE(MH41,36),36);
SGL4:=100*(PC-LLV(PL,324))/(HHV(PH,324)-LLV(PL,324));
MH42:=(EMA(SGL4+SLOPE(SGL4,7),7)+EMA(SGL4+SLOPE(SGL4,5),5)+EMA(SGL4+SLOPE(SGL4,9),9))/3;
市4:=EMA(MH42+SLOPE(MH42,36),36);
PJL4:=100*(INDEXC-LLV(INDEXL,324))/(HHV(INDEXH,324)-LLV(INDEXL,324));
MH43:=(EMA(PJL4+SLOPE(PJL4,7),7)+EMA(PJL4+SLOPE(PJL4,5),5)+EMA(PJL4+SLOPE(PJL4,9),9))/3;
非4:=EMA(MH43+SLOPE(MH43,36),36);
JGL5:=100*(YC-LLV(YL,648))/(HHV(YH,648)-LLV(YL,648));
MH51:=(EMA(JGL5+SLOPE(JGL5,7),7)+EMA(JGL5+SLOPE(JGL5,5),5)+EMA(JGL5+SLOPE(JGL5,9),9))/3;
主5:=EMA(MH51+SLOPE(MH51,72),72);
SGL5:=100*(PC-LLV(PL,648))/(HHV(PH,648)-LLV(PL,648));
MH52:=(EMA(SGL5+SLOPE(SGL5,7),7)+EMA(SGL5+SLOPE(SGL5,5),5)+EMA(SGL5+SLOPE(SGL5,9),9))/3;
市5:=EMA(MH52+SLOPE(MH52,72),72);
PJL5:=100*(INDEXC-LLV(INDEXL,648))/(HHV(INDEXH,648)-LLV(INDEXL,648));
MH53:=(EMA(PJL5+SLOPE(PJL5,7),7)+EMA(PJL5+SLOPE(PJL5,5),5)+EMA(PJL5+SLOPE(PJL5,9),9))/3;
非5:=EMA(MH53+SLOPE(MH53,72),72);
个股:=(((((主0+2*主1)/3+2*主2)/3+2*主3)/3+2*主4)/3+2*主5)/3;
市场:=(((((市0+2*市1)/3+2*市2)/3+2*市3)/3+2*市4)/3+2*市5)/3;
大盘:=(((((非0+2*非1)/3+2*非2)/3+2*非3)/3+2*非4)/3+2*非5)/3;
大:=MAX(个股,MAX(市场,大盘));
小:=MIN(个股,MIN(市场,大盘));
STICKLINE(大<=20,小,20,2,0),COLORBROWN;
STICKLINE(小>=80,小,80,2,0),COLORBLUE;
个股意向:=Wma(个股+SLOPE(个股,63),63),COLORGRAY;
市场意向:=Wma(市场+SLOPE(市场,63),63),COLORGRAY;
大盘意向:=Wma(大盘+SLOPE(大盘,63),63),COLORCYAN;
STICKLINE((个股-个股意向)>0,80,80+(个股-个股意向),0,0),COLORBROWN;
STICKLINE((个股-个股意向)<0,80,80+(个股-个股意向),0,0),COLORAAAA00;
STICKLINE((市场-市场意向)>0,50,50+(市场-市场意向),0,0),COLOR00CCCC;
STICKLINE((市场-市场意向)<0,50,50+(市场-市场意向),0,0),colorFF9F99;
STICKLINE((大盘-大盘意向)>0,20,20+(大盘-大盘意向),0,0),color9999FF;
STICKLINE((大盘-大盘意向)<0,20,20+(大盘-大盘意向),0,0),COLOR006010;
先行资金:((((主0+2*主1)/3+2*主2)/3+2*主3)/3+主2)/2,COLORWHITE,linethick2;
个股资金:个股,COLORRED;
市场资金:市场,COLOR00CCCC;
指数资金:大盘,color9999FF;
意向判别:Wma(先行资金+SLOPE(先行资金,63),63),COLOR00bb00,linethick2;
STICKLINE((先行资金-意向判别)>0,110,110+(先行资金-意向判别)/2,0,0),COLORWHITE;
STICKLINE((先行资金-意向判别)<0,110,110+(先行资金-意向判别)/2,0,0),COLORGRAY;
STICKLINE((先行资金-意向判别)<0 and 先行资金>80,110,110+(先行资金-意向判别)/2,0,0),COLORFAABEC;
分配:=((先行资金-意向判别)*3+(个股-个股意向)*4+市场-市场意向+(大盘-大盘意向)*2),linethick;
共振:=IF((先行资金-意向判别)>=0,3,0)+IF((个股-个股意向)>=0,4,0)+IF((市场-市场意向)>=0,1,0)+IF((大盘-大盘意向)>=0,2,0)+IF(分配>=0,10,0),linethick;
准备区:IF(共振>=17 AND 分配>0 AND 个股>=50 AND 个股<65,65,50),COLORFAABEC,linethick2;
拉升区:IF(共振>=17 AND 分配>0 AND 个股>65,72.5,50),COLOR7F00FF,linethick2;
f0:=100*((YC-HHV(YH,18))/(HHV(YH,18)-LLV(YL,18))+(YC-HHV(YH,27))/(HHV(YH,27)-LLV(YL,27)))/2;
fH01:=(EMA(f0+SLOPE(f0,7),7)+EMA(f0+SLOPE(f0,5),5)+EMA(f0+SLOPE(f0,9),9))/3;
fk0:=(EMA(fH01+SLOPE(fH01,2),2)+EMA(fH01+SLOPE(fH01,3),3))/2;
f1:=100*((YC-HHV(YH,36))/(HHV(YH,36)-LLV(YL,36))+(YC-HHV(YH,45))/(HHV(YH,45)-LLV(YL,45)))/2;
fH11:=(EMA(f1+SLOPE(f1,7),7)+EMA(f1+SLOPE(f1,5),5)+EMA(f1+SLOPE(f1,9),9))/3;
fk1:=(EMA(fH11+SLOPE(fH11,4),4)+EMA(fH11+SLOPE(fH11,5),5))/2;
f2:=100*(YC-HHV(YH,81))/(HHV(YH,81)-LLV(YL,81));
fH21:=(EMA(f2+SLOPE(f2,7),7)+EMA(f2+SLOPE(f2,5),5)+EMA(f2+SLOPE(f2,9),9))/3;
fk2:=EMA(fH21+SLOPE(fH21,9),9);
f3:=100*(YC-HHV(YH,162))/(HHV(YH,162)-LLV(YL,162));
fH31:=(EMA(f3+SLOPE(f3,7),7)+EMA(f3+SLOPE(f3,5),5)+EMA(f3+SLOPE(f3,9),9))/3;
fk3:=EMA(fH31+SLOPE(fH31,18),18);
浮筹:-((((fk0+2*fk1)/3+2*fk2)/3+2*fk3)/3+fk2)/2,colorFF9F99,linethick2;

通达信分流资金升级版指标公式

 

相关文章