在线检测未来函数

同花顺和主力同步指标公式

来源:Internet,编辑:股旁网,2016-02-19

N1:=39;
N2:=8;
N3:=7;
N:=34;
M3:=3;
mp0:0,color00fffF;mp100:100,color0000fF;
资金1:=EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),1),POINTDOT,color00fffF;//资金1线大>50 <20 >昨天[为买],资金1线>50 下穿50线 <昨天 [为卖]
资金3:EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3),color00fffF;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND CLOSE/OPEN>1.08,0.5,0.3,0,'1日资金1线');
X1:=100*(HHV(HIGH,N1)-CLOSE)/(HHV(HIGH,N1)-LLV(LOW,N1));//X1>50>VAR1 VAR1=VAR2<昨天VAR1<昨天X1[为买]
Var1:=100*(HHV(HIGH,N2)-CLOSE)/(HHV(HIGH,N2)-LLV(LOW,N2));//VAR1>VAR2 VAR2<30,VAR2>昨天 [为调整],VAR1<VAR2 VAR2<30,VAR2>昨天[为出货]
Var2:=100*(HHV(HIGH,N3)-CLOSE)/(HHV(HIGH,N3)-LLV(LOW,N3));//VAR1=VAR2>70,<昨天VAR1(为买)
Var3:=Var1-X1;
Var4:=X1-Var1;//大于0[买]AND,昨天<=0
Var5:=EMA(EMA(CLOSE,13),13);
{
条件:=x1<REF(x1,1); 条件1:=Var1<REF(Var1,1); 条件2:=Var2<REF(Var2,1);
条件3:=Var1<=Var2; 条件4:=Var1=Var2; 条件5:=(x1=(Var1+Var2)/2);xds:=BETWEEN(VAR4,-10,10);
条件6:=x1>75; 条件7:=x1<20; 买条件:=2*(条件6 AND 条件 AND 条件1 AND 条件2);
卖条件:=x1<20 AND 条件<1 AND 条件1<1 AND 条件2<1;fgh:=CROSS(VAR4,1);
指导:=条件+条件1+条件2+条件6+条件7;
}
LOWV:=LLV(LOW,10);
HIGHV:=HHV(HIGH,13);
RSV=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
k:=EMA(RSV,3,1),LINETHICK1;
D:=SMA(K,3,1),LINETHICK1;
J:=3*K-2*D,POINTDOT;
PARTLINE(j,j>REF(j,1),RGB(255,0,150),j<REF(j,1),RGB(0,255,200),1),LINETHICK2;
PARTLINE(资金1,资金1>REF(资金1,1),RGB(250,250,0),资金1<REF(资金1,1),RGB(0,205,200),1),LINETHICK2;
J线上升:IF(J>REF(J,1),J,DRAWNULL),COLOR00FFff,LINETHICK2;
J线下降:IF(J<REF(J,1),J,DRAWNULL),COLORffFF00,LINETHICK2;
资金1上升:IF(资金1>REF(资金1,1),资金1,DRAWNULL),COLOR0000ff,LINETHICK2;
资金1下降:IF(资金1<REF(资金1,1),资金1,DRAWNULL),COLOR00fF00,LINETHICK2;
MM:=(2*CLOSE+HIGH+LOW+OPEN)/5;
mpc1:=EMA(mm,2.78)*1.028;
mpc2:=MA(OPEN,3.2)*1.028;
资金1线:=IF(资金1>REF(资金1,1),1,0);// 资金1>80 资金1<20
K大D:=IF(K>d,1,0);//K大D=1[上升趋势],{但K线不能小于昨日K线}
K大昨:=IF(K>REF(K,1),1,0);//K大昨=1 AND J大昨=1[买] 二项=0[卖]
J小KD:=IF(J<K AND J<D,1,0);//判断J线高低度
J大昨:=IF(J>REF(J,1),1,0);//J大昨=1 J线小于20 K大昨=1[买]
主力1:=EMA( (CLOSE-MA(CLOSE,7))/MA(CLOSE,7)*800,2);
主力2:=MA(主力1,2);
VAR1:=(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100;
VAR2:=(CLOSE-LLV(LOW,43))/(HHV(HIGH,43)-LLV(LOW,43))*100;
VAR3:=SMA(VAR2,2,1);
顶:=100+(-ABS(VAR1)),colorred;
股价:=SMA(VAR3,2,1);
底:=ABS(VAR1),colorgreen;
DRAWTEXT(ISNULL(REFX(&CLOSE,1)),资金1,'↖资金1'+资金1),COLOR0000FF;
DRAWTEXT(ISNULL(REFX(&CLOSE,1)),j,'↖J线'+j),COLORffffFF;
MPC12:=IF(MPC1>REF(MPC1,1),1,0);
mpckD:=IF(k>REF(k,1),1,0);
STICKLINE(mpckd>=1AND k<30AND x1<REF(x1,1),50,-20,10,1),COLOR0505ff,LINETHICK1;//红色柱框、买入
DRAWTEXT((CROSS(0,Var4)AND x1<15),50,'↖明后天卖'),color00ff00,,LINETHICK4;
asw:=资金1线=0 AND J大昨=0 AND K大昨=0 AND 主力1<主力2 AND mpckd<=0 AND REF(x1,1)<=10 AND
X1<=15 AND mpckd<=0 AND k>50AND x1>REF(x1,1);
STICKLINE(X1<=15AND 资金1线<1,125,117,8,0),color999999;//第五排白色,白色点高位要变盘了卖点;
STICKLINE(asw ,117,109,8,0),color009900;//浅绿色[有蓝色小卖、无蓝色、有绿色为大卖]
STICKLINE(mpckd<=0 AND mpckD=0,15,7.5,8,0),COLOR09ff00,LINETHICK2;//第一排绿色;
STICKLINE(Var4>0AND mpc12>0,7.5,0,8,0),colorf000ff,LINETHICK1;//第二排的粉红色,粉红色点持股点;
STICKLINE(X1<=10,-7.5,-0,8,0),colorff0000,LINETHICK2;//第三排蓝色,蓝色点加白色点为卖;
STICKLINE(X1<REF(X1,1),-7.5,-15,8,0),color0000FF,LINETHICK2;//第四排的红色,红色点加粉红色点加黄色点为持股点;
STICKLINE(VAR4>=0AND k>REF(k,1)AND k<35,-17,-25,8,0),color00fffF,LINETHICK2;//第五排的黄色,黄色点加红色点为买;
卖号:=mpckd<=0 AND mpckD=0;卖号1:=X1<=10 AND asw;
STICKLINE(卖号 AND REF(卖号,1)=0 AND 卖号1,50,100,6,1),colorff000F,LINETHICK4;
VARF:=TROUGHBARS(3,15,1)<1;
VAR11:=IF(VARF=1,50,0);
EE:=FILTER(VARF=1,5);
STICKLINE(EE>=1,125,117,8,0),coloryellow;//↖明天买
DRAWTEXT(FILTER(VARF=1,3),116,'↖明天买'),coloryellow,低位;
控盘:=(Var5-REF(Var5,1))/REF(Var1,1)*500,colorffcccc;
控盘1:=REF(控盘,1); 控盘2:=IF(CROSS(控盘1,控盘),4,0)AND(D-K)>2;
bb13:=ATAN(EMA(VR,3)-REF(EMA(VR,3),1))*3.1416*10;

同花顺和主力同步指标公式

 

相关文章