在线检测未来函数

通达信筹码阻力支撑主图指标公式

来源:Internet,编辑:股旁网,2016-02-19

DA1:=IF(130>TOTALBARSCOUNT,TOTALBARSCOUNT,130);
DA:=IF(CURRBARSCOUNT>DA1,0,DA1);
HI:=REFDATE(HHV(H,DA),DATE);
LO:=REFDATE(LLV(L,DA),DATE);
C1:=IF(CURRBARSCOUNT<=DA,C,DRAWNULL);
GZ:=EXP(LN(HI/LO)/10);
LH1:=SUM(IF(C1>=(HI/GZ),V,0),DA);
LH2:=SUM(IF(C1>=(HI/POW(GZ,2)) AND C1<(HI/GZ),V,0),DA);
LH3:=SUM(IF(C1>=(HI/POW(GZ,3)) AND C1<(HI/POW(GZ,2)),V,0),DA);
LH4:=SUM(IF(C1>=(HI/POW(GZ,4)) AND C1<(HI/POW(GZ,3)),V,0),DA);
LH5:=SUM(IF(C1>=(HI/POW(GZ,5)) AND C1<(HI/POW(GZ,4)),V,0),DA);
LH6:=SUM(IF(C1>=(HI/POW(GZ,6)) AND C1<(HI/POW(GZ,5)),V,0),DA);
LH7:=SUM(IF(C1>=(HI/POW(GZ,7)) AND C1<(HI/POW(GZ,6)),V,0),DA);
LH8:=SUM(IF(C1>=(HI/POW(GZ,8)) AND C1<(HI/POW(GZ,7)),V,0),DA);
LH9:=SUM(IF(C1>=(LO*GZ) AND C1<LO*POW(GZ,2),V,0),DA);
LH10:=SUM(IF(C1>=LO AND C1<LO*GZ,V,0),DA);
L1:=REFDATE(HHV(LH1,DA),DATE),LINETHICK0;
L2:=REFDATE(HHV(LH2,DA),DATE),LINETHICK0;
L3:=REFDATE(HHV(LH3,DA),DATE),LINETHICK0;
L4:=REFDATE(HHV(LH4,DA),DATE);
L5:=REFDATE(HHV(LH5,DA),DATE);
L6:=REFDATE(HHV(LH6,DA),DATE);
L7:=REFDATE(HHV(LH7,DA),DATE);
L8:=REFDATE(HHV(LH8,DA),DATE);
L9:=REFDATE(HHV(LH9,DA),DATE);
L10:=REFDATE(HHV(LH10,DA),DATE);
SS:=(L1+L2+L3+L4+L5+L6+L7+L8+L9+L10);
STICKLINE(CEILING(DA*L1/SS)*3>=CURRBARSCOUNT,HI*99/100,HI/GZ,9,0)COLOR3C3C3A;
STICKLINE(CEILING(DA*L2/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,1)*99/100,HI/POW(GZ,2),9,0)COLOR3C3C3A;
STICKLINE(CEILING(DA*L3/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,2)*99/100,HI/POW(GZ,3),9,0)COLOR3C3C3A;
STICKLINE(CEILING(DA*L4/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,3)*99/100,HI/POW(GZ,4),9,0)COLOR3C3C3A;
STICKLINE(CEILING(DA*L5/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,4)*99/100,HI/POW(GZ,5),9,0)COLOR3C3C3A;
STICKLINE(CEILING(DA*L6/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,5)*99/100,HI/POW(GZ,6),9,0)COLOR3C3C3A;
STICKLINE(CEILING(DA*L7/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,6)*99/100,HI/POW(GZ,7),9,0)COLOR3C3C3A;
STICKLINE(CEILING(DA*L8/SS)*3>=CURRBARSCOUNT,LO*POW(GZ,2),LO*POW(GZ,3)*99/100,9,0)COLOR3C3C3A;
STICKLINE(CEILING(DA*L9/SS)*3>=CURRBARSCOUNT,LO*POW(GZ,1),LO*POW(GZ,2)*99/100,9,0)COLOR3C3C3A;
STICKLINE(CEILING(DA*L10/SS)*3>=CURRBARSCOUNT,LO,LO*POW(GZ,1)*99/100,9,0)COLOR3C3C3A;
ZDZ1501:=MAX(L1,MAX(L2,MAX(L3,MAX(L4,MAX(L5,MAX(L6,MAX(L7,MAX(L8,MAX(L9,L10)))))))));
STICKLINE(CEILING(DA*IF(ZDZ1501=L1,L1,IF(ZDZ1501=L2,L2,
IF(ZDZ1501=L3,L3,IF(ZDZ1501=L4,L4,IF(ZDZ1501=L5,L5,IF(ZDZ1501=L6,L6,IF(ZDZ1501=L7,L7,IF(ZDZ1501=L8,L8,
IF(ZDZ1501=L9,L9,IF(ZDZ1501=L10,L10,DRAWNULL))))))))))/SS)*3>=CURRBARSCOUNT,
IF(ZDZ1501=L1,HI*99/100,IF(ZDZ1501=L2,HI/POW(GZ,1)*99/100,
IF(ZDZ1501=L3,HI/POW(GZ,2)*99/100,IF(ZDZ1501=L4,HI/POW(GZ,3)*99/100,
IF(ZDZ1501=L5,HI/POW(GZ,4)*99/100,IF(ZDZ1501=L6,HI/POW(GZ,5)*99/100,IF(ZDZ1501=L7,HI/POW(GZ,6)*99/100,IF(ZDZ1501=L8,LO*POW(GZ,2),
IF(ZDZ1501=L9,LO*POW(GZ,1),IF(ZDZ1501=L10,L10,DRAWNULL)))))))))),
IF(ZDZ1501=L1,HI/GZ,IF(ZDZ1501=L2,HI/POW(GZ,2)*99/100,
IF(ZDZ1501=L3,HI/POW(GZ,3)*99/100,IF(ZDZ1501=L4,HI/POW(GZ,4)*99/100,
IF(ZDZ1501=L5,HI/POW(GZ,5)*99/100,IF(ZDZ1501=L6,HI/POW(GZ,6)*99/100,IF(ZDZ1501=L7,HI/POW(GZ,7)*99/100,IF(ZDZ1501=L8,LO*POW(GZ,3)*99/100,
IF(ZDZ1501=L9,LO*POW(GZ,2)*99/100,IF(ZDZ1501=L10,LO*POW(GZ,1)*99/100,DRAWNULL)))))))))),
9,0)COLOR666666;
DRAWKLINE(H,O,L,C);
HB:=COST(99.99);
LB:=COST(0.01);
B3:=(HB-LB)/50;
B31:=HB-B3;
B32:=HB-2*B3;
B33:=HB-3*B3;
B34:=HB-4*B3;
B35:=HB-5*B3;
B36:=HB-6*B3;
B37:=HB-7*B3;
B38:=HB-8*B3;
B39:=HB-9*B3;
B310:=HB-10*B3;
B311:=HB-11*B3;
B312:=HB-12*B3;
B313:=HB-13*B3;
B314:=HB-14*B3;
B315:=HB-15*B3;
B316:=HB-16*B3;
B317:=HB-17*B3;
B318:=HB-18*B3;
B319:=HB-19*B3;
B320:=HB-20*B3;
B321:=HB-21*B3;
B322:=HB-22*B3;
B323:=HB-23*B3;
B324:=HB-24*B3;
B325:=HB-25*B3;
B326:=HB-26*B3;
B327:=HB-27*B3;
B328:=HB-28*B3;
B329:=HB-29*B3;
B330:=HB-30*B3;
B331:=HB-31*B3;
B332:=HB-32*B3;
B333:=HB-33*B3;
B334:=HB-34*B3;
B335:=HB-35*B3;
B336:=HB-36*B3;
B337:=HB-37*B3;
B338:=HB-38*B3;
B339:=HB-39*B3;
B340:=HB-40*B3;
B341:=HB-41*B3;
B342:=HB-42*B3;
B343:=HB-43*B3;
B344:=HB-44*B3;
B345:=HB-45*B3;
B346:=HB-46*B3;
B347:=HB-47*B3;
B348:=HB-48*B3;
B349:=HB-49*B3;
B350:=HB-50*B3;
AMY1:=WINNER(HB)*100-WINNER(B31)*100;
AMY2:=WINNER(B31)*100-WINNER(B32)*100;
AMY3:=WINNER(B32)*100-WINNER(B33)*100;
AMY4:=WINNER(B33)*100-WINNER(B34)*100;
AMY5:=WINNER(B34)*100-WINNER(B35)*100;
AMY6:=WINNER(B35)*100-WINNER(B36)*100;
AMY7:=WINNER(B36)*100-WINNER(B37)*100;
AMY8:=WINNER(B37)*100-WINNER(B38)*100;
AMY9:=WINNER(B38)*100-WINNER(B39)*100;
AMY10:=WINNER(B39)*100-WINNER(B310)*100;
AMY11:=WINNER(B310)*100-WINNER(B311)*100;
AMY12:=WINNER(B311)*100-WINNER(B312)*100;
AMY13:=WINNER(B312)*100-WINNER(B313)*100;
AMY14:=WINNER(B313)*100-WINNER(B314)*100;
AMY15:=WINNER(B314)*100-WINNER(B315)*100;
AMY16:=WINNER(B315)*100-WINNER(B316)*100;
AMY17:=WINNER(B316)*100-WINNER(B317)*100;
AMY18:=WINNER(B317)*100-WINNER(B318)*100;
AMY19:=WINNER(B318)*100-WINNER(B319)*100;
AMY20:=WINNER(B319)*100-WINNER(B320)*100;
AMY21:=WINNER(B320)*100-WINNER(B321)*100;
AMY22:=WINNER(B321)*100-WINNER(B322)*100;
AMY23:=WINNER(B322)*100-WINNER(B323)*100;
AMY24:=WINNER(B323)*100-WINNER(B324)*100;
AMY25:=WINNER(B324)*100-WINNER(B325)*100;
AMY26:=WINNER(B325)*100-WINNER(B326)*100;
AMY27:=WINNER(B326)*100-WINNER(B327)*100;
AMY28:=WINNER(B327)*100-WINNER(B328)*100;
AMY29:=WINNER(B328)*100-WINNER(B329)*100;
AMY30:=WINNER(B329)*100-WINNER(B330)*100;
AMY31:=WINNER(B330)*100-WINNER(B331)*100;
AMY32:=WINNER(B331)*100-WINNER(B332)*100;
AMY33:=WINNER(B332)*100-WINNER(B333)*100;
AMY34:=WINNER(B333)*100-WINNER(B334)*100;
AMY35:=WINNER(B334)*100-WINNER(B335)*100;
AMY36:=WINNER(B335)*100-WINNER(B336)*100;
AMY37:=WINNER(B336)*100-WINNER(B337)*100;
AMY38:=WINNER(B337)*100-WINNER(B338)*100;
AMY39:=WINNER(B338)*100-WINNER(B339)*100;
AMY40:=WINNER(B339)*100-WINNER(B340)*100;
AMY41:=WINNER(B340)*100-WINNER(B341)*100;
AMY42:=WINNER(B341)*100-WINNER(B342)*100;
AMY43:=WINNER(B342)*100-WINNER(B343)*100;
AMY44:=WINNER(B343)*100-WINNER(B344)*100;
AMY45:=WINNER(B344)*100-WINNER(B345)*100;
AMY46:=WINNER(B345)*100-WINNER(B346)*100;
AMY47:=WINNER(B346)*100-WINNER(B347)*100;
AMY48:=WINNER(B347)*100-WINNER(B348)*100;
AMY49:=WINNER(B348)*100-WINNER(B349)*100;
AMY50:=WINNER(B349)*100-WINNER(LB)*100;
DJG:=MAX(AMY1,MAX(AMY2,MAX(AMY3,MAX(AMY4,MAX(AMY5,MAX(AMY6,MAX(AMY7,MAX(AMY8,MAX(AMY9,MAX(AMY10,
MAX(AMY11,MAX(AMY12,MAX(AMY13,MAX(AMY14,MAX(AMY15,AMY16)))))))))))))));
XJG:=MAX(AMY17,MAX(AMY18,MAX(AMY19,MAX(AMY20,
MAX(AMY21,MAX(AMY22,MAX(AMY23,MAX(AMY24,MAX(AMY25,MAX(AMY26,MAX(AMY27,MAX(AMY28,MAX(AMY29,MAX(AMY30,
MAX(AMY31,MAX(AMY32,MAX(AMY33,MAX(AMY34,AMY35))))))))))))))))));
SH:=MAX(AMY36,MAX(AMY37,MAX(AMY38,MAX(AMY39,MAX(AMY40,
MAX(AMY41,MAX(AMY42,MAX(AMY43,MAX(AMY44,MAX(AMY45,MAX(AMY46,MAX(AMY47,MAX(AMY48,MAX(AMY49,AMY50))))))))))))));
STICKLINE((AMY1=DJG OR AMY2=DJG OR AMY3=DJG OR AMY4=DJG OR AMY5=DJG OR AMY6=DJG OR AMY7=DJG OR AMY8=DJG OR AMY9=DJG
OR AMY10=DJG OR AMY11=DJG OR AMY12=DJG OR AMY13=DJG OR AMY14=DJG OR AMY15=DJG OR AMY16=DJG) AND ISLASTBAR ,
IF(AMY1=DJG,B31, IF( AMY2=DJG,B32, IF( AMY3=DJG,B33 ,IF( AMY4=DJG,B34, IF( AMY5=DJG ,B35,IF (AMY6=DJG ,B36,IF( AMY7=DJG,B37,IF( AMY8=DJG ,B38,IF( AMY9=DJG
,B39,IF( AMY10=DJG,B310,IF( AMY11=DJG,B311,IF(AMY12=DJG,B312,IF( AMY13=DJG,B313,IF ( AMY14=DJG,B314, IF( AMY15=DJG ,B315,IF( AMY16=DJG,B316,DRAWNULL)
))))))))))))))),
IF(AMY1=DJG,B31, IF( AMY2=DJG,B32, IF( AMY3=DJG,B33 ,IF( AMY4=DJG,B34, IF( AMY5=DJG ,B35,IF (AMY6=DJG ,B36,IF( AMY7=DJG,B37,IF( AMY8=DJG ,B38,IF( AMY9=DJG
,B39,IF( AMY10=DJG,B310,IF( AMY11=DJG,B311,IF(AMY12=DJG,B312,IF( AMY13=DJG,B313,IF ( AMY14=DJG,B314, IF( AMY15=DJG ,B315,IF( AMY16=DJG,B316,DRAWNULL)
))))))))))))))),
DJG*100,-1),COLORYELLOW;
STICKLINE((AMY17=XJG OR AMY18=XJG OR AMY19=XJG OR AMY20=XJG OR AMY21=XJG OR AMY22=XJG OR AMY23=XJG OR AMY24=XJG OR AMY25=XJG
OR AMY35=XJG OR AMY34=XJG OR AMY33=XJG OR AMY32=XJG OR AMY31=XJG OR AMY30=XJG OR AMY29=XJG OR AMY28=XJG OR AMY27=XJG OR AMY26=XJG
) AND ISLASTBAR ,
IF(AMY17=XJG,B317, IF( AMY18=XJG,B318, IF( AMY19=XJG,B319 ,IF( AMY20=XJG,B320, IF( AMY21=XJG ,B321,IF (AMY22=XJG ,B322,IF( AMY23=XJG,B323,IF(AMY24=XJG ,B324,IF(AMY25=XJG
,B325,IF( AMY26=XJG,B326,IF( AMY27=XJG,B327,IF(AMY28=XJG,B328,IF(AMY29=XJG,B329,IF (AMY30=XJG,B330, IF(AMY31=XJG ,B331,IF(AMY32=XJG,B332,
IF(AMY33=XJG,B333,IF(AMY34=XJG,B334,IF(AMY35=XJG,B335,
DRAWNULL))))))))))))))))))),
IF(AMY17=XJG,B317, IF( AMY18=XJG,B318, IF( AMY19=XJG,B319 ,IF( AMY20=XJG,B320, IF( AMY21=XJG ,B321,IF (AMY22=XJG ,B322,IF( AMY23=XJG,B323,IF(AMY24=XJG ,B324,IF(AMY25=XJG
,B325,IF( AMY26=XJG,B326,IF( AMY27=XJG,B327,IF(AMY28=XJG,B328,IF(AMY29=XJG,B329,IF (AMY30=XJG,B330, IF(AMY31=XJG ,B331,IF(AMY32=XJG,B332,
IF(AMY33=XJG,B333,IF(AMY34=XJG,B334,IF(AMY35=XJG,B335,
DRAWNULL))))))))))))))))))),
XJG*100,-1),COLORYELLOW;
STICKLINE((AMY36=SH OR AMY37=SH OR AMY38=SH OR AMY39=SH OR AMY40=SH OR AMY41=SH OR AMY42=SH OR AMY43=SH OR AMY44=SH OR AMY45=SH
OR AMY46=SH OR AMY47=SH OR AMY48=SH OR AMY49=SH OR AMY50=SH ) AND ISLASTBAR,
IF(AMY36=SH,B336, IF( AMY37=SH,B337, IF( AMY38=SH,B338 ,IF( AMY39=SH,B339, IF( AMY40=SH ,B340,IF (AMY41=SH ,B341,IF( AMY42=SH,B342,IF(AMY43=SH ,B343,IF(AMY44=SH
,B344,IF( AMY45=SH,B345,IF( AMY46=SH,B346,IF(AMY47=SH,B347,IF(AMY48=SH,B348,IF (AMY49=SH,B349, IF(AMY50=SH ,B350,
DRAWNULL))))))))))))))),
IF(AMY36=SH,B336, IF( AMY37=SH,B337, IF( AMY38=SH,B338 ,IF( AMY39=SH,B339, IF( AMY40=SH ,B340,IF (AMY41=SH ,B341,IF( AMY42=SH,B342,IF(AMY43=SH ,B343,IF(AMY44=SH
,B344,IF( AMY45=SH,B345,IF( AMY46=SH,B346,IF(AMY47=SH,B347,IF(AMY48=SH,B348,IF (AMY49=SH,B349, IF(AMY50=SH ,B350,
DRAWNULL))))))))))))))),
SH*100,-1),COLORYELLOW;
DRAWNUMBER(ISLASTBAR,
IF(AMY1=DJG,B31, IF( AMY2=DJG,B32, IF( AMY3=DJG,B33 ,IF( AMY4=DJG,B34, IF( AMY5=DJG ,B35,IF (AMY6=DJG ,B36,IF( AMY7=DJG,B37,IF( AMY8=DJG ,B38,IF( AMY9=DJG
,B39,IF( AMY10=DJG,B310,IF( AMY11=DJG,B311,IF(AMY12=DJG,B312,IF( AMY13=DJG,B313,IF ( AMY14=DJG,B314, IF( AMY15=DJG ,B315,IF( AMY16=DJG,B316,DRAWNULL)
))))))))))))))),
DJG*1);
DRAWNUMBER(ISLASTBAR,
IF(AMY17=XJG,B317, IF( AMY18=XJG,B318, IF( AMY19=XJG,B319 ,IF( AMY20=XJG,B320, IF( AMY21=XJG ,B321,IF (AMY22=XJG ,B322,IF( AMY23=XJG,B323,IF(AMY24=XJG ,B324,IF(AMY25=XJG
,B325,IF( AMY26=XJG,B326,IF( AMY27=XJG,B327,IF(AMY28=XJG,B328,IF(AMY29=XJG,B329,IF (AMY30=XJG,B330, IF(AMY31=XJG ,B331,IF(AMY32=XJG,B332,
IF(AMY33=XJG,B333,IF(AMY34=XJG,B334,IF(AMY35=XJG,B335,
DRAWNULL))))))))))))))))))),
XJG*1);
DRAWNUMBER(ISLASTBAR,
IF(AMY36=SH,B336, IF( AMY37=SH,B337, IF( AMY38=SH,B338 ,IF( AMY39=SH,B339, IF( AMY40=SH ,B340,IF (AMY41=SH ,B341,IF( AMY42=SH,B342,IF(AMY43=SH ,B343,IF(AMY44=SH
,B344,IF( AMY45=SH,B345,IF( AMY46=SH,B346,IF(AMY47=SH,B347,IF(AMY48=SH,B348,IF (AMY49=SH,B349, IF(AMY50=SH ,B350,
DRAWNULL))))))))))))))),
SH*1);

通达信筹码阻力支撑主图指标公式

 

相关文章