在线检测未来函数

通达信四量齐红及选股指标公式

来源:Internet,编辑:股旁网,2016-02-22

时间:DATE+1900/00/00,NODRAW ,COLORWHITE;
MID1:=(3*CLOSE+LOW+OPEN+HIGH)/6;
牛线:=(20*MID1+19*REF(MID1,1)+18*REF(MID1,2)+17*REF(MID1,3)+16*REF(MID1,4)+15*REF(MID1,5)+14*REF(MID1,6)+13*REF(MID1,7)+12*REF(MID1,8)+11*REF(MID1,9)+10*REF(MID1,10)+9*REF(MID1,11)+8*REF(MID1,12)+7*REF(MID1,13)+6*REF(MID1,14)+5*REF(MID1,15)+4*REF(MID1,16)+3*REF(MID1,17)+2*REF(MID1,18)+REF(MID1,20))/210,COLORGREEN{COLORRED};
马线:=MA(牛线,3),COLORMAGENTA{COLORYELLOW};
GB:=(C-牛线);
换手:=V*100/CAPITAL;
主:=MA(换手,5);
大:=MA(换手,12);
中:=MA(换手,34);
散:=MA(换手,55);
均:=(主+大+中+散)/4;
GBB:=(主-散);
GB1:=GB+GBB;
STICKLINE(GB1>=0,5,-5,4,0),COLOR000099{COLOR017700},LINETHICK2;
STICKLINE(GB1<0,5,-5,4,0),COLOR017700{COLOR000099},LINETHICK2;
DRAWTEXT(ISLASTBAR=1,IF(V>=0,5,5),'散户'),COLORWHITE;
AA:=MAX(MA(C,60),MA(C,120));
BB:=MIN(MA(C,60),MA(C,120));
成交量:=V,COLORWHITE,LINETHICK0;
Q:=EMA(V,5);
Q1A:=EMA(V,50);
OBVA:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0);
OBV1:=EMA(OBVA,5);
OBV2:=EMA(OBVA,50);
WA:=(Q-Q1A)*0.00001;
W1:=(OBV1-OBV2)*0.000001;
W2:=WA+W1;
STICKLINE(W2>=0,-10,-20,4,0),COLOR000099{COLOR017700},LINETHICK2;
STICKLINE(W2<0,-10,-20,4,0),COLOR017700{COLOR000099},LINETHICK2;
DRAWTEXT(ISLASTBAR=1,IF(V>=0,-10,-10),'游资'),COLORWHITE;
{R:=0;}
E:=MAX(MA(C,45),MA(C,90));
FF:=MIN(MA(C,45),MA(C,90));
C1A:=10000*CLOSE/INDEXC;
O1:=10000*OPEN/INDEXO;
H1:=10000*HIGH/INDEXH;
L1:=10000*LOW/INDEXL;
LL:=IF(L1<C1A AND L1<O1,L1,MIN(C1A,O1));
HH:=IF(H1>C1A AND H1>O1,H1,MAX(C1A,O1));
A:=EMA(C1A,5);
B:=EMA(C1A,12);
DA:=EMA(C1A,30);
XX:=EMA(C1A,35);
F:=EMA(C1A,7);
均量:=(A+B+DA)/3;
VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
OBV11:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
MAOBV:=MA(OBV11,30);
MTR:=EMA(EMA(EMA(CLOSE,12),12),12);
TRIX:=(MTR-REF(MTR,1))/REF(MTR,1)*100;
MATRIX:=MA(TRIX,9) ;
MIDA:=CLOSE-MIN(REF(CLOSE,1),LOW);
MIDB:=IF(CLOSE<REF(CLOSE,1),CLOSE-MAX(REF(CLOSE,1),HIGH),0);
WAD:=SUM(IF(CLOSE>REF(CLOSE,1),MIDA,MIDB),0);
MAWAD:=MA(WAD,30);
JB:=(OBV11-MAOBV)*0.000001+(A-XX);
机构:=A-XX;
STICKLINE(机构>=0,-25,-35,4,0),COLOR000099{COLOR017700},LINETHICK2;
STICKLINE(机构<0,-25,-35,4,0),COLOR017700{COLOR000099},LINETHICK2;
DRAWTEXT(ISLASTBAR=1,IF(V>=0,-25,-25),'机构'),COLORWHITE;
JA:=MAX(MA(C,30),MA(C,60));
KA:=MIN(MA(C,30),MA(C,60));
MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
DKX:=(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+
16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+
13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+
10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+
7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+
4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210;
MADKX:=MA(DKX,6);
MDD:=(DKX-MADKX)*1.2;
V1:=(C*2+H+L)/4*10;
V2:=EMA(V1,6)-EMA(V1,55);
V3:=EMA(V2,6);
V4:=2*(V2-V3)*5.5;
V5:=(V2-V3)*0.06;
V6:=MDD+V5;
STICKLINE(V6>=0,-40,-50,4,0),COLOR000099{COLOR017700},LINETHICK2;
STICKLINE(V6<0,-40,-50,4,0),COLOR017700{COLOR000099},LINETHICK2;
DRAWTEXT(ISLASTBAR=1,IF(V>=0,-40,-40),'主力'),COLORWHITE;
BQIUV:(GB1),COLORWHITE,NODRAW;
BQIUSV:(W2),COLORYELLOW,NODRAW;
WWV:(A-XX),COLORBLUE,NODRAW;
XEV:(V6),COLORGREEN,NODRAW;

{选股公式:}
MID1:=(3*CLOSE+LOW+OPEN+HIGH)/6;
牛线:=(20*MID1+19*REF(MID1,1)+18*REF(MID1,2)+17*REF(MID1,3)+16*REF(MID1,4)+15*REF(MID1,5)+14*REF(MID1,6)+13*REF(MID1,7)+12*REF(MID1,8)+11*REF(MID1,9)+10*REF(MID1,10)+9*REF(MID1,11)+8*REF(MID1,12)+7*REF(MID1,13)+6*REF(MID1,14)+5*REF(MID1,15)+4*REF(MID1,16)+3*REF(MID1,17)+2*REF(MID1,18)+REF(MID1,20))/210,COLORGREEN{COLORRED};
马线:=MA(牛线,3),COLORMAGENTA{COLORYELLOW};
GB:=(C-牛线);
换手:=V*100/CAPITAL;
主:=MA(换手,5);
大:=MA(换手,12);
中:=MA(换手,34);
散:=MA(换手,55);
均:=(主+大+中+散)/4;
GBB:=(主-散);
GB1:=GB+GBB;
AA:=MAX(MA(C,60),MA(C,120));
BB:=MIN(MA(C,60),MA(C,120));
成交量:=V,COLORWHITE,LINETHICK0;
Q:=EMA(V,5);
Q1:=EMA(V,50);
OBV:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0);
OBV1:=EMA(OBV,5);
OBV2:=EMA(OBV,50);
W:=(Q-Q1)*0.00001;
W1:=(OBV1-OBV2)*0.000001;
W2:=W+W1;
{R:=0;}
E:=MAX(MA(C,45),MA(C,90));
FF:=MIN(MA(C,45),MA(C,90));
C1:=10000*CLOSE/INDEXC;
O1:=10000*OPEN/INDEXO;
H1:=10000*HIGH/INDEXH;
L1:=10000*LOW/INDEXL;
LL:=IF(L1<C1 AND L1<O1,L1,MIN(C1,O1));
HH:=IF(H1>C1 AND H1>O1,H1,MAX(C1,O1));
A:=EMA(C1,5);
B:=EMA(C1,12);
D:=EMA(C1,30);
XX:=EMA(C1,35);
F:=EMA(C1,7);
均量:=(A+B+D)/3;
VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
OBV11:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
MAOBV:=MA(OBV11,30);
MTR:=EMA(EMA(EMA(CLOSE,12),12),12);
TRIX:=(MTR-REF(MTR,1))/REF(MTR,1)*100;
MATRIX:=MA(TRIX,9) ;
MIDA:=CLOSE-MIN(REF(CLOSE,1),LOW);
MIDB:=IF(CLOSE<REF(CLOSE,1),CLOSE-MAX(REF(CLOSE,1),HIGH),0);
WAD:=SUM(IF(CLOSE>REF(CLOSE,1),MIDA,MIDB),0);
MAWAD:=MA(WAD,30);
JB:=(OBV11-MAOBV)*0.000001+(A-XX);
机构:=A-XX;
J:=MAX(MA(C,30),MA(C,60));
K:=MIN(MA(C,30),MA(C,60));
MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
DKX:=(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+
16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+
13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+
10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+
7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+
4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210;
MADKX:=MA(DKX,5);
MDD:=(DKX-MADKX)*1.2;
V1:=(C*2+H+L)/4*10;
V2:=EMA(V1,6)-EMA(V1,55);
V3:=EMA(V2,6);
V4:=2*(V2-V3)*5.5;
V5:=(V2-V3)*0.06;
V6:=MDD+V5;
BQIUV:=(GB1);
BQIUSV:=(W2);
WWV:=(A-XX);
XEV:=(V6);
SH:=CROSS(BQIUV,0);
YZ:=CROSS(BQIUSV,0);
JG:=CROSS(WWV,0);
ZL:=CROSS(XEV,0);
买:=SH AND BQIUSV>=0 AND WWV>=0 AND XEV>=0 OR YZ AND BQIUV>=0 AND WWV>=0 AND XEV>=0 OR JG AND BQIUSV>=0 AND BQIUV>=0 AND XEV>=0 OR ZL AND BQIUSV>=0 AND WWV>=0 AND BQIUV>=0;
买A:SH AND BQIUSV>=0 AND WWV>=0 AND XEV>=0 OR YZ AND BQIUV>=0 AND WWV>=0 AND XEV>=0 OR JG AND BQIUSV>=0 AND BQIUV>=0 AND XEV>=0 OR ZL AND BQIUSV>=0 AND WWV>=0 AND BQIUV>=0 AND DYNAINFO(8)>1 AND EXIST(C/REF(C,1)>1.056,90);

通达信四量齐红及选股指标公式

 

相关文章