在线检测未来函数

通达信非常漂亮的3DMACD指标公式

来源:Internet,编辑:股旁网,2016-02-22

SHORT:=12,NODRAW;
LONG:=26,NODRAW;
MID:=9,NODRAW;
DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:EMA(DIF,MID);
MACD:(DIF-DEA)*2,COLORSTICK;
每股公积金:FINANCE(18),NODRAW,COLORYELLOW;
PE动:DYNAINFO(39),NODRAW,COLORCYAN;
量比:IF(BARSCOUNT(C)=CURRBARSCOUNT,DYNAINFO(17),V/REF(MA(V,5),1)),LINETHICK0,COLORYELLOW;
换手:VOL/CAPITAL*100,NODRAW,COLORYELLOW;
五日均换手:MA(换手,5),NODRAW,COLORYELLOW;
十日均换手:MA(换手,10)NODRAW,COLORYELLOW;
STICKLINE(MACD>0 AND MACD>=REF(MACD,1),0,MACD,3,0),COLOR000045;
STICKLINE(MACD>0 AND MACD>=REF(MACD,1),0,MACD,2.5,0),COLOR000065;
STICKLINE(MACD>0 AND MACD>=REF(MACD,1),0,MACD,1.5,0),COLOR0000A5;
STICKLINE(MACD>0 AND MACD>=REF(MACD,1),0,MACD,1,0),COLOR0000C5;
STICKLINE(MACD>0 AND MACD>=REF(MACD,1),0,MACD,0.5,0),COLOR0000E5;
STICKLINE(MACD>0 AND MACD>=REF(MACD,1),0,MACD,0,0),COLOR0000F5;
STICKLINE(MACD>0 AND MACD>=REF(MACD,1),0,MACD,0,0),COLOR0000F5;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),0,MACD,0,0),COLORFF5500;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),0,MACD,3.1,0),COLORFF6600;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),0,MACD,2.4,0),COLORFF7700;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),0,MACD,2.0,0),COLORFF8800;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),0,MACD,1.6,0),COLORFF9900;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),0,MACD,1.2,0),COLORFFAA00;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),0,MACD,0.6,0),COLORFFCC00;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),0,MACD,0.1,0),COLORFFFF00;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),0,MACD,0,0),COLORFF5500;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),0,MACD,3.1,0),COLORFF6600;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),0,MACD,2.4,0),COLORFF7700;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),0,MACD,2.0,0),COLORFF8800;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),0,MACD,1.6,0),COLORFF9900;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),0,MACD,1.2,0),COLORFFAA00;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),0,MACD,0.6,0),COLORFFCC00;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),0,MACD,0.1,0),COLORFFFF00;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,0,0),COLOR7D7DFF;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,0,0),COLOR7D7DFF;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,3.1,0),COLOR1313FF;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,2.4,0),COLOR2424FF;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,2.0,0),COLOR2D2DFF;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,1.6,0),COLOR4444FF;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,1.2,0),COLOR5757FF;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,0.6,0),COLOR6666FF;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,0.1,0),COLOR7D7DFF;
DRAWICON(CROSS(DIF,DEA),DIF*0.0,25);
DRAWICON(CROSS(DEA,DIF),DEA*0.0,24);

通达信非常漂亮的3DMACD指标公式

 

相关文章