在线检测未来函数

通达信富力提示对比指标公式

来源:Internet,编辑:股旁网,2016-02-26

DIFF:=WMA(CLOSE,12)-WMA(CLOSE,26);
DEA:=WMA(DIFF,9);
MACD:2*(DIFF-DEA),LINETHICK0;
Q:=2.5;
SZ:=MACD>REF(MACD,1);
STICKLINE(SZ,0,MACD*1*Q,1.0.05,0),COLOR8F8F5F;
XD:=MACD<REF(MACD,1);
STICKLINE(XD,0,MACD*1*Q,1.0.05,1),COLORFF2400;
M:=7;
N:=11;
VAR1:=EMA(SLOPE(C,21)+C,34);
VAR5:=EMA(C,2);
VAR9:=VAR5-VAR1;
ZJC:=VAR9;
ZJH:=IF(C>O,(H-C)/(C-L)*(C-L)+ZJC,(H-C)/(O-L)*(O-L)+ZJC);
ZJO:=IF(C>O,ZJH-(H-O)/(C-L)*(C-L),ZJH-(H-O)/(O-L)*(O-L));
ZJL:=IF(C>O,ZJH-(H-L)/(H-O)*(H-O),ZJH-(H-L)/(H-C)*(H-C));
STICKLINE(C> O,ZJH,ZJL,0.01,0),COLORFF66FF;
STICKLINE(C> O,ZJC,ZJO,2.1,0),COLORAA00AA;
STICKLINE(C> O,ZJC,ZJO,1.9,0),COLORCC11CC;
STICKLINE(C> O,ZJC,ZJO,1.6,0),COLORFF22FF;
STICKLINE(C> O,ZJC,ZJO,1.2,0),COLORFF44FF;
STICKLINE(C> O,ZJC,ZJO,0.7,0),COLORFF66FF;
STICKLINE(C> O,ZJC,ZJO,0.2,0),COLORFF99FF;
STICKLINE(C<=O OR C<REF(C,1),ZJH,ZJL,0.01,0),COLORGREEN;
STICKLINE(C<=O OR C<REF(C,1),ZJO,ZJC,2.1,0),COLOR005500;
STICKLINE(C<=O OR C<REF(C,1),ZJO,ZJC,1.9,0),COLOR007700;
STICKLINE(C<=O OR C<REF(C,1),ZJO,ZJC,1.6,0),COLOR009900;
STICKLINE(C<=O OR C<REF(C,1),ZJO,ZJC,1.2,0),COLOR00BB00;
STICKLINE(C<=O OR C<REF(C,1),ZJO,ZJC,0.7,0),COLOR00DD00;
STICKLINE(C<=O OR C<REF(C,1),ZJO,ZJC,0.2,0),COLOR44FF00;
ZTB:=(C-REF(C,1))/REF(C,1)*100>9.91&&(C-REF(C,1))/REF(C,1)*100<10.6;
STICKLINE(C=H,ZJH,ZJL,0.0,0),COLORYELLOW;
STICKLINE(ZTB,ZJC,ZJO,2.1,0),COLOR006666;
STICKLINE(ZTB,ZJC,ZJO,1.9,0),COLOR008888;
STICKLINE(ZTB,ZJC,ZJO,1.6,0),COLOR00AAAA;
STICKLINE(ZTB,ZJC,ZJO,1.2,0),COLOR00CCCC;
STICKLINE(ZTB,ZJC,ZJO,0.7,0),COLOR00EEEE;
STICKLINE(ZTB,ZJC,ZJO,0.2,0),COLOR33FFFF;
DTB:=(C-REF(C,1))/REF(C,1)*100<-9.9&&(C-REF(C,1))/REF(C,1)*100>-10.6;
STICKLINE(DTB,ZJO,ZJC,2.1,0),COLORFF0000;{蓝色}
STICKLINE(DTB,ZJO,ZJC,1.9,0),COLORFF2200;
STICKLINE(DTB,ZJO,ZJC,1.6,0),COLORFF4400;
STICKLINE(DTB,ZJO,ZJC,1.2,0),COLORFF6600;
STICKLINE(DTB,ZJO,ZJC,0.7,0),COLORFF8800;
STICKLINE(DTB,ZJO,ZJC,0.2,0),COLORFFAA00;
DRAWTEXT_FIX(1,0,0.07,0,'A:0轴以上,与主图相比,阴K线若高收,后市下跌。'),COLORFFFFFF;
DRAWTEXT_FIX(1,0,0.13,0,'B:0轴以上,与主图相比,阳K线若下挫,后市下跌。'),COLORFFFFFF;
DRAWTEXT_FIX(1,0,0.19,0,'C:0轴以上,股价创新高但MACD柱状线缩短,后市下调或下跌。'),COLORFFFFFF;
DRAWTEXT_FIX(1,0,0.25,0,'D:0轴以下,与主图相比,阴K线若上移,后市上涨。'),COLORFFFFFF;
DRAWTEXT_FIX(1,0,0.31,0,'E:0轴以下,与主图相比,阳K线若下移,后市上涨。'),COLORFFFFFF;
DRAWTEXT_FIX(1,0,0.37,0,'F:0轴以下,股价创新低但MACD柱状线缩短或翻红,后市上涨。'),COLORFFFFFF;
套牢盘%:=100*(1-WINNER(C));
获利盘%:=100*WINNER(C);
集中度90%:=(COST(95)-COST(5))/(COST(100))*100;
集中度70%:=(COST(85)-COST(15))/(COST(100))*100;
平均成本:=COST(50);
主力成本:=COST(4);
短期压力:=HHV(H,20);
短期支撑:=LLV(L,20);
PQ:=REF(HIGH,1)-REF(LOW,1);
中价:=(H+L+C)/3;
近高:=2*中价-LOW;
近低:=2*中价-HIGH;
最高:=中价+PQ;
最低:=中价-PQ;
DRAWTEXT_FIX(ISLASTBAR,0.8,0.05,0, '【富力动态读盘提示】'),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR,0.8,0.1,0,'套牢盘%----'),COLORLIRED;
DRAWNUMBER_FIX(ISLASTBAR,0.9,0.1,0,套牢盘%),COLOR9F9F5F;
DRAWTEXT_FIX(ISLASTBAR,0.8,0.15,0,'获利盘%----'),COLORLIRED;
DRAWNUMBER_FIX(ISLASTBAR,0.9,0.15,0,获利盘%),COLOR9F9F5F;
DRAWTEXT_FIX(ISLASTBAR,0.8,0.2,0,'集中度90%--'),COLORRED;
DRAWNUMBER_FIX(ISLASTBAR,0.9,0.2,0,集中度90%),COLOR9F9F5F;
DRAWTEXT_FIX(ISLASTBAR,0.8,0.25,0,'集中度70%--'),COLORRED;
DRAWNUMBER_FIX(ISLASTBAR,0.9,0.25,0,集中度70%),COLOR9F9F5F;
DRAWTEXT_FIX(ISLASTBAR,0.8,0.3,0,'平均成本----'),COLORLIRED;
DRAWNUMBER_FIX(ISLASTBAR,0.9,0.3,0,平均成本),COLOR9F9F5F;
DRAWTEXT_FIX(ISLASTBAR,0.8,0.35,0,'主力成本----'),COLORLIRED;
DRAWNUMBER_FIX(ISLASTBAR,0.9,0.35,0,主力成本),COLOR9F9F5F;
DRAWTEXT_FIX(ISLASTBAR,0.8,0.4,0,'短期压力----'),COLORLIRED;
DRAWNUMBER_FIX(ISLASTBAR,0.9,0.4,0,短期压力),COLOR9F9F5F;
DRAWTEXT_FIX(ISLASTBAR,0.8,0.45,0,'短期支撑----'),COLORLIRED;
DRAWNUMBER_FIX(ISLASTBAR,0.9,0.45,0,短期支撑),COLOR9F9F5F;
DRAWTEXT_FIX(ISLASTBAR,0.8,0.5,0,'中价--------'),COLORLIRED;
DRAWNUMBER_FIX(ISLASTBAR,0.9,0.5,0,中价),COLOR9F9F5F;
DRAWTEXT_FIX(ISLASTBAR,0.8,0.55,0,'近高--------'),COLORLIRED;
DRAWNUMBER_FIX(ISLASTBAR,0.9,0.55,0,近高),COLOR9F9F5F;
DRAWTEXT_FIX(ISLASTBAR,0.8,0.6,0,'近低--------'),COLORLIRED;
DRAWNUMBER_FIX(ISLASTBAR,0.9,0.6,0,近低),COLOR9F9F5F;
DRAWTEXT_FIX(ISLASTBAR,0.8,0.65,0,'最高--------'),COLORLIRED;
DRAWNUMBER_FIX(ISLASTBAR,0.9,0.65,0,最高),COLOR9F9F5F;
DRAWTEXT_FIX(ISLASTBAR,0.8,0.7,0,'最低--------'),COLORLIRED;
DRAWNUMBER_FIX(ISLASTBAR,0.9,0.7,0,最低),COLOR9F9F5F;

通达信富力提示对比指标公式

 

相关文章