在线检测未来函数

飞狐黄金主图指标公式

来源:Internet,编辑:股旁网,2016-03-01

input:N1(5,1,100),N2(13,1,100),N3(21,1,100),N4(30,1,100);
A00:=(DATE < 20341231);
A01:=DYNAINFO(7);
A02:=MA(((AMOUNT / VOL) / 100),(VOL / CAPITAL));
A03:=BARSCOUNT(CLOSE);
A04:=(SMA((CLOSE / HHV(HIGH,120)),3,1) * 100);
A05:=IF((A03 > 20),A04,0);
A06:=IF(((LOW > A01) AND A00),0,IF(((HIGH < A01) AND A00),1,(((A01 - LOW) + 0.01) / ((HIGH - LOW) + 0.01))));
A07:=(DMA(A06,(VOL / CAPITAL)) * 100);
A08:=IF((A02 > A01),(100 - A07),A07);
A09:=IF(((((A07 > 0) AND (A07 > REF(A07,1))) AND A00) AND (A05 <= 88)),A07,0);
FILLRGN((A09 > 0),LOW,(LOW * 1.1)),colorFF99FF;
黄金线选股:IF(((CROSS(A09,0.01) AND (OPEN <> LOW)) AND (CLOSE <> LOW)),888,0),LINETHICK0,colorFF00FF;
机构黄金线:LOW,LINETHICK2,colorFFFF;
A0D:DRAWTEXT(CROSS(A09,0.01),LOW,'-----注意'),colorFF00;
DRAWICON(CROSS(A09,0.01),LOW,1);
EXPLAINICON(CROSS(A09,0.01),4);
EXPLAIN(CROSS(A09,0.009),'请密切注意了!\n彩虹在眼前!!\n有机构在开始吸筹了!!\n如出现信号后首次带量上攻是最佳的买点!!'),colorFF;
EXPLAIN((CLOSE > 0),'用法说明如下'),colorFF00;
EXPLAIN((CLOSE > 0),'1:如出现股价在下跌!\n2:机构黄金线在不断上升!\n3:出现红色区域!\n4:说明有主流资金在打他的主意。\n5:有主流资金在低位不断买入!\n6:注意了!\n 等股价出现止跌信号,买入!\n7:(若本股基本面恶化或属老庄股出货.请放弃操作,安全第一!)'),colorFFFFFF;
M1:MA(CLOSE,N1);
M2:MA(CLOSE,N2);
M3:MA(CLOSE,N3);
M4:MA(CLOSE,N4);
MA1:=MA(CLOSE,3);
MA2:=MA(CLOSE,5);
MA3:=MA(CLOSE,10);
MS3:=REF(CLOSE,2);
MC3:=(CLOSE - REF(CLOSE,2));
JC3:=((MA(CLOSE,3) - REF(MA(CLOSE,3),1)) * 3);
YS3:=(CLOSE - ((MA(CLOSE,3) - REF(MA(CLOSE,3),1)) * 3));
MS1:=REF(CLOSE,9);
MC1:=(CLOSE - REF(CLOSE,9));
JC1:=((MA(CLOSE,10) - REF(MA(CLOSE,10),1)) * 10);
YS1:=(CLOSE - ((MA(CLOSE,10) - REF(MA(CLOSE,10),1)) * 10));
MS:REF(CLOSE,4),LINETHICK0,colorFF00;
MC:(CLOSE - REF(CLOSE,4)),LINETHICK0,colorFF00;
JC:((MA(CLOSE,5) - REF(MA(CLOSE,5),1)) * 5),LINETHICK0,colorFFFF00;
YS:(CLOSE - ((MA(CLOSE,5) - REF(MA(CLOSE,5),1)) * 5)),LINETHICK0,colorFFFFFF;
DRAWNUMBER((BARSCOUNT(CLOSE) = SYSPARAM(1)),CLOSE,REF(CLOSE,4),2),ALIGN4,colorFFFF;
DRAWNUMBER((BARSCOUNT(CLOSE) = SYSPARAM(1)),CLOSE,(CLOSE - REF(CLOSE,4)),2),ALIGN3,colorFFFF;
DRAWNUMBER((BARSCOUNT(CLOSE) = SYSPARAM(1)),CLOSE,(CLOSE - ((MA(CLOSE,5) - REF(MA(CLOSE,5),1)) * 5)),2),ALIGN5,colorFFFFFF;
DRAWTEXT((BARSCOUNT(CLOSE) = SYSPARAM(1)),CLOSE,' ←明收'),ALIGN4,colorFFFF;
DRAWTEXT((BARSCOUNT(CLOSE) = SYSPARAM(1)),CLOSE,' ←明差'),ALIGN3,colorFFFF;
DRAWTEXT((BARSCOUNT(CLOSE) = SYSPARAM(1)),CLOSE,' ←应收'),ALIGN5,colorFFFFFF;
ZD:=(CLOSE - REF(CLOSE,1));
ZF:=(((CLOSE / REF(CLOSE,1)) * 100) - 100);
EXPLAINEX(1,(('明日均线:(最新)' + NUMTOSTR(CLOSE,2)) + ' 幅:'),ZF,2,0);
EXPLAINEX(1,(((('三:今 ' + NUMTOSTR(YS3,2)) + ' 明 ') + NUMTOSTR(MS3,2)) + ' 超 '),((MC3 / MS3) * 100),2,0),colorFFFFFF;
EXPLAINEX(1,(((('五:今 ' + NUMTOSTR(YS,2)) + ' 明 ') + NUMTOSTR(MS,2)) + ' 超 '),((MC / MS) * 100),2,0),colorFFFF;
EXPLAINEX(1,(((('十:今 ' + NUMTOSTR(YS1,2)) + ' 明 ') + NUMTOSTR(MS1,2)) + ' 超 '),((MC1 / MS1) * 100),2,1),colorFF00;
三日:=(MA1 - REF(MA1,1));
五日:=(MA2 - REF(MA2,1));
十日:=(MA1 - REF(MA3,1));
EXPLAINEX((三日 > 0),(((('三:前 ' + NUMTOSTR(REF(MA1,2),2)) + ' 昨 ') + NUMTOSTR(REF(MA1,1),2)) + ' 今 ↑'),MA1,2,0),colorFF;
EXPLAINEX((三日 < 0),(((('三:前 ' + NUMTOSTR(REF(MA1,2),2)) + ' 昨 ') + NUMTOSTR(REF(MA1,1),2)) + ' 今 ↓'),MA1,2,0),color3300CC;
EXPLAINEX((五日 > 0),(((('五:前 ' + NUMTOSTR(REF(MA2,2),2)) + ' 昨 ') + NUMTOSTR(REF(MA2,1),2)) + ' 今 ↑'),MA2,2,0),colorFFFFFF;
EXPLAINEX((五日 < 0),(((('五:前 ' + NUMTOSTR(REF(MA2,2),2)) + ' 昨 ') + NUMTOSTR(REF(MA2,1),2)) + ' 今 ↓'),MA2,2,0),colorAAAAAA;
EXPLAINEX((十日 > 0),(((('十:前 ' + NUMTOSTR(REF(MA3,2),2)) + ' 昨 ') + NUMTOSTR(REF(MA3,1),2)) + ' 今 ↑'),MA3,2,1),colorFF00;
EXPLAINEX((十日 < 0),(((('十:前 ' + NUMTOSTR(REF(MA3,2),2)) + ' 昨 ') + NUMTOSTR(REF(MA3,1),2)) + ' 今 ↓'),MA3,2,1),colorAA00;
PT:=(REF(HIGH,1) - REF(LOW,1));
DP:=(((REF(HIGH,1) + REF(LOW,1)) + (REF(CLOSE,1) * 2)) / 4);
AH:=(DP + PT);
NH:=((DP * 2) - REF(LOW,1));
CDP:=DP;
NL:=((DP * 2) - REF(HIGH,1));
AL:=(DP - PT);
EXPLAIN((1 = 1),'-------------------------'),colorFF;
EXPLAIN((1 = 1),'盘后预测 实时参考'),colorFFFF;
EXPLAINEX((1 = 1),'最高: ',AH,2,0),colorFF;
EXPLAINEX((1 = 1),'近高: ',NH,2,0),colorFF33FF;
EXPLAINEX((1 = 1),'中间价: ',CDP,2,0);
EXPLAINEX((1 = 1),'近低: ',NL,2,0),colorFFFF00;
EXPLAINEX((1 = 1),'最低: ',AL,2,0),colorFF00;
EXPLAIN((1 = 1),'-------------------------'),colorFF;
AA:=(WINNER((CLOSE + ((CLOSE * 15) / 100))) * 100);
BB:=(WINNER((CLOSE + ((CLOSE * 0) / 100))) * 100);
CC:=(AA - BB);
DD:=((WINNER((CLOSE - ((CLOSE * 0.1) / 100))) - WINNER((CLOSE - ((CLOSE * 15) / 100)))) * 100);
EE:=(((CC < 3) AND (DD < 0.5)) AND (OPEN <> LOW));
A4:=DYNAINFO(6);
A5:=IF((LOW > A4),0,IF((HIGH < A4),1,(((A4 - LOW) + 0.01) / ((HIGH - LOW) + 0.01))));
A6:=(VOL / WINNER(LOW));
A7:=REF(HHV(CLOSE,120),1);
A8:=REF(LLV(CLOSE,120),1);
A9:=((100 * (CLOSE - A8)) / (A7 - A8));
A10:=((A5 > 0) OR (A5 = 1));
A11:=((A10 AND ((A6 / REF(A6,3)) >= 3)) AND (A9 < 80));
A12:=(((REF(A11,1) OR REF(A11,2)) OR REF(A11,3)) OR REF(A11,4));
VAR93:=(A11 AND A12);
VAR94:=IF(FILTER(A11,3),5,0);
VAR95:=IF((FILTER(VAR93,3) OR EE),10,0);
机构进场日:STICKLINE(VAR94,LOW,(LOW * 1.05),5,0),colorFF7700;
机构加仓日:STICKLINE(VAR95,LOW,(LOW * 1.1),5,0),colorFF00FF;
STICKLINE(VAR94,LOW,(LOW * 1.05),5,0),colorFF7700;
STICKLINE(VAR94,LOW,(LOW * 1.05),4.5,0),colorFF8800;
STICKLINE(VAR94,LOW,(LOW * 1.05),4,0),colorFF9900;
STICKLINE(VAR94,LOW,(LOW * 1.05),3.5,0),colorFFAA00;
STICKLINE(VAR94,LOW,(LOW * 1.05),3,0),colorFFBB00;
STICKLINE(VAR94,LOW,(LOW * 1.05),2.5,0),colorFFCC00;
STICKLINE(VAR94,LOW,(LOW * 1.05),2,0),colorFFDD00;
STICKLINE(VAR94,LOW,(LOW * 1.05),1,0),colorFFEE00;
STICKLINE(VAR95,LOW,(LOW * 1.1),4.5,0),color102099;
STICKLINE(VAR95,LOW,(LOW * 1.1),4,0),color1020AA;
STICKLINE(VAR95,LOW,(LOW * 1.1),3.5,0),color1020BB;
STICKLINE(VAR95,LOW,(LOW * 1.1),3,0),color1020CC;
STICKLINE(VAR95,LOW,(LOW * 1.1),2.5,0),color1020DD;
STICKLINE(VAR95,LOW,(LOW * 1.1),2,0),color1020EE;
STICKLINE(VAR95,LOW,(LOW * 1.1),1,0),color1020FF;
DRAWTEXT(VAR94,LOW,'进场'),colorFFFF;
DRAWTEXT(VAR95,(LOW * 1.1),'加仓'),colorFFFFFF;

飞狐黄金主图指标公式

 

相关文章