在线检测未来函数

通达信顶底分析指标公式

来源:Internet,编辑:股旁网,2016-03-01

{用法:1、趋势线,红色上升趋势,紫色下降趋势,80以上是风险区,趋势线上涨到80以上大盘短线就进入高抛区, 熊市连续3天(上面标有白色数字周期)以上进入短线极度危险区,熊市一般不会超过6个周期, 趋势性走平向下拐头做好减仓准备,死叉尤其是高位二次死叉清仓。

P1:=6;P2:=4;P3:=13;A:=(3*C+L+O+H)/6;
SSRCJL:=WMA(VOL,P3);
SSRCJE:=WMA(AMOUNT,P3);
SSRCBJX:=((SSRCJE / SSRCJL) / 100);
SSRGL:=(((A - SSRCBJX) / SSRCBJX) * 100);
短底:(SSRGL<-6),COLORWHITE,NODRAW;
中底:(SSRGL<-10),COLORYELLOW,NODRAW;
大底:(SSRGL<-14),COLORCYAN,NODRAW;
绝对底:(SSRGL<-18),COLORRED,NODRAW;
STICKLINE((SSRGL < (0 - 18)),30,40,0.51,0),COLORRED;
STICKLINE((SSRGL < (0 - 14)),20,30,0.51,0),COLORCYAN;
STICKLINE((SSRGL < (0 - 10)),10,20,0.51,0),COLORYELLOW;
STICKLINE((SSRGL < (0 - 6)),0,10,0.51,0),COLORWHITE;
风险线上高抛:80, DOTLINE,COLORGREEN;
机会线下低吸:20, DOTLINE,COLORCYAN;
VAR1:=LLV(LOW,P1);
VAR2:=HHV(HIGH,P1);
QS:=WMA((A-VAR1)/(VAR2-VAR1)*100,P2);
DRAWNUMBER(QS>=80,80,BARSLASTCOUNT(QS>=80));
VR2:=REF(LOW,1);
VR3:=SMA(ABS(LOW-VR2),3,1)/SMA(MAX(LOW-VR2,0),3,1)*100;
VR4:=EMA(VR3*10,3);
VR5:=LLV(LOW,38);
VR6:=HHV(VR4,38);
VR8:=EMA(IF(L=VR5,(VR4+VR6*2)/2,0),3)/618;
主力进场:IF(VR8>REF(VR8,1),VR8,85),COLORRED,NODRAW;
STICKLINE(VR8>REF(VR8,1),85,IF(VR8>85,0,85-VR8),0,1),COLORRED;
洗盘:IF(VR8<REF(VR8,1),VR8,0),COLORAAAAFF,NODRAW;
STICKLINE(VR8<REF(VR8,1),85,IF(VR8>85,0,85-VR8),0,1),COLORAAAAFF;
T1:=CURRBARSCOUNT<130;
AA:=WINNER(C+C*15/100)*100;
BB:=WINNER(C+C*0/100)*100;
CC:=AA-BB;
DD:=(WINNER(C-C*0.1/100)-WINNER(C-C*15/100))*100;
EE:=CC<3 AND DD<0.5 AND (O<L OR O>L);
A1:=DYNAINFO(6);
A2:=IF(L>A1,0,IF(H<A1,1,(A1-L+0.01)/(H-L+0.01)));
A3:=V/WINNER(L);
A4:=REF(HHV(C,120),1);
A5:=REF(LLV(C,120),1);
A6:=100*(C-A5)/(A4-A5);
A7:=A2>0 OR A2=1;
A8:=A7 AND A3/REF(A3,3)>=3 AND A6<80 ;
A9:=REF(A8,1) OR REF(A8,2) OR REF(A8,3) OR REF(A8,4);
A10:=A8 AND A9;
A11:=IF(FILTER(A8,3),5,0);
A12:=IF(FILTER(A10,3) OR EE,10,0);
见底:IF(A11 AND C<200,50,0),COLOR0080FF;
加仓:IF(A12 AND C<200,70,0),COLOR00FF80;
慢线: WMA(0.667*REF(QS,1)+0.333*QS,2),COLORYELLOW,LINETHICK1,DOTLINE;
GW:= REF(QS,1)>80 OR QS>80;DW:=REF(QS,1)<30 OR QS<30;
DRAWICON(CROSS(慢线,QS) AND GW, 50,2);
DRAWICON(CROSS(QS,慢线) AND DW, 50,1);
趋势线:QS ,COLORMAGENTA,LINETHICK1;
IF(QS>=REF(QS,1),QS,DRAWNULL),COLORRED,LINETHICK2;

通达信顶底分析指标公式

 

相关文章