在线检测未来函数

通达信仓位马力指标公式

来源:Internet,编辑:股旁网,2016-03-02

MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
BBI线:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
CPX40:=WMA(MID,40);
CPX30:=WMA(MID,30);
CPX20:=WMA(MID,20);
CPX15:=WMA(MID,15);
CPX10:=WMA(MID,10);
CPX5:=WMA(MID,5);
CPX3:=WMA(MID,3);
STZF:=(MAX(CLOSE,OPEN)/MIN(CLOSE,OPEN)-1)*100;
均STZF:=(SUM(STZF,21)-STZF)/20;
DYX:=CLOSE<REF(CLOSE,1) AND (100*(REF(CLOSE,1)-CLOSE)/REF(CLOSE,1)>(均STZF*2.5));
ZNCPX3:=IFF(DYX,(6*CLOSE+2*REF(MID,1)+1*REF(MID,2))/9,CPX3);
DYKX:=CLOSE>REF(CLOSE,1) AND (100*(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>(均STZF*2.5));
ZNCPX5:=IFF(DYKX,(6*CLOSE+2*REF(MID,1)+1*REF(MID,2))/9,CPX5);
CPMXK:=CPX20;
CPMXM:=CPX30;
CPKXM:=ZNCPX3;
CPKXK:=ZNCPX3;
UP:=CPX30>REF(CPX30,1);
DOWN:=CPX30<REF(CPX30,1);
CPXM:=IFF(UP,CPMXK,IFF(DOWN,CPMXM,0));
CPXK:=IFF(UP,CPKXM,IFF(DOWN,CPKXK,0));
D:=CPXK> CPXM;
K:=CPXK<=CPXM;
长:=WMA(MID,30);
中:=WMA(MID,20);
短:=WMA(MID,10);
SXX:=短>REF(短,1) AND 中<REF(中,1) AND 长<REF(长,1);
SMX:=短>REF(短,1) AND 中>REF(中,1) AND 长<REF(长,1);
SML:=短>REF(短,1) AND 中>REF(中,1) AND 长>REF(长,1);
SXL:=短>REF(短,1) AND 中<REF(中,1) AND 长>REF(长,1);
XML:=短<REF(短,1) AND 中>REF(中,1) AND 长>REF(长,1);
XXL:=短<REF(短,1) AND 中<REF(中,1) AND 长>REF(长,1);
XXX:=短<REF(短,1) AND 中<REF(中,1) AND 长<REF(长,1);
均线最大:=MAX(CPX5,MAX(CPX10,MAX(CPX20,MAX(CPX30,CPX40))));
均线最小:=MIN(CPX5,MIN(CPX10,MIN(CPX20,MIN(CPX30,CPX40))));
高缠绕度:=1000*(均线最大/均线最小-1)<27;
低缠绕度:=1000*(均线最大/均线最小-1)>=27;
投机:=IFF(BARSSINCE(C>0)>=40,10,0);
STICKLINE(投机,0,10,3.00,0),COLORBLUE,COLOR990000;
试盘:=IFF(SXX,20,0);
STICKLINE(SXX,0,20,3.00,0),COLOR990000;
加仓:=IFF(SMX AND D,40,IFF(SMX AND K,20,0));
STICKLINE(SMX AND D,0,40,3.00,0),COLORYELLOW,COLOR0088FF;
STICKLINE(SMX AND K,0,20,3.00,0),COLORBLUE,COLOR990000;
重仓:=IFF(SML AND D AND 低缠绕度,90,IFF(SML AND D AND 高缠绕度,60,IFF(SML AND K,20,0)));
STICKLINE(SML AND K ,0,20,3.00,0),COLOR990000;
STICKLINE(SML AND D AND 低缠绕度,0,90,3.00,0),COLORRED,COLOR000055;
STICKLINE(SML AND D AND 高缠绕度,0,60,3.00,0),COLORYELLOW,COLOR0088FF;
高仓:=IFF(SXL AND D AND 低缠绕度,70,IFF(SXL AND D AND 高缠绕度,40,IFF(SXL AND K,20,0)));
STICKLINE(((SXL AND K) OR (SXL AND D AND 高缠绕度)),0,20,3.00,0),COLORBLUE,COLOR990000;
STICKLINE(SXL AND D AND 低缠绕度,0,70,3.00,0),COLOR000055;
STICKLINE(SXL AND D AND 高缠绕度 ,0,40,3.00,0),COLOR0088FF;
减仓:=IFF(XML AND D,60,IFF(XML AND K,20,0));
STICKLINE(XML AND D,0,60,3.00,0),COLOR0088FF;
STICKLINE(XML AND K,0,20,3.00,0),COLOR990000;
轻仓:=IFF(XXL AND D,30,IFF(XXL AND K,20,0));
STICKLINE(XXL AND D,0,30,3.00,0),COLOR0088FF;
STICKLINE(XXL AND K,0,20,3.00,0),COLOR990000;
空仓:=IFF(XXX,0,0);
仓位1:=IFF(SML AND D AND 低缠绕度,90,IFF(SXL AND D AND 低缠绕度,70,IFF((XML AND D) OR (SML AND D AND 高缠绕度),60,IFF
((1/2)==10,50,IFF((SMX AND D) OR (SXL AND D AND 高缠绕度),40,IFF(XXL AND D,30,0))))));
仓位2:=IFF(SXX OR (SMX AND K) OR (SML AND K) OR (SXL AND K) OR
(XML AND K) OR (XXL AND K),20,10);
仓位A:=MAX(仓位1,仓位2);
配置仓位:=IFF(((REF(仓位A,1)==90) OR (REF(仓位A,1)==70)) AND (仓位A<=50 AND 仓位A>=30),60,仓位A);
STICKLINE(((REF(仓位A,1)==90) OR (REF(仓位A,1)==70)) AND (仓位A<=50 AND 仓位A>=30),0,60,3.00,0),COLOR0088FF;
修正一天:=COUNT(配置仓位>=70,2)==1 AND COUNT(配置仓位>=30 AND 配置仓位<=60,2)==1;
修正二天:=COUNT(配置仓位>=70,3)==1 AND COUNT(配置仓位>=30 AND 配置仓位<=60,3)==2;
修正三天:=COUNT(配置仓位>=70,4)==1 AND COUNT(配置仓位>=30 AND 配置仓位<=60,4)==3;
修正四天:=COUNT(配置仓位>=70,5)==1 AND COUNT(配置仓位>=30 AND 配置仓位<=60,5)==4;
修正五天:=COUNT(配置仓位>=70,6)==1 AND COUNT(配置仓位>=30 AND 配置仓位<=60,6)==5;
修正六天:=COUNT(配置仓位>=70,7)==1 AND COUNT(配置仓位>=30 AND 配置仓位<=60,7)==6;
修正七天:=COUNT(配置仓位>=70,8)==1 AND COUNT(配置仓位>=30 AND 配置仓位<=60,8)==7;
修正八天:=COUNT(配置仓位>=70,9)==1 AND COUNT(配置仓位>=30 AND 配置仓位<=60,9)==8;
修正九天:=COUNT(配置仓位>=70,10)==1 AND COUNT(配置仓位>=30 AND 配置仓位<=60,10)==9;
修正十天:=COUNT(配置仓位>=70,11)==1 AND COUNT(配置仓位>=30 AND 配置仓位<=60,11)==10;
修正十一天:=COUNT(配置仓位>=70,12)==1 AND COUNT(配置仓位>=30 AND 配置仓位<=60,12)==11;
修正十二天:=COUNT(配置仓位>=70,13)==1 AND COUNT(配置仓位>=30 AND 配置仓位<=60,13)==12;
修正十三天:=COUNT(配置仓位>=70,14)==1 AND COUNT(配置仓位>=30 AND 配置仓位<=60,14)==13;
修正条件BX:=((修正一天 AND D) OR (修正二天 AND D) OR (修正三天 AND D) OR
(修正四天 AND D) OR (修正五天 AND D) OR (修正六天 AND D) OR
(修正七天 AND D) OR (修正八天 AND D) OR (修正九天 AND D) OR
(修正十天 AND D) OR (修正十一天 AND D) OR (修正十二天 AND D) OR (修正十三天 AND D));STICKLINE(修正条件BX,0,配置仓位,3.00,0),COLOR000055;
蓝:=配置仓位<=20;
红:=(配置仓位>=70) OR 修正一天 OR 修正二天 OR 修正三天 OR 修正四天 OR 修正五天 OR 修正六天 OR
修正七天 OR 修正八天 OR 修正九天 OR 修正十天 OR 修正十一天 OR 修正十二天 OR 修正十三天;
黄:=(红==0) AND (蓝==0);
VAR1:=EMA(EMA(CLOSE,9),9);
控盘:=((VAR1-REF(VAR1,1))/REF(VAR1,1)*1000)>0;
满仓线:IFF(1,100,0),COLORRED;
STICKLINE(控盘==0 AND 红,0,配置仓位,3.00,0),COLOR0088FF;
STICKLINE(控盘==0 AND 黄,0,配置仓位,3.00,0),COLOR990000;
STICKLINE(控盘 AND 蓝,0,配置仓位,3.00,0),COLOR0088FF;
配置仓位NEW:=IFF(控盘 AND 配置仓位<=50,50,配置仓位);
仓位马力:IFF(1,配置仓位NEW,0),NODRAW;
STICKLINE(控盘 AND (加仓 OR 轻仓 OR (SXL AND D AND 高缠绕度)) AND 红==0,0,50,3.00,0),COLOR0088FF;
STICKLINE(红,0,50,3.00,0),COLOR000055;
STICKLINE(控盘==0 AND 红,0,配置仓位NEW,3.00,0),COLOR0088FF;
STICKLINE(控盘==0 AND 黄,0,配置仓位NEW,3.00,0),COLOR990000;
STICKLINE(控盘 AND 蓝,0,配置仓位NEW,3.00,0),COLOR0088FF;
黄新:=黄 OR (控盘==0 AND 红) OR (控盘 AND 蓝) OR (控盘==0 AND 仓位马力>=60);
蓝新:=蓝 OR (控盘==0 AND 黄);
红新:=红;
STICKLINE((控盘==0 AND 仓位马力>=60),0,仓位马力,3.00,0),COLOR0088FF;
修一天:=COUNT(红新,2)==1 AND COUNT(黄新,2)==1;
修二天:=COUNT(红新,3)==1 AND COUNT(黄新,3)==2;
修三天:=COUNT(红新,4)==1 AND COUNT(黄新,4)==3;
修四天:=COUNT(红新,5 )==1 AND COUNT(黄新,5 )==4;
修五天:=COUNT(红新,6 )==1 AND COUNT(黄新,6 )==5;
修六天:=COUNT(红新,7 )==1 AND COUNT(黄新,7 )==6;
修七天:=COUNT(红新,8 )==1 AND COUNT(黄新,8 )==7;
修八天:=COUNT(红新,9 )==1 AND COUNT(黄新,9 )==8;
修九天:=COUNT(红新,10)==1 AND COUNT(黄新,10)==9;
修十天:=COUNT(红新,11)==1 AND COUNT(黄新,11)==10;
修十一天:=COUNT(红新,12)==1 AND COUNT(黄新,12)==11;
修正条件AX:=
(修一天 OR 修二天 OR 修三天 OR 修四天 OR 修五天 OR
修六天 OR 修七天 OR 修八天 OR 修九天 OR 修十天 OR
修十一天);
STICKLINE(修正条件AX,0,配置仓位NEW,3.00,0),COLOR000055;

通达信仓位马力指标公式

 

相关文章