在线检测未来函数

通达信小反转主图及选股指标公式

来源:Internet,编辑:股旁网,2016-03-09

M5:MA(C,5);
M10:MA(C,10);
M20:MA(C,20);
G1:=HHVBARS(H,30);
D1:=BARSLAST(L=LLV(L,G1+1));
H1:=REF(C,G1+1);
L1:=REF(C,D1);
ZF:=(L1-H1)/H1*100;
LZF:=REF(ZF,D1);
TJ:=LZF<-10 AND G1>20 AND D1<G1;
GL:=(C-H1)/H1*100;
QD:=C/REF(C,1)>1.03 AND VOL>=REF(VOL,1)*1.8 AND VOL/REF(VOL,1)<3;
ZF3:=(C-REF(C,3))/REF(C,3)*100<15;
A:=SUM(HSL,G1)/G1>2.5;
A1:=CCI.CCI(77)>REF(CCI.CCI(77),1);
A2:=(C-REF(C,D1+1))/REF(C,D1+1)*100;
A4:=MACD.DIF=HHV(MACD.DIF,D1+1);
A5:=IF(O>=REF(MAX(C,O),1),V*0.8<REF(V,1) AND HSL<16 AND VOL/REF(VOL,1)<3.5,V>0);
A3:=EVERY(BARSLASTCOUNT(C>O OR (C=O AND C>=REF(C,1)))<6,D1);
XG:=TJ AND QD AND ZF<GL AND ZF3 AND A AND A1 AND A2<15 AND A3 AND A5 AND A4;
DRAWICON(XG,L*0.95,1);
STICKLINE(XG,C,O,2,0),COLORYELLOW;
STICKLINE(XG,H,L,0,0),COLORYELLOW;

{
选股公式:

G1:=HHVBARS(H,30);
D1:=BARSLAST(L=LLV(L,G1+1));
H1:=REF(C,G1+1);
L1:=REF(C,D1);
ZF:=(L1-H1)/H1*100;
LZF:=REF(ZF,D1);
TJ:=LZF<-10 AND G1>20 AND D1<G1;
GL:=(C-H1)/H1*100;
QD:=C/REF(C,1)>1.03 AND VOL>=REF(VOL,1)*1.8 AND VOL/REF(VOL,1)<3;
ZF3:=(C-REF(C,3))/REF(C,3)*100<15;
A:=SUM(HSL,G1)/G1>2.5;
A1:=CCI.CCI(77)>REF(CCI.CCI(77),1);
A2:=(C-REF(C,D1+1))/REF(C,D1+1)*100;
A4:=MACD.DIF=HHV(MACD.DIF,D1+1);
A5:=IF(O>=REF(MAX(C,O),1),V*0.8<REF(V,1) AND HSL<16 AND VOL/REF(VOL,1)<3.5,V>0);
A3:=EVERY(BARSLASTCOUNT(C>O OR (C=O AND C>=REF(C,1)))<6,D1);
XG:TJ AND QD AND ZF<GL AND ZF3 AND A AND A1 AND A2<15 AND A3 AND A5 AND A4;
}

通达信小反转主图及选股指标公式

 

相关文章