在线检测未来函数

飞狐草根涨幅量尺主图指标公式

来源:Internet,编辑:股旁网,2016-03-11

INPUT:XS(0,0,1),CY1(0,0,5),p2(0,0,255),df(0,0,555),BOL(0,0,999),FA(0,0,3),高H(0,0,255);
STICKLINE(C>=O,low,high,0.5,0),colorFF;
STICKLINE(C>=O,close,open,8,0),color102088;
STICKLINE(C>=O,close,open,7,0),color102099;
STICKLINE(C>=O,close,open,6,0),color1020AA;
STICKLINE(C>=O,close,open,5,0),color1020BB;
STICKLINE(C>=O,close,open,4,0),color1020CC;
STICKLINE(C>=O,close,open,3,0),color1020DD;
STICKLINE(C>=O,close,open,2,0),color1020EE;
STICKLINE(C>=O,close,open,1,0),color1020FF;
STICKLINE(C<=O,low,high,0.5,0),colorFF8800;
STICKLINE(C<=O,close,open,8,0),colorFF7700;
STICKLINE(C<=O,close,open,7,0),colorFF8800;
STICKLINE(C<=O,close,open,6,0),colorFF9900;
STICKLINE(C<=O,close,open,5,0),colorFFAA00;
STICKLINE(C<=O,close,open,4,0),colorFFBB00;
STICKLINE(C<=O,close,open,3,0),colorFFCC00;
STICKLINE(C<=O,close,open,2,0),colorFFDD00;
STICKLINE(C<=O,close,open,1,0),colorFFEE00;
TTt:=ISLASTBAR=1;
AS1:=((H-L)/L)*100;
AS2:=H-L;
MAI:=C*1.015;
MAII:=C*1.03;
DRAWTEXTEX(TTT,0,310,1,'▼明短线赢利[1.5%--3%:]'+'/'+NUMTOSTR(MAI[SYSPARAM(1)],2)+'--'+NUMTOSTR(MAII [SYSPARAM(1)],2)),Color00dd00;
DRAWTEXTEX(TTt,0,176,1,'【振幅:'+NUMTOSTR(AS1[SYSPARAM(1)],2)+'% '+NUMTOSTR(AS2[SYSPARAM(1)],2)+'元 】'+''),Colordddd00;
DRAWTEXTEX(TTT,0,1,1,'【代码:'+STKLABEL+' 名称:'+STKNAME+'】'),ColorffFFFF;DRAWTEXTEX(TTT,0,270,14,'【创于2010.11.20晚】'),ColorffFFFF;
TT1:=ISLASTBAR=1;
JJJ:=IF(DYNAINFO(8)>0.01,0.01*DYNAINFO(10)/DYNAINFO(8),DYNAINFO(3));
DDD:=(DYNAINFO(5)<0.01 || DYNAINFO(6)<0.01);
JJJT:=IF(DDD,1,(JJJ<(DYNAINFO(5)+0.01) && JJJ>(DYNAINFO(6)-0.01)));
CYC1:IF(JJJT,0.01*EMA(AMOUNT,CY1)/EMA(VOL,5),EMA((HIGH+LOW+CLOSE)/3,CY1)),COLORFFFFFF;
DRAWTEXT(TT1,CYC1,'5:'+NUMTOSTR(CYC1,2)),COLORffffff;
as:=(o+h+l+c)/4;
BLM: MA(C,p2),linethick1,Color00FF00;
BLT:=BARSTATUS=2;
DRAWTEXT(BLT AND BLM>REF(BLM,1),BLM,'↑'+NUMTOSTR(p2,0)+':'+NUMTOSTR(BLM,2)),COLORCC00CC;
DRAWTEXT(BLT AND BLM<REF(BLM,1),BLM,'↓'+NUMTOSTR(p2,0)+':'+NUMTOSTR(BLM,2)),Color00CC00;
BQ:=IF((SYSPARAM(1) = (BARSSINCE((C > 0)) + 1)),1,0);
BQ1:=(H<REF(L,1));BQ2:=(L>REF(H,1));
BQ3:=REF(L,1)-H; BQ4:=L-REF(H,1);
BQ5:=REF(L,1); BQ6:=H;
BQ7:=REF(H,1); BQ8:=L;
QZH:=IF(BQ1,BQ1,BQ2);
QZH1:=IF(BQ1,BQ5,BQ7);
QZH2:=IF(BQ1,BQ6,BQ8);
QK:=IF(C>O,C,O);
QK1:=IF(C>O,O,C);
QKA:=IF(C>O,o+(c-o)*0.65,o+(c-o)*0.35);
QKB:=IF(C>O,o+(c-o)*0.35,o+(c-o)*0.65);
STICKLINE(BQ1,QKA,QK,5.5,0),colorEE0000;
STICKLINE(BQ2,QKB,QK1,5,0),color20CEEE;
DRAWTEXT(((BQ > 0) AND Bq1),H,'↓缺口 '+'\n '+NUMTOSTR(BQ3[SYSPARAM(1)],2)+' '+'\n '+NUMTOSTR(BQ5[SYSPARAM(1)],2)+'-'+NUMTOSTR(BQ6[SYSPARAM(1)],2)+' '),colorFFFFEE,pxdn10,ALIGN2;
DRAWTEXT(((BQ > 0) AND Bq2),L,'↑缺口 '+'\n '+NUMTOSTR(BQ4[SYSPARAM(1)],2)+' '+'\n '+NUMTOSTR(BQ7[SYSPARAM(1)],2)+'-'+NUMTOSTR(BQ8[SYSPARAM(1)],2)+' '),color00FFEE,pxup20,ALIGN2;
DRAWSL(SYSPARAM(1)=BARPOS AND QZH,QZH1,0,0,0),COLOR888888;
DRAWSL(SYSPARAM(1)=BARPOS AND QZH,QZH2,0,0,0),COLOR888888;
QKD:=BQ8[DATACOUNT]; QKE:=0;
QK:=IF(BQ2,1,IF(BQ1,-1,0));
for I=DATACOUNT-1 downto 2 do begin
IF BQ8[I ]<QKD then QKD:=BQ8 [I ];
IF BQ6[I ]>QKE then QKE:=BQ6 [I ];
IF QK[I ]=1 and QKD<=BQ6[I-1] then QK [I ]:=0;
IF QK[I ]=-1 and QKE>=BQ8[I-1] then QK [I ]:=0;
end;
DRAWTEXT(QK=1,BQ8,'未补'),COLOR999999,PXUP;
DRAWTEXT(QK=-1,BQ6,'未补 '),COLOR999999,PXDN ;
BLx:EMA(as,17),color00ffFF,linethick2;
DRAWTEXT(BLT AND BLX>REF(BLX,1),BLX,'↑'+NUMTOSTR(BLX,2)),COLOR00CCCC;
DRAWTEXT(BLT AND BLX<REF(BLX,1),BLX,'↓'+NUMTOSTR(BLX,2)),Color00CCCC;
xgm:=CROSS(c,BLx);
PARTLINE(BLX<REF(BLX,1),BLX),colorff0000,linethick2;
DRAWTEXT((BQ>0) AND xgm,BLx,'上穿E17 '),pxDN6,COLORYELLOW,ALIGN1;
PARTLINE(xgm,BLx),CROSSDOT,LINETHICK1,COLOR00FFfff;
BLS: BLX+2.58*STDP(C,BOL),linethick1,Color00FFFF,LINEDOT;
BL2: BLX+1.96*STDP(C,BOL),linethick1,ColorFF00FF,LINEDOT;
BL3: BLX-1.96*STDP(C,BOL),linethick1,ColorF0FF00,LINEDOT;
BLY: BLX-2.58*STDP(c,BOL),linethick1,Color00FF00,LINEDOT;
BLT:=BARSTATUS=2;
DRAWTEXT(BLT AND BLS>REF(BLS,1),BLS,'↑:'+NUMTOSTR(BLS,2)),COLOR00ffff;
DRAWTEXT(BLT AND BLS<REF(BLS,1),BLS,'↓:'+NUMTOSTR(BLS,2)),Color4BFACE;
DRAWTEXT(BLT AND BL2>REF(BL2,1),BL2,'↑:'+NUMTOSTR(BL2,2)),COLORMAGENTA;
DRAWTEXT(BLT AND BL2<REF(BL2,1),BL2,'↓:'+NUMTOSTR(BL2,2)),ColorF29BE1;
DRAWTEXT(BLT AND BL3>REF(BL3,1),BL3,'↑:'+NUMTOSTR(BL3,2)),COLORffff00;
DRAWTEXT(BLT AND BL3<REF(BL3,1),BL3,'↓:'+NUMTOSTR(BL3,2)),ColorFAD994;
DRAWTEXT(BLT AND BLY>REF(BLY,1),BLY,'↑:'+NUMTOSTR(BLY,2)),COLOR00ff00;
DRAWTEXT(BLT AND BLY<REF(BLY,1),BLY,'↓:'+NUMTOSTR(BLY,2)),ColorB7FD91;
LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
PARTLINE(RSI1>76,H+0.02),CIRCLEDOT,LINETHICK1,COLORFFFF00;
DRAWTEXT((BQ > 0) AND RSI1>76,h,'RSI>76 '),pxup29,COLORFFFF00,ALIGN1;
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA),;
G:=IF((SYSPARAM(1) = (BARSSINCE((C > 0)) + 1)),1,0);
DRAWTEXT(((G > 0) AND CROSS(DIff,DEa) AND DIff>0),L,'MACD金叉/> 0 '),color00FFEE,pxdn20,ALIGN2;
DRAWTEXT(((G > 0) AND CROSS(DIff,DEa) AND DIff<0),L,'MACD金叉/< 0 '),color00FFEE,pxdn20,ALIGN2;
DRAWICON(CROSS(DIff,DEa),L,12),pxdn25,ALIGN0;
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
DRAWICON(CROSS(K,D) AND K>20 AND D<50,L,8);
DRAWTEXT(((G > 0) AND CROSS(k,d) AND k>20 and d<50),L,' k>20 d<50 KD金叉'),color00FFEE,pxUP15,ALIGN1;
QC:=REF(C,1);QO:=REF(O,1);QH:=REF(H,1);QL:=REF(L,1);
FUZ:=L+((H-L)/2);FUS:=O+((C-O)/2); FUSY:=C+((O-C)/2);SSFU:=(FUZ+IF(C>O,FUS,FUSY))/2;
FUZ1:=L+((H-L)*0.333);FUS1:=O+((C-O)*0.333);FUS1Y:=C+((O-C)*0.333);SSFU1:=(FUZ1+IF(C>O,FUS1,FUS1Y))/2;
FUZ2:=L+((H-L)*0.667);FUS2:=O+((C-O)*0.677);FUS2Y:=C+((O-C)*0.667);SSFU2:=(FUZ2+IF(C>O,FUS2,FUS2Y))/2;
B1:=Ql+((Qh-Ql)/2);B2:=QO+((QC-QO)/2);B3:=QC+((QO-QC)/2);
DB1:=QL+((QH-QL)*0.333);DB2:=QO+((QC-QO)*0.333);DB3:=QC+((QO-QC)*0.333);
EB1:=QL+((QH-QL)*0.667);EB2:=QO+((QC-QO)*0.667);EB3:=QC+((QO-QC)*0.667);
SYB1:=QH-((QH-QC)/2);SYB2:=QH-((QH-QO)/2);
SYB3:=IF(QC>QO,SYB1,SYB2);
XYB1:=QL+((QC-QL)/2);XYB2:=QL+((QO-QL)/2);
XYB3:=IF(QC<QO,XYB1,XYB2);
QFU:=(B1+IF(QC>QO,B2,B3))/2;
QDFU:=(DB1+IF(QC>QO,DB2,DB3))/2;
QEFU:=(EB1+IF(QC>QO,EB2,EB3))/2;
STICKLINE(C=C AND fa,SSFU2,SSFU2,4,0),COLORFFaaff,LINETHICK1;
STICKLINE(C=C AND fa,SSFU1,SSFU1,4,0),COLORFFaaff,LINETHICK1;
STICKLINE(C=C AND fa,SSFU,SSFU,5.5,0),COLOR20dFFF,LINETHICK1;
STICKLINE(C=C AND fa,IF(C>O,H-((H-C)/2),H-((H-O)/2)),IF(C>O,H-((H-C)/2),H-((H-O)/2)),1.3,0),COLORYELLOW,LINETHICK1;
STICKLINE(C=C AND fa,IF(C<O,L+((C-L)/2),L+((O-L)/2)),IF(C<O,L+((C-L)/2),L+((O-L)/2)),1.3,0),COLORYELLOW,LINETHICK1;
AJ:=AMOUNT/(VOL*100),COLORFFFFFF,LINETHICK0;
DRAWTEXT(C=C AND fa=2,AJ,'←'),COLORFF5f00;
DRAWTEXTEX(TT1 AND FA=3,0,1,30,' 前/现日振幅的1/2 【'+NUMTOSTR(QFU,2)+'】/【'+NUMTOSTR(SSFU,2)+'】'),Color00AAFF;
DRAWTEXTEX(TT1 AND FA=3,0,1,45,' 前/现日振幅的:1/3 【'+NUMTOSTR(QDFU,2)+'】/【'+NUMTOSTR(SSFU1,2)+'】'),Color00FF00;
DRAWTEXTEX(TT1 AND FA=3,0,1,60,' 前/现日振幅的:2/3 【'+NUMTOSTR(QEFU,2)+'】/【'+NUMTOSTR(SSFU2,2)+'】'),Color00FF00;
DRAWTEXTEX(TT1 AND FA=3,0,1,75,' 前上影线幅度的1/2 【'+NUMTOSTR(SYB3,2)+'】'),ColorFFFFFF;
DRAWTEXTEX(TT1 AND FA=3,0,1,90,' 前下影线幅度的1/2 【'+NUMTOSTR(XYB3,2)+'】'),ColorFFFFFF;
//INPUT:XS(1,0,2);
TA1:=BARPOS=SYSPARAM(1);
最低:=REF(L,BARSLAST(TA1));
PARTLINE(最低 AND XS,最低),LINETHICK1,COLOR008F00;
DRAWTEXT(TA1 AND XS,最低,'▲'+'('+NUMTOSTR(最低,2)),ALIGN1,color00FFdd,pxdn5;
Q:=(最低 * 1.25);
Q2:=(最低* 1.20);
Q3:=(最低* 1.18);
Q4:=(最低* 1.13);
Q5:=(最低 * 1.08);
Q6:=(最低* 1.05);
Q7:=(最低 * 1.03);
Q8:=(最低 * 1.10);
Y_1:=REF(Q,BARSLAST(TA1));
Y_2:=REF(Q2,BARSLAST(TA1));
Y_3:=REF(Q3,BARSLAST(TA1));
Y_4:=REF(Q4,BARSLAST(TA1));
Y_5:=REF(Q5,BARSLAST(TA1));
Y_6:=REF(Q6,BARSLAST(TA1));
Y_7:=REF(Q7,BARSLAST(TA1));
Y_8:=REF(Q8,BARSLAST(TA1));
PARTLINE(Y_1 and xs,Y_1),LINEDOT,Color555555;
PARTLINE(Y_2 and xs,Y_2),LINEDOT,Color005555;
PARTLINE(Y_3 and xs,Y_3),LINEDOT,Color888888;
PARTLINE(Y_4 and xs,Y_4),LINEDOT,Color005555;
PARTLINE(Y_5 and xs,Y_5),LINEDOT,Color555555;
PARTLINE(Y_6 and xs,Y_6),LINEDOT,Color005555;
PARTLINE(Y_7 and xs,Y_7),LINEDOT,Color005555;
PARTLINE(Y_8 and xs,Y_8),LINEDOT,Color551155;
DRAWTEXT(TA1 AND XS,Y_1,' 25%('+NUMTOSTR(Q,2)),COLORBBbbbb,ALIGN1,PXDN5;
DRAWTEXT(TA1 AND XS,Y_2,' 20%('+NUMTOSTR(Q2,2)),COLOR00bbbb,ALIGN1,PXUP22;
DRAWTEXT(TA1 AND XS,Y_3,' 18%('+NUMTOSTR(Q3,2)),COLOReeeeee,ALIGN1,PXDN5;
DRAWTEXT(TA1 AND XS,Y_4,' 13%('+NUMTOSTR(Q4,2)),COLOR00bbbb,ALIGN1,PXDN5;
DRAWTEXT(TA1 AND XS,Y_5,' 8%('+NUMTOSTR(Q5,2)),COLORBBbbbb,ALIGN1,PXDN5;
DRAWTEXT(TA1 AND XS,Y_6,' 5%('+NUMTOSTR(Q6,2)),COLOR00eeee,ALIGN1,PXDN5;
DRAWTEXT(TA1 AND XS,Y_7,' 3%('+NUMTOSTR(Q7,2)),COLOR00eeee,ALIGN1,PXDN5;
DRAWTEXT(TA1 AND XS,Y_8,' 10%('+NUMTOSTR(Q8,2)),COLOR0000ee,ALIGN1,PXDN5;
X1:=SYSPARAM(3);
ZGH:=ref(H,高H);
BGH:=HHV(zgH,1);
GGh:=BGH[X1],colorFF00FF;
ZDL:=ref(L,DF);
BDL:=LLV(ZDL,1);
DDL:=BDL[X1];
MHI:=GGH*0.95;
MHII:=GGH*0.92;
MHIII:=GGH*0.87;
MHRI:=GGH*0.85;
MHRII:=GGH*0.80;
MHRIII:=GGH*0.75;
GDF:=GGH-DDL;
GDFDA:=GDF/GGH*100;
GDFD:=GDF/DDL*100;
GDF1:=GGH-L;
GDF2:=GDF1/GGH*100;
GDF3:=GGH-C;
GDF4:=GDF3/ggh*100;
GDF5:=C-DDL;
GDF6:=GDF5/DDL*100;
GDF7:=H-DDL;
GDF8:=GDF7/DDL*100;
TTt:=ISLASTBAR=1;
最低:=TROUGHBARS(L,DF,1);{调整之字幅度找到低位起点}
Y_1:=SUMBARS(最低=0,1)-1; Y_2:=DATACOUNT-Y_1[DATACOUNT]; Y_3:=IF(BARPOS=Y_2,最低=0,0);
Y_4:=IF(Y_3,1,0); 控制:=BARSLAST(Y_4)+1;
低价:=REF(L,BARSLAST(最低=0));
DRAWLINE(最低=0 and DF>0,L,ISLASTBAR,低价,0),Color999999;
DRAWLINE(最低=0 and df>0,L*1.03,ISLASTBAR,低价*1.03,0),Color999999;
DRAWLINE(最低=0 and df>0,L*1.05,ISLASTBAR,低价*1.05,0),Color999999;
DRAWLINE(最低=0 and df>0,L*1.08,ISLASTBAR,低价*1.08,0),Color999999;
DRAWLINE(最低=0 and df>=2,L*1.13,ISLASTBAR,低价*1.13,0),Color999999;
DRAWLINE(最低=0 and df>=2,L*1.18,ISLASTBAR,低价*1.18,0),Color999999;
DRAWLINE(最低=0 and df>=2,L*1.25,ISLASTBAR,低价*1.25,0),Color999999;
DRAWTEXT(控制=1 and df>0,低价,NUMTOSTR(低价,2)+'[ 0%]'),ALIGN2,PXUP8,COLORWHITE;
DRAWTEXT(控制=1 and df>0,低价*1.03,'3% ['+NUMTOSTR(低价*1.03,2)+']'),ALIGN2,PXUP8,COLORWHITE;
DRAWTEXT(控制=1 and df>0,低价*1.05,'5% ['+NUMTOSTR(低价*1.05,2)+']'),ALIGN2,PXUP8,COLORWHITE;
DRAWTEXT(控制=1 and df>0,低价*1.08,'8% ['+NUMTOSTR(低价*1.08,2)+']'),ALIGN2,PXUP8,COLORWHITE;
DRAWTEXT(控制=1 and df>=2,低价*1.13,'13% ['+NUMTOSTR(低价*1.13,2)+']'),ALIGN2,PXUP8,COLORWHITE;
DRAWTEXT(控制=1 and df>=2,低价*1.18,'18% ['+NUMTOSTR(低价*1.18,2)+']'),ALIGN2,PXUP8,COLORWHITE;
DRAWTEXT(控制=1 and df>=2,低价*1.25,'25% ['+NUMTOSTR(低价*1.25,2)+']'),ALIGN2,PXUP8,COLORWHITE;
FU:=C-低价;
到当前幅度%:=FU/低价*100;
GDFT:=GGH-低价;
GDFDB:=GDFT/GGH*100;
DRAWTEXTEX(TTt,0,3,15,'【'+NUMTOSTR(低价,2)+'--到当前幅度 C:'+NUMTOSTR(到当前幅度%[SYSPARAM(1)],2)+'% 涨跌:'+NUMTOSTR(FU[SYSPARAM(1)],2)+'】'),ColorFFFF00;
DRAWTEXT(H=GGH AND 高H,Ggh,'▼'),ALIGN0,color9F9f00,pxup18;
DRAWTEXT(h=ggh AND 高H,Ggh,' '+NUMTOSTR(ggh,2)),ALIGN1,color9F9F00,pxup18;
DRAWTEXTEX(TTt AND 高H,0,5,105,'▼高-至-◇低幅度\n('+NUMTOSTR(GGH,2)+')-至-('+NUMTOSTR(低价,2)+')\('+NUMTOSTR(GDFDB,2)+'% '+NUMTOSTR(GDF1,2)+'\n▼'+'当前/-L('+NUMTOSTR(GDF2,2)+'% -'
+NUMTOSTR(GDF1,2)+':/-C('+NUMTOSTR(GDF4,2)+'% -'+NUMTOSTR(GDF3,2)+'\n [5%----8%----13%:]'+'\n '+NUMTOSTR(MHI,2)+'--'
+NUMTOSTR(MHII,2)+'--'+NUMTOSTR(MHIII,2)+'\n [15%---20%---25%:]'+'\n '+NUMTOSTR(MHRI,2)+'--'+NUMTOSTR(MHRII,2)+'--'+NUMTOSTR(MHRIII,2)),Color9F9f00;
{添加到参数精灵中
--------显示光标涨跌幅度--------
XS=1 Param#1 光标涨幅幅度;
--------显示成本均价线--------
CY1=5 Param#2 五日成本均价线;
P计算 Param#3 任意均价线;
--------显示近期涨跌幅度--------
找近期低点 Param#4 显示涨幅幅度
--------显示布林线--------
调节BOL Param#5 20--26为外轨
FA=1--3 Param#6 显示分位价及均价;
高H显示 Param#7 ▲高-至-▼低-下跌幅度;

飞狐草根涨幅量尺主图指标公式

 

相关文章