在线检测未来函数

通达信KDJ的MACD指标公式

来源:Internet,编辑:股旁网,2016-03-14

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
DIFF:EMA(J,8) - EMA(J,16),COLOR0044FF;
DEA:EMA(DIFF,5),COLOR00FF00;
DRAWBAND(DIFF,RGB(255,80,0),DEA,RGB(0,255,100));
MACD:2*(DIFF-DEA), COLORSTICK;
0,COLORFF9900,DOTLINE;
{卖}
KC:=FORCAST(((2*C+H+L)/4*0.618+C*0.382),3);
AAX:=(KC-MA(KC,9))/MA(KC,9)*100;
VAR0:=MIN(EXIST(KC,55),9);
AAX1:=EMA(AAX,VAR0)*VAR0;
AAX2:=MA(AAX1,3);
AAX3:=MA(AAX1,5);
DRAWTEXT(AAX3>10 AND AAX1<REF(AAX1,1) AND CROSS(AAX2,AAX1) ,12,'卖'),COLOR00FFFF,LINETHICK3;
DRAWTEXT(AAX3>10 AND AAX1<REF(AAX1,1) AND CROSS(AAX2,AAX1) ,15,'◆'),COLOR0000FF,LINETHICK3;
DRAWTEXT_FIX(1,0.02,0,0,'■现在KDJ的参数是:N=9,M1=3,M2=3;'),COLOR0000FF;
DRAWTEXT_FIX(1,0.02,0.1,0,'■【KDJ】的【MACD】的参数是:LONG=8,LONG=16,M=5;'),COLOR00FF00;

通达信KDJ的MACD指标公式

 

相关文章