在线检测未来函数

大智慧觉得很好的指标公式

来源:Internet,编辑:股旁网,2016-03-15

散户:EMA( (CLOSE-MA(CLOSE,20))/MA(CLOSE,20),7),linethick3;;
ma5:ma(散户,3),colorblue,linethick3;
FILLRGN(散户,0, 散户>0,rgb(255,0,0), 散户<0 ,rgb(0,55,0) );
0;
FILLRGN(散户,ma5, 散户>0 and 散户<ma5,rgb(0,0,255), 散户<0 and 散户>ma5 and 散户<0,rgb(255,255,55) );
{主力:EMA( (CLOSE-MA(CLOSE,3))/MA(CLOSE,3),2),colorstick;
主力1:EMA( (CLOSE-MA(CLOSE,3))/MA(CLOSE,3),2);
散户:EMA( (CLOSE-MA(CLOSE,20))/MA(CLOSE,20),7),linethick3;;
ma5:ma(散户,4),colorblue,linethick3;
FILLRGN(散户,主力, 散户>主力,rgb(255,0,0), 散户<主力 and 主力<0,rgb(0,55,0) );
0;
FILLRGN(散户,ma5, 散户>主力 and 散户<ma5,rgb(0,0,255), 散户<主力 and 散户>ma5 and 散户<0,rgb(255,255,55) );};
RSV:=(((CLOSE - LLV(LOW,36)) / (HHV(HIGH,36) - LLV(LOW,36))) * 100);
Y0:=SMA(RSV,7,1);
Y1:=SMA(SMA(RSV,7,1),3,1);
Y2:=(((CLOSE/COST(13))<=0.8)*10);
Y3:=SMA(Y0,7,1);
k:y0-y1,linethick0;
k1:y1-y3,linethick0;
k2:y0-y3,linethick0;
TYP := (HIGH + LOW + CLOSE)/3;
CCI14:(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),LINETHICK0;
CCI24:(TYP-MA(TYP,24))/(0.015*AVEDEV(TYP,24)),LINETHICK0;
CCI84:(TYP-MA(TYP,84))/(0.015*AVEDEV(TYP,84)),LINETHICK0;
CCI084:(TYP-MA(TYP,84))/(0.015*AVEDEV(TYP,84)),LINETHICK0;
CCI168:(TYP-MA(TYP,168))/(0.015*AVEDEV(TYP,168)),LINETHICK0;
CCI840:(TYP-MA(TYP,840))/(0.015*AVEDEV(TYP,840)),LINETHICK0;
n:=13;
cor:=SUM(IF(CLOSE>REF(CLOSE,1),(VOL/capital)*(2*c-2*o-(h-c)+(o-l)),IF(CLOSE<REF(CLOSE,1),-(VOL/capital)*(2*o-2*c+(h-o)-(c-l)),0)),0);
ROC:=(cor-REF(ma(Cor,21),n))/REF(ma(Cor,21),n)*100;
ROCMA9:=MA(ROC,8);
ROCMA3:=eMA(ROC,3);
短线:roc>rocma3 and rocma3>rocma9,LINETHICK0;
工作区:k>0 and k1>0 and k2>0 {and cci14>cci24 and cci24>cci84}, linethick0;
STICKLINE(工作区,散户,0.2,1,0),COLORyellow;
STICKLINE(短线,散户+0.02,0.15,4,0),COLORwhite;

大智慧觉得很好的指标公式

 

相关文章