在线检测未来函数

通达信四维看盘主图指标公式

来源:Internet,编辑:股旁网,2016-03-15

N1:=100;
N2:=3;
N3:=0;
N4:=1;
N5:=1;
N6:=1;
N7:=1;
N8:=1;
N9:=0;
N10:=0;
N11:=0;
N12:=3;
周期:CURRBARSCOUNT,NODRAW,COLORGREEN;
X_1:=REFX(HHV(MAX(OPEN,CLOSE),N1),周期-1);
X_2:=REFX(LLV(LOW,N1),周期-1);
X_3:=CLOSE/REF(CLOSE,1)<=1-N2/100 AND OPEN>CLOSE AND DATE<=1151101;
均五:IF(N9>0,MA(CLOSE,5),DRAWNULL),COLORWHITE;
均十:IF(N10>0,MA(CLOSE,10),DRAWNULL),COLORYELLOW;
均二十:IF(N11>0,MA(CLOSE,20),DRAWNULL),COLORMAGENTA;
X_4:=IF(N12=1,0.5,IF(N12=2,1,IF(N12=3,(-1),IF(N12=4,3,4))));
X_5:=0;
X_6:=REFX(REF(OPEN,BARSLAST(X_3 AND OPEN<X_1)),周期-1);
X_7:=REFX(REF(OPEN,BARSLAST(X_3 AND OPEN<X_1 AND OPEN>X_6)),周期-1);
X_8:=REFX(REF(OPEN,BARSLAST(X_3 AND OPEN<X_1 AND OPEN>X_7)),周期-1);
X_9:=REFX(REF(OPEN,BARSLAST(X_3 AND OPEN<X_1 AND OPEN>X_8)),周期-1);
X_10:=REFX(REF(OPEN,BARSLAST(X_3 AND OPEN<X_1 AND OPEN>X_9)),周期-1);
X_11:=REFX(REF(OPEN,BARSLAST(X_3 AND OPEN<X_1 AND OPEN>X_10)),周期-1);
X_12:=REFX(REF(OPEN,BARSLAST(X_3 AND OPEN<X_1 AND OPEN>X_11)),周期-1);
X_13:=REFX(REF(OPEN,BARSLAST(X_3 AND OPEN<X_1 AND OPEN>X_12)),周期-1);
X_14:=REFX(REF(OPEN,BARSLAST(X_3 AND OPEN<X_1 AND OPEN>X_13)),周期-1);
X_15:=REFX(BARSLAST(X_3 AND OPEN<X_1),周期-1)+1;
X_16:=REFX(BARSLAST(X_3 AND OPEN<X_1 AND OPEN>X_6),周期-1)+1;
X_17:=REFX(BARSLAST(X_3 AND OPEN<X_1 AND OPEN>X_7),周期-1)+1;
X_18:=REFX(BARSLAST(X_3 AND OPEN<X_1 AND OPEN>X_8),周期-1)+1;
X_19:=REFX(BARSLAST(X_3 AND OPEN<X_1 AND OPEN>X_9),周期-1)+1;
X_20:=REFX(BARSLAST(X_3 AND OPEN<X_1 AND OPEN>X_10),周期-1)+1;
X_21:=REFX(BARSLAST(X_3 AND OPEN<X_1 AND OPEN>X_11),周期-1)+1;
X_22:=REFX(BARSLAST(X_3 AND OPEN<X_1 AND OPEN>X_12),周期-1)+1;
X_23:=REFX(BARSLAST(X_3 AND OPEN<X_1 AND OPEN>X_13),周期-1)+1;
X_24:=IF(N3=1,1,COUNT(MAX(OPEN,CLOSE)>X_6,X_15-周期)=0);
X_25:=IF(N3=1,1,COUNT(MAX(OPEN,CLOSE)>X_7,X_16-周期)=0);
X_26:=IF(N3=1,1,COUNT(MAX(OPEN,CLOSE)>X_8,X_17-周期)=0);
X_27:=IF(N3=1,1,COUNT(MAX(OPEN,CLOSE)>X_9,X_18-周期)=0);
X_28:=IF(N3=1,1,COUNT(MAX(OPEN,CLOSE)>X_10,X_19-周期)=0);
X_29:=IF(N3=1,1,COUNT(MAX(OPEN,CLOSE)>X_11,X_20-周期)=0);
X_30:=IF(N3=1,1,COUNT(MAX(OPEN,CLOSE)>X_12,X_21-周期)=0);
X_31:=IF(N3=1,1,COUNT(MAX(OPEN,CLOSE)>X_13,X_22-周期)=0);
X_32:=IF(N3=1,1,COUNT(MAX(OPEN,CLOSE)>X_14,X_23-周期)=0);
STICKLINE(周期<X_15 AND X_24,X_6,X_6,X_4,X_5),COLORLIGREEN;
STICKLINE(周期<X_16 AND X_25,X_7,X_7,X_4,X_5),COLORLIBLUE;
STICKLINE(周期<X_17 AND X_26,X_8,X_8,X_4,X_5),COLORLIGREEN;
STICKLINE(周期<X_18 AND X_27,X_9,X_9,X_4,X_5),COLORLIBLUE;
STICKLINE(周期<X_19 AND X_28,X_10,X_10,X_4,X_5),COLORLIGREEN;
STICKLINE(周期<X_20 AND X_29,X_11,X_11,X_4,X_5),COLORLIBLUE;
STICKLINE(周期<X_21 AND X_30,X_12,X_12,X_4,X_5),COLORLIGREEN;
STICKLINE(周期<X_22 AND X_31,X_13,X_13,X_4,X_5),COLORLIBLUE;
STICKLINE(周期<X_23 AND X_32,X_14,X_14,X_4,X_5),COLORLIGREEN;
DRAWTEXT(ISLASTBAR,X_6,VAR2STR(X_6,2)),COLORLIRED;
DRAWTEXT(ISLASTBAR,X_7,VAR2STR(X_7,2)),COLORLIRED;
DRAWTEXT(ISLASTBAR,X_8,VAR2STR(X_8,2)),COLORLIRED;
DRAWTEXT(ISLASTBAR,X_9,VAR2STR(X_9,2)),COLORLIRED;
DRAWTEXT(ISLASTBAR,X_10,VAR2STR(X_10,2)),COLORLIRED;
DRAWTEXT(ISLASTBAR,X_11,VAR2STR(X_11,2)),COLORLIRED;
DRAWTEXT(ISLASTBAR,X_12,VAR2STR(X_12,2)),COLORLIRED;
DRAWTEXT(ISLASTBAR,X_13,VAR2STR(X_13,2)),COLORLIRED;
DRAWTEXT(ISLASTBAR,X_14,VAR2STR(X_14,2)),COLORLIRED;
X_33:=LOW*0.98;
A:IF(N4>0 AND X_6=OPEN AND X_3,X_33,DRAWNULL),STICK,COLORLIGREEN;
B:IF(N4>0 AND X_7=OPEN AND X_3,X_33,DRAWNULL),STICK,COLORLIBLUE;
D:IF(N4>0 AND X_8=OPEN AND X_3,X_33,DRAWNULL),STICK,COLORLIGREEN;
E:IF(N4>0 AND X_9=OPEN AND X_3,X_33,DRAWNULL),STICK,COLORLIBLUE;
F:IF(N4>0 AND X_10=OPEN AND X_3,X_33,DRAWNULL),STICK,COLORLIGREEN;
G:IF(N4>0 AND X_11=OPEN AND X_3,X_33,DRAWNULL),STICK,COLORLIBLUE;
I:IF(N4>0 AND X_12=OPEN AND X_3,X_33,DRAWNULL),STICK,COLORLIGREEN;
J:IF(N4>0 AND X_13=OPEN AND X_3,X_33,DRAWNULL),STICK,COLORLIBLUE;
K:IF(N4>0 AND X_14=OPEN AND X_3,X_33,DRAWNULL),STICK,COLORLIGREEN;
DRAWTEXT(N6>0 AND REFX(X_6=OPEN AND X_3,1),X_2,VAR2STR(X_16-X_15,0)),COLORCYAN,LINETHICK9;
DRAWTEXT(N6>0 AND REFX(X_7=OPEN AND X_3,1),X_2,VAR2STR(X_17-X_16,0)),COLORGREEN,LINETHICK9;
DRAWTEXT(N6>0 AND REFX(X_8=OPEN AND X_3,1),X_2,VAR2STR(X_18-X_17,0)),COLORCYAN,LINETHICK9;
DRAWTEXT(N6>0 AND REFX(X_9=OPEN AND X_3,1),X_2,VAR2STR(X_19-X_18,0)),COLORGREEN,LINETHICK9;
DRAWTEXT(N6>0 AND REFX(X_10=OPEN AND X_3,1),X_2,VAR2STR(X_20-X_19,0)),COLORCYAN,LINETHICK9;
DRAWTEXT(N6>0 AND REFX(X_11=OPEN AND X_3,1),X_2,VAR2STR(X_21-X_20,0)),COLORGREEN,LINETHICK9;
DRAWTEXT(N6>0 AND REFX(X_12=OPEN AND X_3,1),X_2,VAR2STR(X_22-X_21,0)),COLORCYAN,LINETHICK9;
DRAWTEXT(N6>0 AND REFX(X_13=OPEN AND X_3,1),X_2,VAR2STR(X_23-X_22,0)),COLORGREEN,LINETHICK9;
X_34:=CLOSE/REF(CLOSE,1)>=1.099 AND CLOSE=HIGH;
STICKLINE(N7>0 AND X_34,OPEN,CLOSE,(-1),0),COLORMAGENTA;
X_35:=CLOSE/REF(CLOSE,1)<=0.9 AND LOW=CLOSE;
STICKLINE(N5>0 AND X_35,OPEN,CLOSE*1.009,(-1),0),COLORLIBLUE;
DRAWTEXT(N8>0 AND X_3 AND OPEN=X_6,HIGH,VAR2STR(周期,0)),COLORGREEN,LINETHICK9;
DRAWTEXT(N8>0 AND X_3 AND OPEN=X_7,HIGH,VAR2STR(周期,0)),COLORCYAN,LINETHICK9;
DRAWTEXT(N8>0 AND X_3 AND OPEN=X_8,HIGH,VAR2STR(周期,0)),COLORGREEN,LINETHICK9;
DRAWTEXT(N8>0 AND X_3 AND OPEN=X_9,HIGH,VAR2STR(周期,0)),COLORCYAN,LINETHICK9;
DRAWTEXT(N8>0 AND X_3 AND OPEN=X_10,HIGH,VAR2STR(周期,0)),COLORGREEN,LINETHICK9;
DRAWTEXT(N8>0 AND X_3 AND OPEN=X_11,HIGH,VAR2STR(周期,0)),COLORCYAN,LINETHICK9;
DRAWTEXT(N8>0 AND X_3 AND OPEN=X_12,HIGH,VAR2STR(周期,0)),COLORGREEN,LINETHICK9;
DRAWTEXT(N8>0 AND X_3 AND OPEN=X_13,HIGH,VAR2STR(周期,0)),COLORCYAN,LINETHICK9;
DRAWTEXT(N8>0 AND X_3 AND OPEN=X_14,HIGH,VAR2STR(周期,0)),COLORGREEN,LINETHICK9;
DRAWTEXT(ISLASTBAR,X_2,VAR2STR(X_15,0)),COLORGREEN,LINETHICK9;
STICKLINE(周期<X_23,X_2,X_2,X_4,X_5),COLORLIGREEN;

通达信四维看盘主图指标公式

 

相关文章