在线检测未来函数

通达信变色双均线主图指标公式

来源:Internet,编辑:股旁网,2016-03-16

P1:=10;
P2:=20;
DRAWGBK(C>0, RGB(0,10,10),RGB(88,0,0),0,'11',0);
DRAWNUMBER(ISLASTBAR,C,C),COLORMAGENTA;
N8:=STRCAT(CON2STR(YEAR,0),' 年 ');
Y8:=STRCAT(CON2STR(MONTH,0),' 月 ');
R8:=STRCAT(CON2STR(DAY,0),' 日 ');
MAR1:=MA(CLOSE,P1);
C1:=C>=MAR1;
C2:=C<MAR1;
AA:=C1>=C2;
BB:=C2>C1;
STICKLINE(AA,C,O,3,0),COLORRED;
STICKLINE(AA,H,L,0,0),COLORRED;
STICKLINE(BB,C,O,3,0),COLOR00FF00;
STICKLINE(BB,H,L,0,0),COLOR00FF00;
STICKLINE(AA,CLOSE,OPEN,3,0),COLOR000099;
STICKLINE(AA,CLOSE,OPEN,2.2,0),COLOR0000CC;
STICKLINE(AA,CLOSE,OPEN,1.5,0),COLOR0000FF;
STICKLINE(AA,CLOSE,OPEN,0.5,0),COLORCC66FF;
STICKLINE(BB,CLOSE,OPEN,3,0),COLORFF7700;
STICKLINE(BB,CLOSE,OPEN,2.2,0),COLORFF9900;
STICKLINE(BB,CLOSE,OPEN,1.5,0),COLORFFBB00;
STICKLINE(BB,CLOSE,OPEN,0.5,0),COLORCYAN;
MAA:MAR1,COLOR00FF00,LINETHICK2;
IF(MAA>=REF(MAA,1),MAA,DRAWNULL),COLORRED,LINETHICK2;
IF(MAA<REF(MAA,1),MAA,DRAWNULL),COLORFFFFFF,LINETHICK2;
MAB:MA(CLOSE,P2),COLOR00FF00,LINETHICK2;
IF(MAB>=REF(MAB,1),MAB,DRAWNULL),COLORMAGENTA,LINETHICK2;
IF(MAB<REF(MAB,1),MAB,DRAWNULL),COLORGREEN,LINETHICK2;
SJ8:=STRCAT(STRCAT(N8,Y8), R8);
VAR2:=(2*CLOSE+HIGH+LOW)/4;
VAR3:=IF(YEAR>=2099 AND MONTH>2,0,1);
VAR4:=LLV(LOW,5);
VAR5:=HHV(HIGH,4);
VAR6:=EMA((VAR2-VAR4)/(VAR5-VAR4)*100,4)*VAR3;
VAR7:=EMA(0.667*REF(VAR6,1)+0.333* VAR6,2)*VAR3;
DRAWTEXT(CROSS(VAR6, VAR7) AND VAR6<30,L-0.05,'←低吸'),COLOR00FFFF;
DRAWTEXT(CROSS(VAR7, VAR6) AND VAR6>70,H+0.05,'←高抛'),COLOR00FFFF;
DRAWICON(CROSS(VAR6, VAR7) AND VAR6<30,L-0.05,13);
DRAWICON(CROSS(VAR7, VAR6) AND VAR6>70,H+0.05,14);
AAA:= MAA>=REF(MAA,1);{C>=MAA;}
BBB:= MAA<REF(MAA,1);{ C<MAA;}
DDD:=MAB>=REF(MAB,1);
EEE:=MAB<REF(MAB,1);
TT:=IF(ISLASTBAR,240/FROMOPEN,1);
NN:=120;
HH:=HHV(V*TT,NN);
LL:=LLV(V,NN);
最高:=CONST(HH);
最低:=CONST(LL);
最高2:=CONST(HHV(H,NN));
最低2:=CONST(LLV(L,NN));
PP:=IF((最高2*0.9-(最高2-最低2)*0.5)>CONST(LLV(L,20)),0.9,IF((最高2*0.9-(最高2-最低2)*0.5)>CONST(LLV(L,50)),0.7,0.6)),NODRAW;
RCC1:=最高2*0.9-(最高2-最低2)*PP;
最低3:=MIN(RCC1,最低2);
AA1:=最低3;
STICKLINE(AAA,AA1-0.000*AA1,AA1-0.040*AA1,4,0),COLOR0000FF;
STICKLINE(BBB,AA1-0.000*AA1,AA1-0.040*AA1,4,1),COLOR686868;
STICKLINE(EEE,AA1-0.050*AA1,AA1-0.090*AA1,4,1),COLOR686868;
STICKLINE(DDD,AA1-0.050*AA1,AA1-0.090*AA1,4,0),COLORFF00FF;
DRAWTEXT_FIX(C>0,0.5,0,0,SJ8),COLOR00FFFF;
DRAWTEXT_FIX(1,0.5,0.84,0,'★★ A-红色均线持股 ★ ★ B-粉色均线持股★★'),COLOR00FFFF;
今日保护价:(REF(C,2)+REF(C,1)+O)/3,COLOR00FFFF,NODRAW;
顶点:IF(CURRBARSCOUNT<=60,CONST(IF(ISLASTBAR=1,HHV(H,BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLORRED,DOTLINE;
低点:IF(CURRBARSCOUNT<=60,CONST(IF(ISLASTBAR=1,LLV(L,BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLORMAGENTA,DOTLINE;
STICKLINE(CCI>=200 AND H>=顶点,O,C,3,0),COLORBLUE;
STICKLINE(CCI<=100 AND L<=低点,O,C,3,0),COLORYELLOW;
DRAWTEXT(ISLASTBAR,顶点,'顶点'),COLORRED;
DRAWTEXT(ISLASTBAR,低点,'低点'),COLORMAGENTA;

通达信变色双均线主图指标公式

 

相关文章