在线检测未来函数

通达信顶底压力主图指标公式

来源:Internet,编辑:股旁网,2016-03-16

N02:=30;
高:=REFDATE(HHV(H,N02),DATE);
低:=REFDATE(LLV(L,N02),DATE);
H1:=高-(高-低)*0.191;
H2:=高-(高-低)*0.382;
H3:=高-(高-低)*0.5;
H4:=高-(高-低)*0.618;
H5:=高-(高-低)*0.809;
DRAWTEXT(CURRBARSCOUNT=1,高,'高位'),COLORRED;
DRAWTEXT(CURRBARSCOUNT=1,H1,'809'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=1,H2,'618'),COLORRED;
DRAWTEXT(CURRBARSCOUNT=1,H3,'050'),COLORLIMAGENTA;
DRAWTEXT(CURRBARSCOUNT=1,H4,'382'),COLORRED;
DRAWTEXT(CURRBARSCOUNT=1,H5,'191'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=1,低,'低位'),COLORRED;
STICKLINE(CURRBARSCOUNT=13,高,高,100,-1),COLORRED;
STICKLINE(CURRBARSCOUNT=13,H1,H1,100,-1),COLORWHITE;
STICKLINE(CURRBARSCOUNT=13,H2,H2,100,-1),COLORRED;
STICKLINE(CURRBARSCOUNT=13,H3,H3,100,-1),COLORLIMAGENTA;
STICKLINE(CURRBARSCOUNT=13,H4,H4,100,-1),COLORRED;
STICKLINE(CURRBARSCOUNT=13,H5,H5,100,-1),COLORWHITE;
STICKLINE(CURRBARSCOUNT=13,低,低,100,-1),COLORRED;
{黄金分割线结束};
N:=150;判断高低:=3;
近期顶:REFDATE(高,DATE),COLORGREEN,LINETHICK3;
最顶:=REFDATE(近期顶,DATE),NODRAW;
出:=最顶=H AND ((C-L)<(O-C) OR (O-L)<(C-O)),NODRAW;
STICKLINE(出,C,O,3,0),COLORGREEN;
STICKLINE(出,C,O,2,0),COLORGREEN;
近期底:REFDATE(低,DATE),COLORRED,LINETHICK3;
最底:=REFDATE(近期底,DATE),NODRAW;
进:=最底=L AND ((C+L)<(O+C) OR (O+L)<(C+O)),NODRAW;
STICKLINE(进,C,O,3,0),COLORRED;
STICKLINE(进,C,O,2,0),COLORRED;
T1B:=CONST(LLVBARS(LOW,20));
T1HIGH:=CONST(REF(HIGH,T1B));
CC:=CONST(CURRBARSCOUNT);
T2B:=CONST(BARSLAST(CURRBARSCOUNT>CC+T1B AND H>T1HIGH));
T2HIGH:=CONST(REF(HIGH,T2B));
T3:=CONST(BARSLAST(CURRBARSCOUNT>CC+T2B AND HIGH>T2HIGH));
T3HIGH:=CONST(REF(HIGH,T3));
必杀线:DRAWLINE(CURRBARSCOUNT=T3+1, T3HIGH, ISLASTBAR, T3HIGH, 1),COLORRED,LINETHICK3;{,LINETHICK2,COLOR0000FF;}
DRAWTEXT(ISLASTBAR, T3HIGH, '必杀线')LINETHICK1,COLOR0000FF;
MA5K:必杀线,COLORYELLOW,LINETHICK1;
STICKLINE(ISLASTBAR,HHV(C,10),HHV(C,10),218,1)COLORYELLOW;
STICKLINE(ISLASTBAR,HHV(C,10)*0.95,HHV(C,10)*0.95,218,1)COLORYELLOW;

通达信顶底压力主图指标公式

 

相关文章