在线检测未来函数

同花顺正反KDJ指标公式

来源:Internet,编辑:股旁网,2016-03-18

Z1:2.21,colorred,DOTLINE;
Z0:3,colorgray,DOTLINE;
Z2:4.33,colorlicyan,DOTLINE;
RSV=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
a=SMA(RSV,3,1);
b=SMA(a,3,1);
e=3*a-2*b;
//J1:e/8,colorlicyan;
IF(a<0) a=0;
IF(a>100) a=100;
IF(b<0) b=0;
IF(b>100) b=100;
IF(e<0) e=0;
IF(e>100) e=100;
K:=a;
D:=b;
J:=e;
S0:=(REF(K,1)/K+REF(D,1)/D+REF(J,1)/J),colormagenta;
S1:IF(S0>10,10,S0),colormagenta;
S00:=(K/REF(K,1)+D/REF(D,1)+J/REF(J,1)),coloryellow;
S2:IF(S00>10,10,S00),coloryellow;
DIFF := 10*(EMA(CLOSE,12) - EMA(CLOSE,26)),colorwhite,DOTLINE;
DEA := EMA(DIFF,9),coloryellow,DOTLINE;
S3:=S1+S2;
S4:IF(DIFF > DEA,S1+S2,DRAWNULL),colorred,DOTLINE;
S5:IF(DIFF = DEA,S1+S2,DRAWNULL),colorwhite,DOTLINE;
S6:IF(DIFF < DEA,S1+S2,DRAWNULL),colorgreen,DOTLINE;
DRAWTEXT(CROSS(S1,Z2),S3+0.8,"S"),colorgreen;
DRAWTEXT(S2-S1>=1.46,S3+1,"B"),colorred;
DRAWTEXT(CROSS(REF(S1,1),Z2)AND S2-S1>0.53,S3+2,"中"),colorcyan;
STICKLINE(S2>Z0,S2,Z0,8,0),colorred;
STICKLINE(S2<=Z0,S2,Z0,8,0),colorgreen;
DRAWICON(CROSS(S2,S1),S1,1);
DRAWICON(CROSS(S1,S2),S1,2);
DRAWTEXT(S2>4.22 AND DIFF>DEA,0,"."),colorred;
CC1:IF(CROSS(S2,S1),1,0),colorred,NODRAW;

同花顺正反KDJ指标公式

 

相关文章